summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/gettext/gettext_0.18.1.1.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-05-24 14:53:51 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-01 18:34:32 +0100
commit39e10b599021ef2abe992ee09c7c937fbe166a77 (patch)
treeab62cb19ac9b16d29cdfad679a963d4a7e5cb909 /meta/recipes-core/gettext/gettext_0.18.1.1.bb
parentcbaca4e4fcc02711cff2a5c47b7dfc1b00baa32b (diff)
downloadpoky-39e10b599021ef2abe992ee09c7c937fbe166a77.tar.gz
gettext: Update to 0.18.1.1
Add Upstream Status tags to patches (From OE-Core rev: 13fff2baf108e07eaf2d7e4c982bbdf9089c6bad) Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/gettext/gettext_0.18.1.1.bb')
-rw-r--r--meta/recipes-core/gettext/gettext_0.18.1.1.bb84
1 files changed, 84 insertions, 0 deletions
diff --git a/meta/recipes-core/gettext/gettext_0.18.1.1.bb b/meta/recipes-core/gettext/gettext_0.18.1.1.bb
new file mode 100644
index 0000000000..fe1b2662a0
--- /dev/null
+++ b/meta/recipes-core/gettext/gettext_0.18.1.1.bb
@@ -0,0 +1,84 @@
1SUMMARY = "Utilities and libraries for producing multi-lingual messages."
2DESCRIPTION = "Gettext offers to programmers, translators, and even users, a well integrated set of tools and documentation. Specifically, the GNU `gettext' utilities are a set of tools that provides a framework to help other GNU packages produce multi-lingual messages. These tools include a set of conventions about how programs should be written to support message catalogs, a directory and file naming organization for the message catalogs themselves, a runtime library supporting the retrieval of translated messages, and a few stand-alone programs to massage in various ways the sets of translatable strings, or already translated strings."
3HOMEPAGE = "http://www.gnu.org/software/gettext/gettext.html"
4SECTION = "libs"
5LICENSE = "GPLv3"
6LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
7
8PR = "r0"
9DEPENDS = "gettext-native virtual/libiconv ncurses expat"
10DEPENDS_virtclass-native = ""
11PROVIDES = "virtual/libintl virtual/gettext"
12PROVIDES_virtclass-native = ""
13CONFLICTS_${PN} = "proxy-libintl"
14SRC_URI = "${GNU_MIRROR}/gettext/gettext-${PV}.tar.gz \
15 file://wchar-uclibc.patch \
16 "
17
18SRC_URI_append_linux-uclibc = " file://gettext-error_print_progname.patch;patch=1"
19SRC_URI_append_linux-uclibceabi = " file://gettext-error_print_progname.patch;patch=1"
20
21SRC_URI[md5sum] = "3dd55b952826d2b32f51308f2f91aa89"
22SRC_URI[sha256sum] = "93ac71a7afa5b70c1b1032516663658c51e653087f42a3fc8044752c026443e9"
23
24#PARALLEL_MAKE = ""
25
26inherit autotools
27
28EXTRA_OECONF += "--without-lispdir \
29 --disable-csharp \
30 --disable-libasprintf \
31 --disable-java \
32 --disable-native-java \
33 --disable-openmp \
34 --with-included-glib \
35 --with-libncurses-prefix=${STAGING_LIBDIR}/.. \
36 --without-emacs \
37 "
38
39acpaths = '-I ${S}/gettext-runtime/m4 \
40 -I ${S}/gettext-tools/m4'
41
42
43# these lack the .x behind the .so, but shouldn't be in the -dev package
44# Otherwise you get the following results:
45# 7.4M glibc/images/ep93xx/Angstrom-console-image-glibc-ipk-2008.1-test-20080104-ep93xx.rootfs.tar.gz
46# 25M uclibc/images/ep93xx/Angstrom-console-image-uclibc-ipk-2008.1-test-20080104-ep93xx.rootfs.tar.gz
47# because gettext depends on gettext-dev, which pulls in more -dev packages:
48# 15228 KiB /ep93xx/libstdc++-dev_4.2.2-r2_ep93xx.ipk
49# 1300 KiB /ep93xx/uclibc-dev_0.9.29-r8_ep93xx.ipk
50# 140 KiB /armv4t/gettext-dev_0.14.1-r6_armv4t.ipk
51# 4 KiB /ep93xx/libgcc-s-dev_4.2.2-r2_ep93xx.ipk
52PACKAGES =+ "gettext-runtime gettext-runtime-dev gettext-runtime-doc"
53
54FILES_gettext-runtime = "${bindir}/gettext \
55 ${bindir}/ngettext \
56 ${bindir}/envsubst \
57 ${bindir}/gettext.sh \
58 ${libdir}/libasprintf.so* \
59 ${libdir}/GNU.Gettext.dll \
60 "
61FILES_gettext-runtime_append_libc-uclibc = " ${libdir}/libintl.so* \
62 ${libdir}/charset.alias \
63 "
64FILES_gettext-runtime-dev += "${libdir}/libasprintf.a \
65 ${includedir}/autosprintf.h \
66 "
67FILES_gettext-runtime-dev_append_libc-uclibc = " ${libdir}/libintl.a \
68 ${includedir}/libintl.h \
69 "
70FILES_gettext-runtime-doc = "${mandir}/man1/gettext.* \
71 ${mandir}/man1/ngettext.* \
72 ${mandir}/man1/envsubst.* \
73 ${mandir}/man1/.* \
74 ${mandir}/man3/* \
75 ${docdir}/gettext/gettext.* \
76 ${docdir}/gettext/ngettext.* \
77 ${docdir}/gettext/envsubst.* \
78 ${docdir}/gettext/*.3.html \
79 ${datadir}/gettext/ABOUT-NLS \
80 ${docdir}/gettext/csharpdoc/* \
81 ${docdir}/libasprintf/autosprintf.html \
82 ${infodir}/autosprintf.info \
83 "
84BBCLASSEXTEND = "native nativesdk"