summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/expat/expat_2.6.1.bb
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@eng.windriver.com>2024-03-04 15:20:30 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-03-05 12:24:49 +0000
commit2c0d94e4f7070db095bce43d594bc55f90777edd (patch)
tree739a101e54dad159df930df5e4e4fc09b6978be1 /meta/recipes-core/expat/expat_2.6.1.bb
parentf629e7ef1b8b6d0c209c228ed201d3c72689ffa4 (diff)
downloadpoky-2c0d94e4f7070db095bce43d594bc55f90777edd.tar.gz
expat: upgrdae 2.6.0 -> 2.6.1
ChangeLog: (https://github.com/libexpat/libexpat/blob/R_2_6_1/expat/Changes) Bug fixes: #817 Make tests independent of CPU speed, and thus more robust #828 #836 Expose billion laughs API with XML_DTD defined and XML_GE undefined, regression from 2.6.0 Other changes: #829 Hide test-only code behind new internal macro #833 Autotools: Reject expat_config.h.in defining SIZEOF_VOID_P #819 Address compiler warnings #832 #834 Version info bumped from 10:0:9 (libexpat*.so.1.9.0) to 10:1:9 (libexpat*.so.1.9.1); see https://verbump.de/ for what these numbers do Infrastructure: #818 CI: Adapt to breaking changes in clang-format (From OE-Core rev: 1808a9e60d587c705218a3328716cd24a5228dc6) Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/expat/expat_2.6.1.bb')
-rw-r--r--meta/recipes-core/expat/expat_2.6.1.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-core/expat/expat_2.6.1.bb b/meta/recipes-core/expat/expat_2.6.1.bb
new file mode 100644
index 0000000000..9bdc3b6206
--- /dev/null
+++ b/meta/recipes-core/expat/expat_2.6.1.bb
@@ -0,0 +1,33 @@
1SUMMARY = "A stream-oriented XML parser library"
2DESCRIPTION = "Expat is an XML parser library written in C. It is a stream-oriented parser in which an application registers handlers for things the parser might find in the XML document (like start tags)"
3HOMEPAGE = "https://github.com/libexpat/libexpat"
4SECTION = "libs"
5LICENSE = "MIT"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=7b3b078238d0901d3b339289117cb7fb"
8
9VERSION_TAG = "${@d.getVar('PV').replace('.', '_')}"
10
11SRC_URI = "${GITHUB_BASE_URI}/download/R_${VERSION_TAG}/expat-${PV}.tar.bz2 \
12 file://run-ptest \
13 "
14
15GITHUB_BASE_URI = "https://github.com/libexpat/libexpat/releases/"
16UPSTREAM_CHECK_REGEX = "releases/tag/R_(?P<pver>.+)"
17
18SRC_URI[sha256sum] = "4677d957c0c6cb2a3321101944574c24113b637c7ab1cf0659a27c5babc201fd"
19
20EXTRA_OECMAKE:class-native += "-DEXPAT_BUILD_DOCS=OFF"
21
22RDEPENDS:${PN}-ptest += "bash"
23
24inherit cmake lib_package ptest github-releases
25
26do_install_ptest:class-target() {
27 install -m 755 ${B}/tests/runtests* ${D}${PTEST_PATH}
28 install -m 755 ${B}/tests/benchmark/benchmark ${D}${PTEST_PATH}
29}
30
31BBCLASSEXTEND += "native nativesdk"
32
33CVE_PRODUCT = "expat libexpat"