summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/expat/expat_2.4.4.bb
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2022-01-31 12:20:28 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-02-01 07:31:18 +0000
commit8ab929b0a63050d232eda14335f64c70a9b55a2a (patch)
treeeefc17c685218af59f5d02b18fb83dcab5af5a80 /meta/recipes-core/expat/expat_2.4.4.bb
parenta8c9104ac4d621c34bd53ea93d8a4bf068fa60fa (diff)
downloadpoky-8ab929b0a63050d232eda14335f64c70a9b55a2a.tar.gz
expat: upgrade to 2.4.4
Fixes CVE-2022-23852 and CVE-2022-23990. (From OE-Core rev: 4ed96683893e7433804ccf7a4000a2dd18318ef5) Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/expat/expat_2.4.4.bb')
-rw-r--r--meta/recipes-core/expat/expat_2.4.4.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-core/expat/expat_2.4.4.bb b/meta/recipes-core/expat/expat_2.4.4.bb
new file mode 100644
index 0000000000..14080220d2
--- /dev/null
+++ b/meta/recipes-core/expat/expat_2.4.4.bb
@@ -0,0 +1,31 @@
1SUMMARY = "A stream-oriented XML parser library"
2DESCRIPTION = "Expat is an XML parser library written in C. It is a stream-oriented parser in which an application registers handlers for things the parser might find in the XML document (like start tags)"
3HOMEPAGE = "https://github.com/libexpat/libexpat"
4SECTION = "libs"
5LICENSE = "MIT"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=9e2ce3b3c4c0f2670883a23bbd7c37a9"
8
9VERSION_TAG = "${@d.getVar('PV').replace('.', '_')}"
10
11SRC_URI = "https://github.com/libexpat/libexpat/releases/download/R_${VERSION_TAG}/expat-${PV}.tar.bz2 \
12 file://run-ptest \
13 "
14
15UPSTREAM_CHECK_URI = "https://github.com/libexpat/libexpat/releases/"
16
17SRC_URI[sha256sum] = "14c58c2a0b5b8b31836514dfab41bd191836db7aa7b84ae5c47bc0327a20d64a"
18
19EXTRA_OECMAKE:class-native += "-DEXPAT_BUILD_DOCS=OFF"
20
21RDEPENDS:${PN}-ptest += "bash"
22
23inherit cmake lib_package ptest
24
25do_install_ptest:class-target() {
26 install -m 755 ${B}/tests/* ${D}${PTEST_PATH}
27}
28
29BBCLASSEXTEND += "native nativesdk"
30
31CVE_PRODUCT = "expat libexpat"