summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/eglibc/eglibc_2.13.bb
diff options
context:
space:
mode:
authorLianhao Lu <lianhao.lu@intel.com>2011-07-29 22:26:42 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-08-15 15:26:17 +0100
commitfb2dfe7ac8e70d2969ebe14995900217e54716f6 (patch)
treefb5d68f641ca6d06d40e59217ea4d3bd000256db /meta/recipes-core/eglibc/eglibc_2.13.bb
parent375cf1561c0c9356a629495256423b44ddced9b6 (diff)
downloadpoky-fb2dfe7ac8e70d2969ebe14995900217e54716f6.tar.gz
eglibc: Modify ldd script according to multilib config.
Bug fixing [YOCTO #1236]. 1. Collect all the values for RTLDLIST for the current multilib configuration to modify the ldd scripts. 2. Collect all the values for KNOWN_INTERPRETER_NAMES for the current multilib configuration. Set the correct ld.so names for ldconfig to deal with the multilib configuration. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/eglibc/eglibc_2.13.bb')
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.13.bb13
1 files changed, 12 insertions, 1 deletions
diff --git a/meta/recipes-core/eglibc/eglibc_2.13.bb b/meta/recipes-core/eglibc/eglibc_2.13.bb
index 915eb32a8a..f3824485fa 100644
--- a/meta/recipes-core/eglibc/eglibc_2.13.bb
+++ b/meta/recipes-core/eglibc/eglibc_2.13.bb
@@ -3,7 +3,7 @@ require eglibc.inc
3SRCREV = "14157" 3SRCREV = "14157"
4 4
5DEPENDS += "gperf-native" 5DEPENDS += "gperf-native"
6PR = "r12" 6PR = "r13"
7PR_append = "+svnr${SRCPV}" 7PR_append = "+svnr${SRCPV}"
8 8
9EGLIBC_BRANCH="eglibc-2_13" 9EGLIBC_BRANCH="eglibc-2_13"
@@ -18,6 +18,7 @@ SRC_URI = "svn://www.eglibc.org/svn/branches/;module=${EGLIBC_BRANCH};proto=http
18 file://generate-supported.mk \ 18 file://generate-supported.mk \
19 file://glibc_bug_fix_12454.patch \ 19 file://glibc_bug_fix_12454.patch \
20 file://ppc-sqrt.patch \ 20 file://ppc-sqrt.patch \
21 file://multilib_readlib.patch \
21 " 22 "
22LIC_FILES_CHKSUM = "file://LICENSES;md5=98a1128c4b58120182cbea3b1752d8b9 \ 23LIC_FILES_CHKSUM = "file://LICENSES;md5=98a1128c4b58120182cbea3b1752d8b9 \
23 file://COPYING;md5=393a5ca445f6965873eca0259a17f833 \ 24 file://COPYING;md5=393a5ca445f6965873eca0259a17f833 \
@@ -83,6 +84,7 @@ do_move_ports() {
83 84
84do_patch_append() { 85do_patch_append() {
85 bb.build.exec_func('do_fix_ia_headers', d) 86 bb.build.exec_func('do_fix_ia_headers', d)
87 bb.build.exec_func('do_fix_readlib_c', d)
86} 88}
87 89
88# We need to ensure that all of the i386 and x86_64 headers are identical 90# We need to ensure that all of the i386 and x86_64 headers are identical
@@ -172,6 +174,10 @@ do_fix_ia_headers() {
172 cp ${S}/sysdeps/unix/sysv/linux/x86_64/sys/user.h ${S}/sysdeps/unix/sysv/linux/i386/sys/user.h 174 cp ${S}/sysdeps/unix/sysv/linux/x86_64/sys/user.h ${S}/sysdeps/unix/sysv/linux/i386/sys/user.h
173} 175}
174 176
177do_fix_readlib_c () {
178 sed -i -e 's#OECORE_KNOWN_INTERPRETER_NAMES#${EGLIBC_KNOWN_INTERPRETER_NAMES}#' ${S}/elf/readlib.c
179}
180
175do_configure () { 181do_configure () {
176# override this function to avoid the autoconf/automake/aclocal/autoheader 182# override this function to avoid the autoconf/automake/aclocal/autoheader
177# calls for now 183# calls for now
@@ -201,6 +207,11 @@ do_compile () {
201 rpcgen -h $r -o $h || oewarn "unable to generate header for $r" 207 rpcgen -h $r -o $h || oewarn "unable to generate header for $r"
202 done 208 done
203 ) 209 )
210 echo "Adjust ldd script"
211 [ -z "${RTLDLIST}" ] && return
212 sed -i ${B}/elf/ldd -e 's#^\(RTLDLIST=\)"\(.*\)"$#\1\2#'
213 sed -i ${B}/elf/ldd -e 's#^\(RTLDLIST=\)\(.*\)$#\1"${RTLDLIST} \2"#'
214
204} 215}
205 216
206require eglibc-package.inc 217require eglibc-package.inc