summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/eglibc/cross-localedef-native_2.16.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-01-03 23:28:20 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-01-28 12:29:31 +0000
commitd7b8ad5c294e371eee7630840269a6df10511695 (patch)
tree6e3d3af850f79404e3bc388c96473e5167446dac /meta/recipes-core/eglibc/cross-localedef-native_2.16.bb
parentb71a16e8ac18b5633ac3a52c60ad78dde37ede7b (diff)
downloadpoky-d7b8ad5c294e371eee7630840269a6df10511695.tar.gz
eglibc: Upgrade recipes 2.16 -> 2.17
Drop patches that are applied upstream Fix the license checksums for changes in LICENSES file the new changes add more copyright notices that were missing earlier Moving ports is no longer needed since ports is now part of libc proper Refresh tzselect-sh.patch to accomodate upstream changes C++ headers discovery relative to target sysroot is fixed differently upstream hence we drop use-sysroot-cxx-headers.patch aarch64 support is already available in 2.17 hence drop the local patches (From OE-Core rev: 83b6fe6d91b924be5a7676e6ee973ce26b5eefc5) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/eglibc/cross-localedef-native_2.16.bb')
-rw-r--r--meta/recipes-core/eglibc/cross-localedef-native_2.16.bb51
1 files changed, 0 insertions, 51 deletions
diff --git a/meta/recipes-core/eglibc/cross-localedef-native_2.16.bb b/meta/recipes-core/eglibc/cross-localedef-native_2.16.bb
deleted file mode 100644
index 11970e70c0..0000000000
--- a/meta/recipes-core/eglibc/cross-localedef-native_2.16.bb
+++ /dev/null
@@ -1,51 +0,0 @@
1DESCRIPTION = "Cross locale generation tool for eglibc"
2HOMEPAGE = "http://www.eglibc.org/home"
3SECTION = "libs"
4LICENSE = "LGPL-2.1"
5
6LIC_DIR = "${WORKDIR}/eglibc-${PV}/libc"
7LIC_FILES_CHKSUM = "file://${LIC_DIR}/LICENSES;md5=98a1128c4b58120182cbea3b1752d8b9\
8 file://${LIC_DIR}/COPYING;md5=393a5ca445f6965873eca0259a17f833 \
9 file://${LIC_DIR}/posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
10 file://${LIC_DIR}/COPYING.LIB;md5=bbb461211a33b134d42ed5ee802b37ff "
11
12
13inherit native
14inherit autotools
15
16# pick up an eglibc-2.16 patch
17FILESPATH = "${FILE_DIRNAME}/eglibc-${PV}"
18
19PR = "r2"
20SRC_URI = "http://downloads.yoctoproject.org/releases/eglibc/eglibc-${PV}-svnr21224.tar.bz2 \
21 file://fix_for_centos_5.8.patch;patchdir=.. \
22 "
23
24SRC_URI[md5sum] = "88894fa6e10e58e85fbd8134b8e486a8"
25SRC_URI[sha256sum] = "460a45f422da6eb1fd909baab6a64b5ae4c8ba18ea05a1491ed1024c8b98eeaa"
26
27S = "${WORKDIR}/eglibc-${PV}/localedef"
28
29do_unpack_append() {
30 bb.build.exec_func('do_move_ports', d)
31}
32
33do_move_ports() {
34 if test -d ${WORKDIR}/eglibc-${PV}/ports ; then
35 rm -rf ${WORKDIR}/libc/ports
36 mv ${WORKDIR}/eglibc-${PV}/ports ${WORKDIR}/libc/
37 fi
38}
39
40EXTRA_OECONF = "--with-glibc=${WORKDIR}/eglibc-${PV}/libc"
41CFLAGS += "-DNOT_IN_libc=1"
42
43do_configure () {
44 ./configure ${EXTRA_OECONF}
45}
46
47
48do_install() {
49 install -d ${D}${bindir}
50 install -m 0755 ${S}/localedef ${D}${bindir}/cross-localedef
51}