summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/eglibc/cross-localedef-native_2.13.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-06-21 16:06:32 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-06-25 16:35:53 +0100
commit92e20d13c819c0c1933706b22ffc3478ab76e7d0 (patch)
tree00423068aaece5dcd19b500e44a5203605eb626a /meta/recipes-core/eglibc/cross-localedef-native_2.13.bb
parent2ef14dff79230a67258995c27b49aaab1aae92ca (diff)
downloadpoky-92e20d13c819c0c1933706b22ffc3478ab76e7d0.tar.gz
eglibc-2.13: Retire into toolchain layer
If anyone wants it add toolchain-layer from meta-openembedded repo to your setup (From OE-Core rev: 505d82df47628b72e2af6f73e7c33fbb9812fdd1) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/eglibc/cross-localedef-native_2.13.bb')
-rw-r--r--meta/recipes-core/eglibc/cross-localedef-native_2.13.bb43
1 files changed, 0 insertions, 43 deletions
diff --git a/meta/recipes-core/eglibc/cross-localedef-native_2.13.bb b/meta/recipes-core/eglibc/cross-localedef-native_2.13.bb
deleted file mode 100644
index 52759afe60..0000000000
--- a/meta/recipes-core/eglibc/cross-localedef-native_2.13.bb
+++ /dev/null
@@ -1,43 +0,0 @@
1DESCRIPTION = "Cross locale generation tool for eglibc"
2HOMEPAGE = "http://www.eglibc.org/home"
3SECTION = "libs"
4LICENSE = "LGPL"
5
6LIC_DIR = "${WORKDIR}/${EGLIBC_BRANCH}/libc"
7LIC_FILES_CHKSUM = "file://${LIC_DIR}/LICENSES;md5=07a394b26e0902b9ffdec03765209770 \
8 file://${LIC_DIR}/COPYING;md5=393a5ca445f6965873eca0259a17f833 \
9 file://${LIC_DIR}/posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
10 file://${LIC_DIR}/COPYING.LIB;md5=bbb461211a33b134d42ed5ee802b37ff "
11
12
13inherit native
14inherit autotools
15
16PR = "r1"
17SRCREV="11982"
18EGLIBC_BRANCH="eglibc-2_12"
19SRC_URI = "svn://www.eglibc.org/svn/branches/;module=${EGLIBC_BRANCH};proto=http "
20S = "${WORKDIR}/${EGLIBC_BRANCH}/localedef"
21
22do_unpack_append() {
23 bb.build.exec_func('do_move_ports', d)
24}
25
26do_move_ports() {
27 if test -d ${WORKDIR}/${EGLIBC_BRANCH}/ports ; then
28 rm -rf ${WORKDIR}/libc/ports
29 mv ${WORKDIR}/${EGLIBC_BRANCH}/ports ${WORKDIR}/libc/
30 fi
31}
32
33EXTRA_OECONF = "--with-glibc=${WORKDIR}/${EGLIBC_BRANCH}/libc"
34
35do_configure () {
36 ./configure ${EXTRA_OECONF}
37}
38
39
40do_install() {
41 install -d ${D}${bindir}
42 install -m 0755 ${S}/localedef ${D}${bindir}/cross-localedef
43}