summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/dbus/dbus-test_1.6.18.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
committerTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
commitc527fd1f14c27855a37f2e8ac5346ce8d940ced2 (patch)
treebb002c1fdf011c41dbd2f0927bed23ecb5f83c97 /meta/recipes-core/dbus/dbus-test_1.6.18.bb
downloadpoky-daisy-140929.tar.gz
initial commit for Enea Linux 4.0-140929daisy-140929
Migrated from the internal git server on the daisy-enea-point-release branch Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta/recipes-core/dbus/dbus-test_1.6.18.bb')
-rw-r--r--meta/recipes-core/dbus/dbus-test_1.6.18.bb54
1 files changed, 54 insertions, 0 deletions
diff --git a/meta/recipes-core/dbus/dbus-test_1.6.18.bb b/meta/recipes-core/dbus/dbus-test_1.6.18.bb
new file mode 100644
index 0000000000..9a7cdc5eee
--- /dev/null
+++ b/meta/recipes-core/dbus/dbus-test_1.6.18.bb
@@ -0,0 +1,54 @@
1SUMMARY = "D-Bus test package (for D-bus functionality testing only)"
2HOMEPAGE = "http://dbus.freedesktop.org"
3SECTION = "base"
4LICENSE = "AFL-2 | GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=10dded3b58148f3f1fd804b26354af3e \
6 file://dbus/dbus.h;beginline=6;endline=20;md5=7755c9d7abccd5dbd25a6a974538bb3c"
7
8DEPENDS = "python-pygobject dbus dbus-glib"
9
10RDEPENDS_${PN} += "make"
11RDEPENDS_${PN}-dev = ""
12
13SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
14 file://tmpdir.patch \
15 file://ptest.patch \
16 file://dbus-1.init \
17 file://run-ptest \
18 file://python-config.patch \
19 file://clear-guid_from_server-if-send_negotiate_unix_f.patch \
20 file://avoid_parallel_tests.patch \
21 "
22
23SRC_URI[md5sum] = "b02e9c95027a416987b81f9893831061"
24SRC_URI[sha256sum] = "7085a0895a9eb11a952394cdbea6d8b4358e17cb991fed0e8fb85e2b9e686dcd"
25
26S="${WORKDIR}/dbus-${PV}"
27FILESPATH = "${FILE_DIRNAME}/dbus"
28
29inherit autotools pkgconfig gettext ptest
30
31EXTRA_OECONF_X = "${@base_contains('DISTRO_FEATURES', 'x11', '--with-x', '--without-x', d)}"
32EXTRA_OECONF_X_class-native = "--without-x"
33
34EXTRA_OECONF = "--enable-tests \
35 --enable-modular-tests \
36 --enable-installed-tests \
37 --enable-checks \
38 --enable-asserts \
39 --enable-verbose-mode \
40 --disable-xml-docs \
41 --disable-doxygen-docs \
42 --disable-libaudit \
43 --with-xml=expat \
44 --disable-systemd \
45 --without-systemdsystemunitdir \
46 --with-dbus-test-dir=${PTEST_PATH} \
47 ${EXTRA_OECONF_X}"
48
49do_install() {
50}
51
52do_install_ptest() {
53 find ${D}${PTEST_PATH} -name Makefile | xargs sed -i 's/^Makefile:/_Makefile:/'
54}