summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/dbus/dbus-test_1.12.22.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2022-03-09 23:22:12 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-03-15 08:40:09 +0000
commit73673240555a5cf446edc8512a16228cf0ef6241 (patch)
tree393e6cbd238e6f86ca37542041af4df7ab5e5019 /meta/recipes-core/dbus/dbus-test_1.12.22.bb
parent5d11e2028e9674df2a548ea93f1d6a4351973038 (diff)
downloadpoky-73673240555a5cf446edc8512a16228cf0ef6241.tar.gz
dbus-test: merge into main dbus recipe
The reason it was separate is that there is a peculiar circular dependency: dbus tests require glib, while some of glib's gdbus tests require dbus. So dbus was built with tests disabled and without glib dependency, then glib was built with dbus dependency, then dbus was built again with glib dependency and tests enabled, only for the purpose of installing those tests. I find that brittle and hacky, so this removes dbus dependecy from glib (the fallout is that some gdbus tests are no longer being executed), and dbus and its tests are built once, after glib. Conversely, dbus is now dependent on glib for the purpose of building the tests. Also, dbus ptest installation is no longer using custom code, and dbus run-ptest simply uses standard installed tests execution mechanism from gnome. (From OE-Core rev: cfecef4e6925865961858d0fe5ffc7794c71cd3b) Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/dbus/dbus-test_1.12.22.bb')
-rw-r--r--meta/recipes-core/dbus/dbus-test_1.12.22.bb64
1 files changed, 0 insertions, 64 deletions
diff --git a/meta/recipes-core/dbus/dbus-test_1.12.22.bb b/meta/recipes-core/dbus/dbus-test_1.12.22.bb
deleted file mode 100644
index ae70301431..0000000000
--- a/meta/recipes-core/dbus/dbus-test_1.12.22.bb
+++ /dev/null
@@ -1,64 +0,0 @@
1SUMMARY = "D-Bus test package (for D-bus functionality testing only)"
2HOMEPAGE = "http://dbus.freedesktop.org"
3SECTION = "base"
4
5require dbus.inc
6
7SRC_URI += "file://run-ptest \
8 file://python-config.patch \
9 "
10
11DEPENDS = "dbus glib-2.0"
12
13RDEPENDS:${PN}-dev = ""
14
15S="${WORKDIR}/dbus-${PV}"
16FILESEXTRAPATHS =. "${FILE_DIRNAME}/dbus:"
17
18inherit ptest
19
20EXTRA_OECONF += "--enable-tests \
21 --enable-modular-tests \
22 --enable-installed-tests \
23 --enable-checks \
24 --enable-asserts \
25 --with-dbus-test-dir=${PTEST_PATH} \
26 --enable-embedded-tests \
27 "
28
29do_install() {
30 :
31}
32
33do_install_ptest() {
34 install -d ${D}${PTEST_PATH}/test
35 l="shell printf refs syslog marshal syntax corrupt dbus-daemon dbus-daemon-eavesdrop loopback relay \
36 variant uid-permissions syntax spawn sd-activation names monitor message fdpass service shell-service"
37 for i in $l; do install ${B}/test/.libs/test-$i ${D}${PTEST_PATH}/test; done
38
39 l="bus bus-system bus-launch-helper"
40 for i in $l; do install ${B}/bus/.libs/test-$i ${D}${PTEST_PATH}/test; done
41
42 install -d ${D}${PTEST_PATH}/bus
43 install ${B}/bus/.libs/dbus-daemon-launch-helper-test ${D}${PTEST_PATH}/bus
44
45 install ${B}/test/test-segfault ${D}${PTEST_PATH}/test
46
47 cp -r ${B}/test/data ${D}${PTEST_PATH}/test
48 install ${B}/dbus/.libs/test-dbus ${D}${PTEST_PATH}/test
49
50 install -d ${D}${PTEST_PATH}/test/.libs
51 cp -a ${B}/dbus/.libs/*.so* ${D}${PTEST_PATH}/test/.libs
52
53 # Remove build host references...
54 find "${D}${PTEST_PATH}/test/data" \( -name *.service -o -name *.conf -o -name "*.aaprofile" \) -type f -exec \
55 sed -i \
56 -e 's:${B}:${PTEST_PATH}:g' \
57 {} +
58 sed -i -e 's;@PTEST_PATH@;${PTEST_PATH};g' ${D}${PTEST_PATH}/run-ptest
59}
60
61RDEPENDS:${PN}-ptest += "bash make dbus"
62RDEPENDS:${PN}-ptest:remove = "${PN}"
63
64PRIVATE_LIBS:${PN}-ptest = "libdbus-1.so.3"