summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/dbus/dbus-test_1.12.18.bb
diff options
context:
space:
mode:
authorOvidiu Panait <ovidiu.panait@windriver.com>2020-06-19 22:25:50 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-06-23 12:31:03 +0100
commit44ae5d8d6f26fda4ab1a3fef9fc49d74e4ac89f0 (patch)
tree9a6970c0410fa724dc505496b731d2ceb2d9fab6 /meta/recipes-core/dbus/dbus-test_1.12.18.bb
parent036e3436e51a44de3fc9b4b8e5b1ff149e3aaa9d (diff)
downloadpoky-44ae5d8d6f26fda4ab1a3fef9fc49d74e4ac89f0.tar.gz
dbus,dbus-test: Move common parts to dbus.inc
dbus and dbus-test share the same source code and base configuration options, so factor out the common parts into dbus.inc. This way we can eliminate the need to keep the two recipes in sync. When they are not properly in sync (e.g. when dbus recipe has extra patches/config options that are not duplicated in dbus-test) ptest testsuite will actually test a slightly different codebase. This is due to the fact that dbus-test does not run the testsuite against the system libdbus library, but instead it generates a local libdbus.so that needs to configured/compiled as close as possible to the system one. (From OE-Core rev: 1cde2935526d2eec7d6b17a6c622647b0c132439) Signed-off-by: Ovidiu Panait <ovidiu.panait@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/dbus/dbus-test_1.12.18.bb')
-rw-r--r--meta/recipes-core/dbus/dbus-test_1.12.18.bb38
1 files changed, 8 insertions, 30 deletions
diff --git a/meta/recipes-core/dbus/dbus-test_1.12.18.bb b/meta/recipes-core/dbus/dbus-test_1.12.18.bb
index 68fcdc847f..755c841bad 100644
--- a/meta/recipes-core/dbus/dbus-test_1.12.18.bb
+++ b/meta/recipes-core/dbus/dbus-test_1.12.18.bb
@@ -1,53 +1,31 @@
1SUMMARY = "D-Bus test package (for D-bus functionality testing only)" 1SUMMARY = "D-Bus test package (for D-bus functionality testing only)"
2HOMEPAGE = "http://dbus.freedesktop.org" 2HOMEPAGE = "http://dbus.freedesktop.org"
3SECTION = "base" 3SECTION = "base"
4LICENSE = "AFL-2.1 | GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=10dded3b58148f3f1fd804b26354af3e \
6 file://dbus/dbus.h;beginline=6;endline=20;md5=7755c9d7abccd5dbd25a6a974538bb3c"
7 4
8DEPENDS = "dbus glib-2.0" 5require dbus.inc
9 6
10RDEPENDS_${PN}-dev = "" 7SRC_URI += "file://run-ptest \
8 file://python-config.patch \
9 "
11 10
12SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \ 11DEPENDS = "dbus glib-2.0"
13 file://tmpdir.patch \
14 file://run-ptest \
15 file://python-config.patch \
16 file://clear-guid_from_server-if-send_negotiate_unix_f.patch \
17 "
18 12
19SRC_URI[md5sum] = "4ca570c281be35d0b30ab83436712242" 13RDEPENDS_${PN}-dev = ""
20SRC_URI[sha256sum] = "64cf4d70840230e5e9bc784d153880775ab3db19d656ead8a0cb9c0ab5a95306"
21 14
22S="${WORKDIR}/dbus-${PV}" 15S="${WORKDIR}/dbus-${PV}"
23FILESEXTRAPATHS =. "${FILE_DIRNAME}/dbus:" 16FILESEXTRAPATHS =. "${FILE_DIRNAME}/dbus:"
24 17
25inherit autotools pkgconfig gettext ptest upstream-version-is-even 18inherit ptest
26 19
27EXTRA_OECONF = "--enable-tests \ 20EXTRA_OECONF += "--enable-tests \
28 --enable-modular-tests \ 21 --enable-modular-tests \
29 --enable-installed-tests \ 22 --enable-installed-tests \
30 --enable-checks \ 23 --enable-checks \
31 --enable-asserts \ 24 --enable-asserts \
32 --enable-largefile \
33 --disable-xml-docs \
34 --disable-doxygen-docs \
35 --disable-libaudit \
36 --with-dbus-test-dir=${PTEST_PATH} \ 25 --with-dbus-test-dir=${PTEST_PATH} \
37 --enable-embedded-tests \ 26 --enable-embedded-tests \
38 " 27 "
39 28
40EXTRA_OECONF_append_class-target = " SYSTEMCTL=${base_bindir}/systemctl"
41
42PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd x11', d)}"
43PACKAGECONFIG_class-native = ""
44PACKAGECONFIG_class-nativesdk = ""
45
46PACKAGECONFIG[systemd] = "--enable-systemd --with-systemdsystemunitdir=${systemd_system_unitdir},--disable-systemd --without-systemdsystemunitdir,systemd"
47PACKAGECONFIG[x11] = "--with-x --enable-x11-autolaunch,--without-x --disable-x11-autolaunch, virtual/libx11 libsm"
48PACKAGECONFIG[user-session] = "--enable-user-session --with-systemduserunitdir=${systemd_user_unitdir},--disable-user-session"
49PACKAGECONFIG[verbose-mode] = "--enable-verbose-mode,,,"
50
51do_install() { 29do_install() {
52 : 30 :
53} 31}