summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/coreutils/coreutils_8.22.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2015-01-04 13:40:55 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-01-16 23:08:20 +0000
commitce9cb7ae7a37d211fde7c41e42f36a649f9cd50a (patch)
tree2853b6eb96df9e0a702bb7548d948ee80650dfb2 /meta/recipes-core/coreutils/coreutils_8.22.bb
parentce5cc411bb29f41e2f001118313d19b6c48d8436 (diff)
downloadpoky-ce9cb7ae7a37d211fde7c41e42f36a649f9cd50a.tar.gz
coreutils: upgrade to 8.23
fix-for-dummy-man-usage.patch is rebased. (From OE-Core rev: 4fb3752824ff20e5b5b322e6e12211c81795313c) Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/coreutils/coreutils_8.22.bb')
-rw-r--r--meta/recipes-core/coreutils/coreutils_8.22.bb107
1 files changed, 0 insertions, 107 deletions
diff --git a/meta/recipes-core/coreutils/coreutils_8.22.bb b/meta/recipes-core/coreutils/coreutils_8.22.bb
deleted file mode 100644
index f85bacabd3..0000000000
--- a/meta/recipes-core/coreutils/coreutils_8.22.bb
+++ /dev/null
@@ -1,107 +0,0 @@
1SUMMARY = "The basic file, shell and text manipulation utilities"
2DESCRIPTION = "The GNU Core Utilities provide the basic file, shell and text \
3manipulation utilities. These are the core utilities which are expected to exist on \
4every system."
5HOMEPAGE = "http://www.gnu.org/software/coreutils/"
6BUGTRACKER = "http://debbugs.gnu.org/coreutils"
7LICENSE = "GPLv3+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504\
9 file://src/ls.c;beginline=5;endline=16;md5=38b79785ca88537b75871782a2a3c6b8"
10DEPENDS = "gmp libcap"
11DEPENDS_class-native = ""
12
13inherit autotools gettext texinfo
14
15SRC_URI = "${GNU_MIRROR}/coreutils/${BP}.tar.xz \
16 file://remove-usr-local-lib-from-m4.patch \
17 file://dummy_help2man.patch \
18 file://fix-for-dummy-man-usage.patch \
19 file://fix-selinux-flask.patch \
20 "
21
22SRC_URI[md5sum] = "8fb0ae2267aa6e728958adc38f8163a2"
23SRC_URI[sha256sum] = "5b3e94998152c017e6c75d56b9b994188eb71bf46d4038a642cb9141f6ff1212"
24
25EXTRA_OECONF_class-native = "--without-gmp"
26EXTRA_OECONF_class-target = "--enable-install-program=arch --libexecdir=${libdir}"
27
28# acl is not a default feature
29#
30PACKAGECONFIG_class-target ??= "${@bb.utils.contains('DISTRO_FEATURES', 'acl', 'acl', '', d)}"
31PACKAGECONFIG_class-native ??= ""
32
33# with, without, depends, rdepends
34#
35PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl,"
36
37# [ df mktemp base64 gets a special treatment and is not included in this
38bindir_progs = "arch basename chcon cksum comm csplit cut dir dircolors dirname du \
39 env expand expr factor fmt fold groups head hostid id install \
40 join link logname md5sum mkfifo nice nl nohup nproc od paste pathchk \
41 pinky pr printenv printf ptx readlink realpath runcon seq sha1sum sha224sum sha256sum \
42 sha384sum sha512sum shred shuf sort split stdbuf sum tac tail tee test timeout\
43 tr truncate tsort tty unexpand uniq unlink uptime users vdir wc who whoami yes"
44
45# hostname gets a special treatment and is not included in this
46base_bindir_progs = "cat chgrp chmod chown cp date dd echo false kill ln ls mkdir \
47 mknod mv pwd rm rmdir sleep stty sync touch true uname stat"
48
49sbindir_progs= "chroot"
50
51# Let aclocal use the relative path for the m4 file rather than the
52# absolute since coreutils has a lot of m4 files, otherwise there might
53# be an "Argument list too long" error when it is built in a long/deep
54# directory.
55acpaths = "-I ./m4"
56
57# Deal with a separate builddir failure if src doesn't exist when creating version.c/version.h
58do_compile_prepend () {
59 mkdir -p ${B}/src
60}
61
62do_install_append() {
63 for i in df mktemp base64; do mv ${D}${bindir}/$i ${D}${bindir}/$i.${BPN}; done
64
65 install -d ${D}${base_bindir}
66 [ "${base_bindir}" != "${bindir}" ] && for i in ${base_bindir_progs}; do mv ${D}${bindir}/$i ${D}${base_bindir}/$i.${BPN}; done
67
68 install -d ${D}${sbindir}
69 [ "${sbindir}" != "${bindir}" ] && for i in ${sbindir_progs}; do mv ${D}${bindir}/$i ${D}${sbindir}/$i.${BPN}; done
70
71 # [ requires special handling because [.coreutils will cause the sed stuff
72 # in update-alternatives to fail, therefore use lbracket - the name used
73 # for the actual source file.
74 mv ${D}${bindir}/[ ${D}${bindir}/lbracket.${BPN}
75}
76
77do_install_append_class-native(){
78 # remove groups to fix conflict with shadow-native
79 rm -f ${D}${STAGING_BINDIR_NATIVE}/groups
80}
81
82inherit update-alternatives
83
84ALTERNATIVE_PRIORITY = "100"
85ALTERNATIVE_${PN} = "lbracket ${bindir_progs} ${base_bindir_progs} ${sbindir_progs} base64 mktemp df"
86
87ALTERNATIVE_LINK_NAME[base64] = "${base_bindir}/base64"
88ALTERNATIVE_TARGET[base64] = "${bindir}/base64.${BPN}"
89
90ALTERNATIVE_LINK_NAME[mktemp] = "${base_bindir}/mktemp"
91ALTERNATIVE_TARGET[mktemp] = "${bindir}/mktemp.${BPN}"
92
93ALTERNATIVE_LINK_NAME[df] = "${base_bindir}/df"
94ALTERNATIVE_TARGET[df] = "${bindir}/df.${BPN}"
95
96ALTERNATIVE_LINK_NAME[lbracket] = "${bindir}/["
97ALTERNATIVE_TARGET[lbracket] = "${bindir}/lbracket.${BPN}"
98
99python __anonymous() {
100 for prog in d.getVar('base_bindir_progs', True).split():
101 d.setVarFlag('ALTERNATIVE_LINK_NAME', prog, '%s/%s' % (d.getVar('base_bindir', True), prog))
102
103 for prog in d.getVar('sbindir_progs', True).split():
104 d.setVarFlag('ALTERNATIVE_LINK_NAME', prog, '%s/%s' % (d.getVar('sbindir', True), prog))
105}
106
107BBCLASSEXTEND = "native nativesdk"