summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/busybox/busybox_git.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2013-11-29 20:15:45 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-11-30 22:26:27 +0000
commit3c182d22080e27ecdaf7a04e28caa84fafec5395 (patch)
tree141b046b2782177868126e1e25792ef35c34c498 /meta/recipes-core/busybox/busybox_git.bb
parentef71b02844eb2c286803af12ccd551d6776f211e (diff)
downloadpoky-3c182d22080e27ecdaf7a04e28caa84fafec5395.tar.gz
busybox: add busybox_git.bb recipe
Add busybox_git.bb recipe so that it would be easier to hack with busybox. Set DEFAULT_PREFERENCE to "-1" in the git recipe so that we still use the busybox_1.21.1.bb recipe by default. (From OE-Core rev: d290bbe6d9826fbcfa2e0a7624886284697ed7eb) Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/busybox/busybox_git.bb')
-rw-r--r--meta/recipes-core/busybox/busybox_git.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta/recipes-core/busybox/busybox_git.bb b/meta/recipes-core/busybox/busybox_git.bb
new file mode 100644
index 0000000000..91ecff8212
--- /dev/null
+++ b/meta/recipes-core/busybox/busybox_git.bb
@@ -0,0 +1,53 @@
1require busybox.inc
2
3SRCREV = "e73f3c1d3d83699b723251f7e6a981021ce75475"
4# Lookout for PV bump too when SRCREV is changed
5PV = "1.21.1+git${SRCPV}"
6
7S = "${WORKDIR}/git"
8
9SRC_URI = "git://busybox.net/busybox.git \
10 file://get_header_tar.patch \
11 file://busybox-appletlib-dependency.patch \
12 file://run-parts.in.usr-bin.patch \
13 file://watch.in.usr-bin.patch \
14 file://busybox-udhcpc-no_deconfig.patch \
15 file://find-touchscreen.sh \
16 file://busybox-cron \
17 file://busybox-httpd \
18 file://busybox-udhcpd \
19 file://default.script \
20 file://simple.script \
21 file://hwclock.sh \
22 file://mount.busybox \
23 file://syslog \
24 file://syslog-startup.conf \
25 file://syslog.conf \
26 file://busybox-syslog.default \
27 file://mdev \
28 file://mdev.conf \
29 file://umount.busybox \
30 file://defconfig \
31 file://stat-usr-bin.patch \
32 file://busybox-syslog.service.in \
33 file://busybox-klogd.service.in \
34 file://testsuite-du-du-k-works-fix-false-positive.patch \
35 file://fail_on_no_media.patch \
36 file://busybox-sulogin-empty-root-password.patch \
37 file://run-ptest \
38 file://inetd.conf \
39 file://inetd \
40 file://login-utilities.cfg \
41 file://busybox-list-suid-and-non-suid-app-configs.patch \
42 file://busybox-sed-fix-sed-clusternewline-testcase.patch \
43"
44
45EXTRA_OEMAKE += "V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX} SKIP_STRIP=y"
46
47do_install_ptest () {
48 cp -r ${B}/testsuite ${D}${PTEST_PATH}/
49 cp ${B}/.config ${D}${PTEST_PATH}/
50 ln -s /bin/busybox ${D}${PTEST_PATH}/busybox
51}
52
53DEFAULT_PREFERENCE = "-1"