summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/busybox/busybox_1.21.1.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2013-07-05 10:29:29 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-07-05 15:44:13 +0100
commit131e5e7e8fc497bb2c77cfb3e52eb201d2aaf3d0 (patch)
treecde6580df91d24345c12bac7b171e2d0d35d8d17 /meta/recipes-core/busybox/busybox_1.21.1.bb
parent0463e5c173fed7f081760dea6e8f1bbe4cdbb2e8 (diff)
downloadpoky-131e5e7e8fc497bb2c77cfb3e52eb201d2aaf3d0.tar.gz
busybox: upgrade to stable 1.21.1
Merged or backported patches are dropped. The wget_dl_dir_fix.patch was submitted more than 1 year ago, it's about the -P option behavior, and it's not accepted, so I dropped this patch too. (From OE-Core rev: a2f31a6a6accb8eee2084cb39edb8e9af4b4189f) Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/busybox/busybox_1.21.1.bb')
-rw-r--r--meta/recipes-core/busybox/busybox_1.21.1.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta/recipes-core/busybox/busybox_1.21.1.bb b/meta/recipes-core/busybox/busybox_1.21.1.bb
new file mode 100644
index 0000000000..d702f7e61d
--- /dev/null
+++ b/meta/recipes-core/busybox/busybox_1.21.1.bb
@@ -0,0 +1,45 @@
1require busybox.inc
2PR = "r0"
3
4SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
5 file://get_header_tar.patch \
6 file://busybox-appletlib-dependency.patch \
7 file://run-parts.in.usr-bin.patch \
8 file://watch.in.usr-bin.patch \
9 file://busybox-udhcpc-no_deconfig.patch \
10 file://find-touchscreen.sh \
11 file://busybox-cron \
12 file://busybox-httpd \
13 file://busybox-udhcpd \
14 file://default.script \
15 file://simple.script \
16 file://hwclock.sh \
17 file://mount.busybox \
18 file://syslog \
19 file://syslog-startup.conf \
20 file://mdev \
21 file://mdev.conf \
22 file://umount.busybox \
23 file://defconfig \
24 file://stat-usr-bin.patch \
25 file://busybox-syslog.service.in \
26 file://busybox-klogd.service.in \
27 file://testsuite-du-du-k-works-fix-false-positive.patch \
28 file://fail_on_no_media.patch \
29 file://busybox-sulogin-empty-root-password.patch \
30 file://run-ptest \
31 file://inetd.conf \
32 file://inetd \
33 file://login-utilities.cfg \
34 file://busybox-list-suid-and-non-suid-app-configs.patch"
35
36SRC_URI[tarball.md5sum] = "795394f83903b5eec6567d51eebb417e"
37SRC_URI[tarball.sha256sum] = "cd5be0912ec856110ae12c76c3ec9cd5cba1df45b5a9da2b095b8284d1481303"
38
39EXTRA_OEMAKE += "V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX} SKIP_STRIP=y"
40
41do_install_ptest () {
42 cp -r ${B}/testsuite ${D}${PTEST_PATH}/
43 cp ${B}/.config ${D}${PTEST_PATH}/
44 ln -s /bin/busybox ${D}${PTEST_PATH}/busybox
45}