summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/busybox/busybox_1.20.2.bb
diff options
context:
space:
mode:
authorBjörn Stenberg <bjst@enea.com>2013-06-24 16:52:21 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-06-25 17:44:58 +0100
commit67d95bffa95ca6e56c06c59fd1d15d20ce9a636a (patch)
tree83257f3f5b6de7560943468657b07a56845f4999 /meta/recipes-core/busybox/busybox_1.20.2.bb
parenteea24c6545ea4af1b8cbacb923d7613bd29e7933 (diff)
downloadpoky-67d95bffa95ca6e56c06c59fd1d15d20ce9a636a.tar.gz
busybox: Add ptest
Install busybox test suite and run it as ptest. (From OE-Core rev: 0d29dc5b5f7742df60fdba90835ef77425963bde) Signed-off-by: Anders Roxell <anders.roxell@enea.com> Signed-off-by: Björn Stenberg <bjst@enea.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/busybox/busybox_1.20.2.bb')
-rw-r--r--meta/recipes-core/busybox/busybox_1.20.2.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta/recipes-core/busybox/busybox_1.20.2.bb b/meta/recipes-core/busybox/busybox_1.20.2.bb
index a2e762d451..c854f0b2bd 100644
--- a/meta/recipes-core/busybox/busybox_1.20.2.bb
+++ b/meta/recipes-core/busybox/busybox_1.20.2.bb
@@ -34,6 +34,7 @@ SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
34 file://strict-atime.patch \ 34 file://strict-atime.patch \
35 file://fail_on_no_media.patch \ 35 file://fail_on_no_media.patch \
36 file://busybox-sulogin-empty-root-password.patch \ 36 file://busybox-sulogin-empty-root-password.patch \
37 file://run-ptest \
37 file://inetd.conf \ 38 file://inetd.conf \
38 file://inetd \ 39 file://inetd \
39 file://login-utilities.cfg \ 40 file://login-utilities.cfg \
@@ -43,3 +44,9 @@ SRC_URI[tarball.md5sum] = "e025414bc6cd79579cc7a32a45d3ae1c"
43SRC_URI[tarball.sha256sum] = "eb13ff01dae5618ead2ef6f92ba879e9e0390f9583bd545d8789d27cf39b6882" 44SRC_URI[tarball.sha256sum] = "eb13ff01dae5618ead2ef6f92ba879e9e0390f9583bd545d8789d27cf39b6882"
44 45
45EXTRA_OEMAKE += "V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX} SKIP_STRIP=y" 46EXTRA_OEMAKE += "V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX} SKIP_STRIP=y"
47
48do_install_ptest () {
49 cp -r ${B}/testsuite ${D}${PTEST_PATH}/
50 cp ${B}/.config ${D}${PTEST_PATH}/
51 ln -s /bin/busybox ${D}${PTEST_PATH}/busybox
52}