summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/busybox/busybox-inittab_1.29.3.bb
diff options
context:
space:
mode:
authorDustin Bain <dustin.bain@garmin.com>2019-02-05 09:31:44 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-02-25 22:27:38 +0000
commit4e262fb1627bc7da5a620575f4593446df27cefa (patch)
tree78b7ecc11ebfb1b47111de9127c2e1867066eea9 /meta/recipes-core/busybox/busybox-inittab_1.29.3.bb
parent9b41eae273e08c9b56c59ddd317bcf431c5bbf76 (diff)
downloadpoky-4e262fb1627bc7da5a620575f4593446df27cefa.tar.gz
busybox: update to 1.29.3
Updates busybox to version 1.29.3 to fix a bug related to parsing of config files: 2993551ef ("Revert "libbb: remove unnecessary variable in xmalloc_fgets"") Upgrading the recipe was chosen instead of backporting the fix as a patch because the only difference between version 1.29.2 and 1.29.3 is this revert. (From OE-Core rev: 11d4fd16c3d7dad5d7e3b4d44a96724075be7126) (From OE-Core rev: 1ee1701a01e1bd9146e53613e80ea9185579c719) Signed-off-by: Dustin Bain <dustin.bain@garmin.com> Signed-off-by: Joshua Watt <JPEWhacker@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/busybox/busybox-inittab_1.29.3.bb')
-rw-r--r--meta/recipes-core/busybox/busybox-inittab_1.29.3.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-core/busybox/busybox-inittab_1.29.3.bb b/meta/recipes-core/busybox/busybox-inittab_1.29.3.bb
new file mode 100644
index 0000000000..a83620e859
--- /dev/null
+++ b/meta/recipes-core/busybox/busybox-inittab_1.29.3.bb
@@ -0,0 +1,32 @@
1SUMMARY = "inittab configuration for BusyBox"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
4
5SRC_URI = "file://inittab"
6
7S = "${WORKDIR}"
8
9INHIBIT_DEFAULT_DEPS = "1"
10
11do_compile() {
12 :
13}
14
15do_install() {
16 install -d ${D}${sysconfdir}
17 install -D -m 0644 ${WORKDIR}/inittab ${D}${sysconfdir}/inittab
18 tmp="${SERIAL_CONSOLES}"
19 for i in $tmp
20 do
21 j=`echo ${i} | sed s/\;/\ /g`
22 id=`echo ${i} | sed -e 's/^.*;//' -e 's/;.*//'`
23 echo "$id::respawn:${base_sbindir}/getty ${j}" >> ${D}${sysconfdir}/inittab
24 done
25}
26
27# SERIAL_CONSOLES is generally defined by the MACHINE .conf.
28# Set PACKAGE_ARCH appropriately.
29PACKAGE_ARCH = "${MACHINE_ARCH}"
30
31FILES_${PN} = "${sysconfdir}/inittab"
32CONFFILES_${PN} = "${sysconfdir}/inittab"