summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/base-passwd/base-passwd_3.5.29.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-07-28 23:28:15 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-08-02 15:44:10 +0100
commitbb6ddc3691ab04162ec5fd69a2d5e7876713fd15 (patch)
tree76e376b01253c3aace1a98a5021bcaad3c92e861 /meta/recipes-core/base-passwd/base-passwd_3.5.29.bb
parentfcc456ee4b8f619134abb4649db53c638074082c (diff)
downloadpoky-bb6ddc3691ab04162ec5fd69a2d5e7876713fd15.tar.gz
Convert to new override syntax
This is the result of automated script conversion: scripts/contrib/convert-overrides.py <oe-core directory> converting the metadata to use ":" as the override character instead of "_". (From OE-Core rev: 42344347be29f0997cc2f7636d9603b1fe1875ae) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/base-passwd/base-passwd_3.5.29.bb')
-rw-r--r--meta/recipes-core/base-passwd/base-passwd_3.5.29.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta/recipes-core/base-passwd/base-passwd_3.5.29.bb b/meta/recipes-core/base-passwd/base-passwd_3.5.29.bb
index 65b3cd778d..2926a377c6 100644
--- a/meta/recipes-core/base-passwd/base-passwd_3.5.29.bb
+++ b/meta/recipes-core/base-passwd/base-passwd_3.5.29.bb
@@ -73,7 +73,7 @@ base_passwd_tweaksysroot () {
73 chmod 0755 $dest 73 chmod 0755 $dest
74} 74}
75 75
76python populate_packages_prepend() { 76python populate_packages:prepend() {
77 # Add in the preinst function for ${PN} 77 # Add in the preinst function for ${PN}
78 # We have to do this here as prior to this, passwd/group.master 78 # We have to do this here as prior to this, passwd/group.master
79 # would be unavailable. We need to create these files at preinst 79 # would be unavailable. We need to create these files at preinst
@@ -98,17 +98,17 @@ if [ ! -e $D${sysconfdir}/group ]; then
98""" + group + """EOF 98""" + group + """EOF
99fi 99fi
100""" 100"""
101 d.setVar(d.expand('pkg_preinst_${PN}'), preinst) 101 d.setVar(d.expand('pkg_preinst:${PN}'), preinst)
102} 102}
103 103
104addtask do_package after do_populate_sysroot 104addtask do_package after do_populate_sysroot
105 105
106ALLOW_EMPTY_${PN} = "1" 106ALLOW_EMPTY:${PN} = "1"
107 107
108PACKAGES =+ "${PN}-update" 108PACKAGES =+ "${PN}-update"
109FILES_${PN}-update = "${sbindir}/* ${datadir}/${PN}" 109FILES:${PN}-update = "${sbindir}/* ${datadir}/${PN}"
110 110
111pkg_postinst_${PN}-update () { 111pkg_postinst:${PN}-update () {
112#!/bin/sh 112#!/bin/sh
113if [ -n "$D" ]; then 113if [ -n "$D" ]; then
114 exit 0 114 exit 0