summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/base-files/base-files_3.0.14.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2019-04-17 10:01:25 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-04-23 23:30:20 +0100
commit78ac62b44a9cb85f764b4145d186f55b8b6a1cdb (patch)
treef4252156ed0cb6f902aad5a10d6462033c3891ee /meta/recipes-core/base-files/base-files_3.0.14.bb
parent4f9318adae792b67f26026cb3173e1b74329f535 (diff)
downloadpoky-78ac62b44a9cb85f764b4145d186f55b8b6a1cdb.tar.gz
base-files: move hostname operations out of issue file settings
The function do_install_basefilesissue is meant to deal with /etc/issue* files and the following setting could actually be overridden. BASEFILESISSUEINSTALL ?= "do_install_basefilesissue" So move the hostname operations out of this function. (From OE-Core rev: f17bcc46341db5ee91bb26389ccaebc68c49b97e) Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/base-files/base-files_3.0.14.bb')
-rw-r--r--meta/recipes-core/base-files/base-files_3.0.14.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/meta/recipes-core/base-files/base-files_3.0.14.bb b/meta/recipes-core/base-files/base-files_3.0.14.bb
index a1639db830..4b4027f18d 100644
--- a/meta/recipes-core/base-files/base-files_3.0.14.bb
+++ b/meta/recipes-core/base-files/base-files_3.0.14.bb
@@ -134,15 +134,16 @@ do_install () {
134 install -m 0644 ${WORKDIR}/motd ${D}${sysconfdir}/motd 134 install -m 0644 ${WORKDIR}/motd ${D}${sysconfdir}/motd
135 135
136 ln -sf /proc/mounts ${D}${sysconfdir}/mtab 136 ln -sf /proc/mounts ${D}${sysconfdir}/mtab
137}
138 137
139DISTRO_VERSION[vardepsexclude] += "DATE" 138 # deal with hostname
140do_install_basefilesissue () {
141 if [ "${hostname}" ]; then 139 if [ "${hostname}" ]; then
142 echo ${hostname} > ${D}${sysconfdir}/hostname 140 echo ${hostname} > ${D}${sysconfdir}/hostname
143 echo "127.0.1.1 ${hostname}" >> ${D}${sysconfdir}/hosts 141 echo "127.0.1.1 ${hostname}" >> ${D}${sysconfdir}/hosts
144 fi 142 fi
143}
145 144
145DISTRO_VERSION[vardepsexclude] += "DATE"
146do_install_basefilesissue () {
146 install -m 644 ${WORKDIR}/issue* ${D}${sysconfdir} 147 install -m 644 ${WORKDIR}/issue* ${D}${sysconfdir}
147 if [ -n "${DISTRO_NAME}" ]; then 148 if [ -n "${DISTRO_NAME}" ]; then
148 printf "${DISTRO_NAME} " >> ${D}${sysconfdir}/issue 149 printf "${DISTRO_NAME} " >> ${D}${sysconfdir}/issue