summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/base-files/base-files_3.0.14.bb
diff options
context:
space:
mode:
authorElizabeth Flanagan <elizabeth.flanagan@intel.com>2011-12-03 15:48:29 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-12-08 15:24:32 +0000
commit5eeea9e17013c65f3a4dab1b8215ddf2785adb06 (patch)
tree50331fa1155eb73d9c47db27179f52598752c2dc /meta/recipes-core/base-files/base-files_3.0.14.bb
parentcb91ef9310a2450650ec880be6f0fc3a6e2d4a23 (diff)
downloadpoky-5eeea9e17013c65f3a4dab1b8215ddf2785adb06.tar.gz
OECore license fixes: meta/*
This is a quick audit of only the most obviously wrong licenses found within OECore. These fixes fall into four areas: - LICENSE field had incorrect format so that the parser choked - LICENSE field has a license with no version - LICENSE field was actually incorrect - LICENSE field has an imaginary license that didn't exist This fixes most of the LICENSE warnings thrown, along with my prior commit adding additional licenses to common-licenses and additional SPDXLICENSEMAP entries. HOWEVER..... there is much to be done on the license front. For a list of recipes with licenses that need obvious fixing see: https://wiki.yoctoproject.org/wiki/License_Audit That said, I would suggest another license audit as I've found enough inconsistencies. A good suggestion is when in doubt, look at how openSuse or Gentoo or Debian license the package. (From OE-Core rev: 3083dd70b3a9fa01fcc3cf00373b05502505996e) Signed-off-by: Elizabeth Flanagan <elizabeth.flanagan@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/base-files/base-files_3.0.14.bb')
-rw-r--r--meta/recipes-core/base-files/base-files_3.0.14.bb20
1 files changed, 8 insertions, 12 deletions
diff --git a/meta/recipes-core/base-files/base-files_3.0.14.bb b/meta/recipes-core/base-files/base-files_3.0.14.bb
index 8f5313b652..eb40917eb5 100644
--- a/meta/recipes-core/base-files/base-files_3.0.14.bb
+++ b/meta/recipes-core/base-files/base-files_3.0.14.bb
@@ -1,9 +1,15 @@
1SUMMARY = "Miscellaneous files for the base system." 1SUMMARY = "Miscellaneous files for the base system."
2DESCRIPTION = "The base-files package creates the basic system directory structure and provides a small set of key configuration files for the system." 2DESCRIPTION = "The base-files package creates the basic system directory structure and provides a small set of key configuration files for the system."
3SECTION = "base" 3SECTION = "base"
4PR = "r69" 4PR = "r70"
5LICENSE = "GPLv2" 5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://licenses/GPL-2;md5=94d55d512a9ba36caa9b7df079bae19f" 6LIC_FILES_CHKSUM = "file://licenses/GPL-2;md5=94d55d512a9ba36caa9b7df079bae19f"
7# Removed all license related tasks in this recipe as license.bbclass
8# now deals with this. In order to get accurate licensing on to the image:
9# Set COPY_LIC_MANIFEST to just copy just the license.manifest to the image
10# For the manifest and the license text for each package:
11# Set COPY_LIC_MANIFEST and COPY_LIC_DIRS
12
7SRC_URI = "file://rotation \ 13SRC_URI = "file://rotation \
8 file://nsswitch.conf \ 14 file://nsswitch.conf \
9 file://motd \ 15 file://motd \
@@ -18,14 +24,8 @@ SRC_URI = "file://rotation \
18 file://usbd \ 24 file://usbd \
19 file://share/dot.bashrc \ 25 file://share/dot.bashrc \
20 file://share/dot.profile \ 26 file://share/dot.profile \
21 file://licenses/BSD \
22 file://licenses/GPL-2 \ 27 file://licenses/GPL-2 \
23 file://licenses/GPL-3 \ 28 "
24 file://licenses/LGPL-2 \
25 file://licenses/LGPL-2.1 \
26 file://licenses/LGPL-3 \
27 file://licenses/GFDL-1.2 \
28 file://licenses/Artistic"
29S = "${WORKDIR}" 29S = "${WORKDIR}"
30 30
31INHIBIT_DEFAULT_DEPS = "1" 31INHIBIT_DEFAULT_DEPS = "1"
@@ -103,10 +103,6 @@ do_install () {
103 install -m 0644 ${WORKDIR}/host.conf ${D}${sysconfdir}/host.conf 103 install -m 0644 ${WORKDIR}/host.conf ${D}${sysconfdir}/host.conf
104 install -m 0644 ${WORKDIR}/motd ${D}${sysconfdir}/motd 104 install -m 0644 ${WORKDIR}/motd ${D}${sysconfdir}/motd
105 105
106 for license in BSD GPL-2 LGPL-2 LGPL-2.1 Artistic GPL-3 LGPL-3 GFDL-1.2; do
107 install -m 0644 ${WORKDIR}/licenses/$license ${D}${datadir}/common-licenses/
108 done
109
110 ln -sf /proc/mounts ${D}${sysconfdir}/mtab 106 ln -sf /proc/mounts ${D}${sysconfdir}/mtab
111} 107}
112 108