summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/socat/socat_1.7.2.4.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2014-05-31 01:11:55 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-01 14:30:40 +0100
commitae642d3fadb83f641034148d833a5c1deb3a1f10 (patch)
tree74f033b933a0f72a2671043d19fbeb56191f49dc /meta/recipes-connectivity/socat/socat_1.7.2.4.bb
parentfd4a918d88ff07797600af2e4ad514e93dc60267 (diff)
downloadpoky-ae642d3fadb83f641034148d833a5c1deb3a1f10.tar.gz
socat: upgrade to 1.7.2.4
socat manually maintains config.h.in instead of using autoheader, so exclude autoheader from autoreconf and remove all patches that are intended to enable use of autoheader. The license checksum changed, because the company address changed. Based on a upgrade by Hongxu Jia <hongxu.jia@windriver.com>, with cleanup after noticing that config.h.in was hand-maintained. (From OE-Core rev: ea3ec30c19af23f6b62ce3d4d9d42c1fcb23a215) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/socat/socat_1.7.2.4.bb')
-rw-r--r--meta/recipes-connectivity/socat/socat_1.7.2.4.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/socat/socat_1.7.2.4.bb b/meta/recipes-connectivity/socat/socat_1.7.2.4.bb
new file mode 100644
index 0000000000..efa3b91c16
--- /dev/null
+++ b/meta/recipes-connectivity/socat/socat_1.7.2.4.bb
@@ -0,0 +1,37 @@
1SUMMARY = "Multipurpose relay for bidirectional data transfer"
2DESCRIPTION = "Socat is a relay for bidirectional data \
3transfer between two independent data channels."
4HOMEPAGE = "http://www.dest-unreach.org/socat/"
5
6SECTION = "console/network"
7
8DEPENDS = "openssl readline"
9
10LICENSE = "GPL-2.0+-with-OpenSSL-exception"
11LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
12 file://README;beginline=257;endline=287;md5=79246f11a1db0b6ccec54d1fb711c01e"
13
14
15SRC_URI = "http://www.dest-unreach.org/socat/download/socat-${PV}.tar.bz2 \
16 file://fix-cross-compiling-failed.patch \
17"
18
19SRC_URI[md5sum] = "69b8155dd442a6f24e28ef5407d868eb"
20SRC_URI[sha256sum] = "4b7739901c6fad1e460f3e5b1868fb4c2a1427febbba7a510cd2e42fd4941e09"
21
22inherit autotools
23
24EXTRA_AUTORECONF += "--exclude=autoheader"
25
26EXTRA_OECONF += "ac_cv_have_z_modifier=yes sc_cv_sys_crdly_shift=9 \
27 sc_cv_sys_tabdly_shift=11 sc_cv_sys_csize_shift=4 \
28 ac_cv_ispeed_offset=13 \
29"
30
31PACKAGECONFIG ??= "tcp-wrappers"
32PACKAGECONFIG[tcp-wrappers] = "--enable-libwrap,--disable-libwrap,tcp-wrappers"
33
34do_install_prepend () {
35 mkdir -p ${D}${bindir}
36 install -d ${D}${bindir} ${D}${mandir}/man1
37}