summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/openssl/openssl_1.1.0i.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2018-08-28 12:23:14 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-09-04 11:03:56 +0100
commitd9704260def0c2058ea62398cefff2e7574fba37 (patch)
tree1ca189cbc812c64d4a6f07581bb54dfb9fb854ed /meta/recipes-connectivity/openssl/openssl_1.1.0i.bb
parent1343314af942b58fb659b06221d3df6ab299e35c (diff)
downloadpoky-d9704260def0c2058ea62398cefff2e7574fba37.tar.gz
openssl: update to 1.1.1
At the moment 1.1.1 is in pre-release stage, however the final release should be available within a few weeks. The major selling point is that it supports the new TLS 1.3 specification. It will also be the new long term support version. More information: https://www.openssl.org/policies/releasestrat.html (From OE-Core rev: 9f14a32a3b47b83877fe4fa58b13caeeb38f183a) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/openssl/openssl_1.1.0i.bb')
-rw-r--r--meta/recipes-connectivity/openssl/openssl_1.1.0i.bb177
1 files changed, 0 insertions, 177 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl_1.1.0i.bb b/meta/recipes-connectivity/openssl/openssl_1.1.0i.bb
deleted file mode 100644
index a03f6ff336..0000000000
--- a/meta/recipes-connectivity/openssl/openssl_1.1.0i.bb
+++ /dev/null
@@ -1,177 +0,0 @@
1SUMMARY = "Secure Socket Layer"
2DESCRIPTION = "Secure Socket Layer (SSL) binary and related cryptographic tools."
3HOMEPAGE = "http://www.openssl.org/"
4BUGTRACKER = "http://www.openssl.org/news/vulnerabilities.html"
5SECTION = "libs/network"
6
7# "openssl | SSLeay" dual license
8LICENSE = "openssl"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=d57d511030c9d66ef5f5966bee5a7eff"
10
11DEPENDS = "hostperl-runtime-native"
12
13SRC_URI = "http://www.openssl.org/source/openssl-${PV}.tar.gz \
14 file://run-ptest \
15 file://openssl-c_rehash.sh \
16 file://0001-Take-linking-flags-from-LDFLAGS-env-var.patch \
17 file://0001-allow-OPENSSLDIR-and-ENGINESDIR-CFLAGS-to-be-control.patch \
18 "
19
20SRC_URI_append_class-nativesdk = " \
21 file://environment.d-openssl.sh \
22 "
23
24SRC_URI[md5sum] = "9495126aafd2659d357ea66a969c3fe1"
25SRC_URI[sha256sum] = "ebbfc844a8c8cc0ea5dc10b86c9ce97f401837f3fa08c17b2cdadc118253cf99"
26
27inherit lib_package multilib_header ptest
28
29#| ./libcrypto.so: undefined reference to `getcontext'
30#| ./libcrypto.so: undefined reference to `setcontext'
31#| ./libcrypto.so: undefined reference to `makecontext'
32EXTRA_OECONF_append_libc-musl = " -DOPENSSL_NO_ASYNC"
33
34EXTRA_OEMAKE_append_class-native = " OE_DOPENSSLDIR='/not/builtin' OE_DENGINESDIR='/not/builtin'"
35EXTRA_OEMAKE_append_class-nativesdk = " OE_DOPENSSLDIR='/not/builtin' OE_DENGINESDIR='/not/builtin'"
36
37do_configure () {
38 os=${HOST_OS}
39 case $os in
40 linux-gnueabi |\
41 linux-gnuspe |\
42 linux-musleabi |\
43 linux-muslspe |\
44 linux-musl )
45 os=linux
46 ;;
47 *)
48 ;;
49 esac
50 target="$os-${HOST_ARCH}"
51 case $target in
52 linux-arm*)
53 target=linux-armv4
54 ;;
55 linux-aarch64*)
56 target=linux-aarch64
57 ;;
58 linux-i?86 | linux-viac3)
59 target=linux-x86
60 ;;
61 linux-gnux32-x86_64 | linux-muslx32-x86_64 )
62 target=linux-x32
63 ;;
64 linux-gnu64-x86_64)
65 target=linux-x86_64
66 ;;
67 linux-mips | linux-mipsel)
68 # specifying TARGET_CC_ARCH prevents openssl from (incorrectly) adding target architecture flags
69 target="linux-mips32 ${TARGET_CC_ARCH}"
70 ;;
71 linux-gnun32-mips*)
72 target=linux-mips64
73 ;;
74 linux-*-mips64 | linux-mips64 | linux-*-mips64el | linux-mips64el)
75 target=linux64-mips64
76 ;;
77 linux-microblaze* | linux-nios2* | linux-sh3 | linux-sh4)
78 target=linux-generic32
79 ;;
80 linux-powerpc)
81 target=linux-ppc
82 ;;
83 linux-powerpc64)
84 target=linux-ppc64
85 ;;
86 linux-riscv32)
87 target=linux-generic32
88 ;;
89 linux-riscv64)
90 target=linux-generic64
91 ;;
92 linux-sparc | linux-supersparc)
93 target=linux-sparcv9
94 ;;
95 esac
96
97 useprefix=${prefix}
98 if [ "x$useprefix" = "x" ]; then
99 useprefix=/
100 fi
101 libdirleaf="$(echo ${libdir} | sed s:$useprefix::)"
102 perl ./Configure ${EXTRA_OECONF} ${PACKAGECONFIG_CONFARGS} --prefix=$useprefix --openssldir=${libdir}/ssl-1.1 --libdir=$libdirleaf $target
103}
104
105do_install () {
106 oe_runmake DESTDIR="${D}" MANDIR="${mandir}" MANSUFFIX=ssl install
107
108 oe_multilib_header openssl/opensslconf.h
109
110 # Create SSL structure for packages such as ca-certificates which
111 # contain hard-coded paths to /etc/ssl. Debian does the same.
112 install -d ${D}${sysconfdir}/ssl
113 mv ${D}${libdir}/ssl-1.1/certs \
114 ${D}${libdir}/ssl-1.1/private \
115 ${D}${libdir}/ssl-1.1/openssl.cnf \
116 ${D}${sysconfdir}/ssl/
117
118 # Although absolute symlinks would be OK for the target, they become
119 # invalid if native or nativesdk are relocated from sstate.
120 ln -sf ${@oe.path.relative('${libdir}/ssl-1.1', '${sysconfdir}/ssl/certs')} ${D}${libdir}/ssl-1.1/certs
121 ln -sf ${@oe.path.relative('${libdir}/ssl-1.1', '${sysconfdir}/ssl/private')} ${D}${libdir}/ssl-1.1/private
122 ln -sf ${@oe.path.relative('${libdir}/ssl-1.1', '${sysconfdir}/ssl/openssl.cnf')} ${D}${libdir}/ssl-1.1/openssl.cnf
123}
124
125do_install_append_class-native () {
126 create_wrapper ${D}${bindir}/openssl \
127 OPENSSL_CONF=${libdir}/ssl-1.1/openssl.cnf \
128 SSL_CERT_DIR=${libdir}/ssl-1.1/certs \
129 SSL_CERT_FILE=${libdir}/ssl-1.1/cert.pem \
130 OPENSSL_ENGINES=${libdir}/ssl-1.1/engines
131
132 # Install a custom version of c_rehash that can handle sysroots properly.
133 # This version is used for example when installing ca-certificates during
134 # image creation.
135 install -Dm 0755 ${WORKDIR}/openssl-c_rehash.sh ${D}${bindir}/c_rehash
136 sed -i -e 's,/etc/openssl,${sysconfdir}/ssl,g' ${D}${bindir}/c_rehash
137}
138
139do_install_append_class-nativesdk () {
140 mkdir -p ${D}${SDKPATHNATIVE}/environment-setup.d
141 install -m 644 ${WORKDIR}/environment.d-openssl.sh ${D}${SDKPATHNATIVE}/environment-setup.d/openssl.sh
142 sed 's|/usr/lib/ssl/|/usr/lib/ssl-1.1/|g' -i ${D}${SDKPATHNATIVE}/environment-setup.d/openssl.sh
143}
144
145do_install_ptest () {
146 cp -r * ${D}${PTEST_PATH}
147
148 # Putting .so files in ptest package will mess up the dependencies of the main openssl package
149 # so we rename them to .so.ptest and patch the test accordingly
150 mv ${D}${PTEST_PATH}/libcrypto.so ${D}${PTEST_PATH}/libcrypto.so.ptest
151 mv ${D}${PTEST_PATH}/libssl.so ${D}${PTEST_PATH}/libssl.so.ptest
152 sed -i 's/$target{shared_extension_simple}/".so.ptest"/' ${D}${PTEST_PATH}/test/recipes/90-test_shlibload.t
153}
154
155# Add the openssl.cnf file to the openssl-conf package. Make the libcrypto
156# package RRECOMMENDS on this package. This will enable the configuration
157# file to be installed for both the openssl-bin package and the libcrypto
158# package since the openssl-bin package depends on the libcrypto package.
159
160PACKAGES =+ "libcrypto libssl openssl-conf ${PN}-engines ${PN}-misc"
161
162FILES_libcrypto = "${libdir}/libcrypto${SOLIBS}"
163FILES_libssl = "${libdir}/libssl${SOLIBS}"
164FILES_openssl-conf = "${sysconfdir}/ssl/openssl.cnf"
165FILES_${PN}-engines = "${libdir}/engines-1.1"
166FILES_${PN}-misc = "${libdir}/ssl-1.1/misc"
167FILES_${PN} =+ "${libdir}/ssl-1.1/*"
168FILES_${PN}_append_class-nativesdk = " ${SDKPATHNATIVE}/environment-setup.d/openssl.sh"
169
170CONFFILES_openssl-conf = "${sysconfdir}/ssl/openssl.cnf"
171
172RRECOMMENDS_libcrypto += "openssl-conf"
173RDEPENDS_${PN}-bin = "perl"
174RDEPENDS_${PN}-misc = "perl"
175RDEPENDS_${PN}-ptest += "perl-module-file-spec-functions bash python"
176
177BBCLASSEXTEND = "native nativesdk"