summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/openssl/openssl_1.0.2p.bb
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2018-08-16 21:43:33 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-08-20 17:38:23 +0100
commit7e850872d39fae341b0107ab634cb85bc14c4ffa (patch)
treee9badd0aa53f63f3fc93a5ec9c1f209fd8f1f3f6 /meta/recipes-connectivity/openssl/openssl_1.0.2p.bb
parentc64eec1e67b474b446579a1e0f174b584aa48e2f (diff)
downloadpoky-7e850872d39fae341b0107ab634cb85bc14c4ffa.tar.gz
openssl: minor reformatting to align the 1.0 and 1.1 recipes
Formatting and comment tweaks only, no functional changes. (From OE-Core rev: 06da559b5becee1b5fcc2263f6edd95f6d305fc2) Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/openssl/openssl_1.0.2p.bb')
-rw-r--r--meta/recipes-connectivity/openssl/openssl_1.0.2p.bb43
1 files changed, 22 insertions, 21 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl_1.0.2p.bb b/meta/recipes-connectivity/openssl/openssl_1.0.2p.bb
index 5a2593c0ae..1abf8942a6 100644
--- a/meta/recipes-connectivity/openssl/openssl_1.0.2p.bb
+++ b/meta/recipes-connectivity/openssl/openssl_1.0.2p.bb
@@ -223,10 +223,11 @@ do_install () {
223 install -d ${D}${includedir} 223 install -d ${D}${includedir}
224 cp --dereference -R include/openssl ${D}${includedir} 224 cp --dereference -R include/openssl ${D}${includedir}
225 225
226 oe_multilib_header openssl/opensslconf.h
227
226 install -Dm 0755 ${WORKDIR}/openssl-c_rehash.sh ${D}${bindir}/c_rehash 228 install -Dm 0755 ${WORKDIR}/openssl-c_rehash.sh ${D}${bindir}/c_rehash
227 sed -i -e 's,/etc/openssl,${sysconfdir}/ssl,g' ${D}${bindir}/c_rehash 229 sed -i -e 's,/etc/openssl,${sysconfdir}/ssl,g' ${D}${bindir}/c_rehash
228 230
229 oe_multilib_header openssl/opensslconf.h
230 if [ "${@bb.utils.filter('PACKAGECONFIG', 'perl', d)}" ]; then 231 if [ "${@bb.utils.filter('PACKAGECONFIG', 'perl', d)}" ]; then
231 sed -i -e '1s,.*,#!${bindir}/env perl,' ${D}${libdir}/ssl/misc/CA.pl 232 sed -i -e '1s,.*,#!${bindir}/env perl,' ${D}${libdir}/ssl/misc/CA.pl
232 sed -i -e '1s,.*,#!${bindir}/env perl,' ${D}${libdir}/ssl/misc/tsget 233 sed -i -e '1s,.*,#!${bindir}/env perl,' ${D}${libdir}/ssl/misc/tsget
@@ -234,12 +235,12 @@ do_install () {
234 rm -f ${D}${libdir}/ssl/misc/CA.pl ${D}${libdir}/ssl/misc/tsget 235 rm -f ${D}${libdir}/ssl/misc/CA.pl ${D}${libdir}/ssl/misc/tsget
235 fi 236 fi
236 237
237 # Create SSL structure 238 # Create SSL structure for packages such as ca-certificates which
238 install -d ${D}${sysconfdir}/ssl/ 239 # contain hard-coded paths to /etc/ssl. Debian does the same.
239 mv ${D}${libdir}/ssl/openssl.cnf \ 240 install -d ${D}${sysconfdir}/ssl
240 ${D}${libdir}/ssl/certs \ 241 mv ${D}${libdir}/ssl/certs \
241 ${D}${libdir}/ssl/private \ 242 ${D}${libdir}/ssl/private \
242 \ 243 ${D}${libdir}/ssl/openssl.cnf \
243 ${D}${sysconfdir}/ssl/ 244 ${D}${sysconfdir}/ssl/
244 ln -sf ${sysconfdir}/ssl/certs ${D}${libdir}/ssl/certs 245 ln -sf ${sysconfdir}/ssl/certs ${D}${libdir}/ssl/certs
245 ln -sf ${sysconfdir}/ssl/private ${D}${libdir}/ssl/private 246 ln -sf ${sysconfdir}/ssl/private ${D}${libdir}/ssl/private
@@ -256,6 +257,19 @@ do_install () {
256 done 257 done
257} 258}
258 259
260do_install_append_class-native () {
261 create_wrapper ${D}${bindir}/openssl \
262 OPENSSL_CONF=${libdir}/ssl/openssl.cnf \
263 SSL_CERT_DIR=${libdir}/ssl/certs \
264 SSL_CERT_FILE=${libdir}/ssl/cert.pem \
265 OPENSSL_ENGINES=${libdir}/ssl/engines
266}
267
268do_install_append_class-nativesdk () {
269 mkdir -p ${D}${SDKPATHNATIVE}/environment-setup.d
270 install -m 644 ${WORKDIR}/environment.d-openssl.sh ${D}${SDKPATHNATIVE}/environment-setup.d/openssl.sh
271}
272
259do_install_ptest () { 273do_install_ptest () {
260 cp -r -L Makefile.org Makefile test ${D}${PTEST_PATH} 274 cp -r -L Makefile.org Makefile test ${D}${PTEST_PATH}
261 275
@@ -304,21 +318,8 @@ do_install_ptest () {
304 ${D}${PTEST_PATH}/Makefile ${D}${PTEST_PATH}/Configure 318 ${D}${PTEST_PATH}/Makefile ${D}${PTEST_PATH}/Configure
305} 319}
306 320
307do_install_append_class-native() { 321# Add the openssl.cnf file to the openssl-conf package. Make the libcrypto
308 create_wrapper ${D}${bindir}/openssl \ 322# package RRECOMMENDS on this package. This will enable the configuration
309 OPENSSL_CONF=${libdir}/ssl/openssl.cnf \
310 SSL_CERT_DIR=${libdir}/ssl/certs \
311 SSL_CERT_FILE=${libdir}/ssl/cert.pem \
312 OPENSSL_ENGINES=${libdir}/ssl/engines
313}
314
315do_install_append_class-nativesdk() {
316 mkdir -p ${D}${SDKPATHNATIVE}/environment-setup.d
317 install -m 644 ${WORKDIR}/environment.d-openssl.sh ${D}${SDKPATHNATIVE}/environment-setup.d/openssl.sh
318}
319
320# Add the openssl.cnf file to the openssl-conf package. Make the libcrypto
321# package RRECOMMENDS on this package. This will enable the configuration
322# file to be installed for both the base openssl package and the libcrypto 323# file to be installed for both the base openssl package and the libcrypto
323# package since the base openssl package depends on the libcrypto package. 324# package since the base openssl package depends on the libcrypto package.
324 325