summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/openssl/openssl_1.0.2n.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2018-02-01 20:01:54 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-02-19 23:53:34 +0000
commit932ecd6def4b84ac23bebe6c08c214d112028a1f (patch)
tree3410f4b2e8e44af3fa55c3f26e6692dd68bbdc8b /meta/recipes-connectivity/openssl/openssl_1.0.2n.bb
parent5dc6fd13c53bf69fb9ce7c0243e6ea3dd700596d (diff)
downloadpoky-932ecd6def4b84ac23bebe6c08c214d112028a1f.tar.gz
openssl: update to 1.0.2n
Drop upstreamed 0001-aes-armv4-bsaes-armv7-sha256-armv4-.pl-make-it-work-.patch Rebase a couple more patches (via devtool upgrade). (From OE-Core rev: a69526f9cd7682d8a8ff49fd8101b46616e3c05f) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> (cherry picked from commit 8a79b8619ce797d5395989e7bb804bc2accfbb14) Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/openssl/openssl_1.0.2n.bb')
-rw-r--r--meta/recipes-connectivity/openssl/openssl_1.0.2n.bb60
1 files changed, 60 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl_1.0.2n.bb b/meta/recipes-connectivity/openssl/openssl_1.0.2n.bb
new file mode 100644
index 0000000000..32444c6092
--- /dev/null
+++ b/meta/recipes-connectivity/openssl/openssl_1.0.2n.bb
@@ -0,0 +1,60 @@
1require openssl10.inc
2
3# For target side versions of openssl enable support for OCF Linux driver
4# if they are available.
5
6CFLAG += "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS"
7CFLAG_append_class-native = " -fPIC"
8
9LIC_FILES_CHKSUM = "file://LICENSE;md5=057d9218c6180e1d9ee407572b2dd225"
10
11export DIRS = "crypto ssl apps engines"
12export OE_LDFLAGS="${LDFLAGS}"
13
14SRC_URI += "file://find.pl;subdir=openssl-${PV}/util/ \
15 file://run-ptest \
16 file://openssl-c_rehash.sh \
17 file://configure-targets.patch \
18 file://shared-libs.patch \
19 file://oe-ldflags.patch \
20 file://engines-install-in-libdir-ssl.patch \
21 file://debian1.0.2/block_diginotar.patch \
22 file://debian1.0.2/block_digicert_malaysia.patch \
23 file://debian/ca.patch \
24 file://debian/c_rehash-compat.patch \
25 file://debian/debian-targets.patch \
26 file://debian/man-dir.patch \
27 file://debian/man-section.patch \
28 file://debian/no-rpath.patch \
29 file://debian/no-symbolic.patch \
30 file://debian/pic.patch \
31 file://debian1.0.2/version-script.patch \
32 file://debian1.0.2/soname.patch \
33 file://openssl_fix_for_x32.patch \
34 file://openssl-fix-des.pod-error.patch \
35 file://Makefiles-ptest.patch \
36 file://ptest-deps.patch \
37 file://openssl-1.0.2a-x32-asm.patch \
38 file://ptest_makefile_deps.patch \
39 file://configure-musl-target.patch \
40 file://parallel.patch \
41 file://openssl-util-perlpath.pl-cwd.patch \
42 file://Use-SHA256-not-MD5-as-default-digest.patch \
43 file://0001-Fix-build-with-clang-using-external-assembler.patch \
44 file://0001-openssl-force-soft-link-to-avoid-rare-race.patch \
45 "
46SRC_URI[md5sum] = "13bdc1b1d1ff39b6fd42a255e74676a4"
47SRC_URI[sha256sum] = "370babb75f278c39e0c50e8c4e7493bc0f18db6867478341a832a982fd15a8fe"
48
49PACKAGES =+ "${PN}-engines"
50FILES_${PN}-engines = "${libdir}/ssl/engines/*.so ${libdir}/engines"
51
52# The crypto_use_bigint patch means that perl's bignum module needs to be
53# installed, but some distributions (for example Fedora 23) don't ship it by
54# default. As the resulting error is very misleading check for bignum before
55# building.
56do_configure_prepend() {
57 if ! perl -Mbigint -e true; then
58 bbfatal "The perl module 'bignum' was not found but this is required to build openssl. Please install this module (often packaged as perl-bignum) and re-run bitbake."
59 fi
60}