summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/openssl/openssl_1.0.1m.bb
diff options
context:
space:
mode:
authorBrendan Le Foll <brendan.le.foll@intel.com>2015-03-24 18:14:58 +0000
committerTudor Florea <tudor.florea@enea.com>2015-07-06 20:19:39 +0200
commitd5bf0a0a55a7f7b2c0b05a53f12efc30ab3e212b (patch)
tree0f12816bf8f15cbc2a1b3bd45c7fa50df9524ecc /meta/recipes-connectivity/openssl/openssl_1.0.1m.bb
parentaafccf82fe53b9c7a7de4f9df2a6de221c513e22 (diff)
downloadpoky-d5bf0a0a55a7f7b2c0b05a53f12efc30ab3e212b.tar.gz
openssl: Upgrade to 1.0.1m
Security update, some patches modified to apply correctly mostly due to upstream changing indentation/styling * configure-targets.patch updated * fix-cipher-des-ede3-cfb1.patch updated * openssl-avoid-NULL-pointer-dereference-in-EVP_DigestInit_ex.patch updated * openssl-avoid-NULL-pointer-dereference-in-dh_pub_encode.patch removed as no merged with 3942e7d9ebc262fa5c5c42aba0167e06d981f004 in upstream (From OE-Core rev: 248dec5e550cfcaaaa479a5bff9b79ba5cd0765d) Signed-off-by: Brendan Le Foll <brendan.le.foll@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Sona Sarmadi <sona.sarmadi@enea.com>
Diffstat (limited to 'meta/recipes-connectivity/openssl/openssl_1.0.1m.bb')
-rw-r--r--meta/recipes-connectivity/openssl/openssl_1.0.1m.bb56
1 files changed, 56 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl_1.0.1m.bb b/meta/recipes-connectivity/openssl/openssl_1.0.1m.bb
new file mode 100644
index 0000000000..cab6b3fdf4
--- /dev/null
+++ b/meta/recipes-connectivity/openssl/openssl_1.0.1m.bb
@@ -0,0 +1,56 @@
1require openssl.inc
2
3# For target side versions of openssl enable support for OCF Linux driver
4# if they are available.
5DEPENDS += "cryptodev-linux"
6
7CFLAG += "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS"
8
9LIC_FILES_CHKSUM = "file://LICENSE;md5=f9a8f968107345e0b75aa8c2ecaa7ec8"
10
11export DIRS = "crypto ssl apps engines"
12export OE_LDFLAGS="${LDFLAGS}"
13
14SRC_URI += "file://configure-targets.patch \
15 file://shared-libs.patch \
16 file://oe-ldflags.patch \
17 file://engines-install-in-libdir-ssl.patch \
18 file://openssl-fix-link.patch \
19 file://debian/version-script.patch \
20 file://debian/pic.patch \
21 file://debian/c_rehash-compat.patch \
22 file://debian/ca.patch \
23 file://debian/make-targets.patch \
24 file://debian/no-rpath.patch \
25 file://debian/man-dir.patch \
26 file://debian/man-section.patch \
27 file://debian/no-symbolic.patch \
28 file://debian/debian-targets.patch \
29 file://openssl_fix_for_x32.patch \
30 file://fix-cipher-des-ede3-cfb1.patch \
31 file://openssl-avoid-NULL-pointer-dereference-in-EVP_DigestInit_ex.patch \
32 file://initial-aarch64-bits.patch \
33 file://find.pl \
34 file://openssl-fix-des.pod-error.patch \
35 file://Makefiles-ptest.patch \
36 file://ptest-deps.patch \
37 file://run-ptest \
38 "
39
40SRC_URI[md5sum] = "d143d1555d842a069cb7cc34ba745a06"
41SRC_URI[sha256sum] = "095f0b7b09116c0c5526422088058dc7e6e000aa14d22acca6a4e2babcdfef74"
42
43PACKAGES =+ " \
44 ${PN}-engines \
45 ${PN}-engines-dbg \
46 "
47
48FILES_${PN}-engines = "${libdir}/ssl/engines/*.so ${libdir}/engines"
49FILES_${PN}-engines-dbg = "${libdir}/ssl/engines/.debug"
50
51PARALLEL_MAKE = ""
52PARALLEL_MAKEINST = ""
53
54do_configure_prepend() {
55 cp ${WORKDIR}/find.pl ${S}/util/find.pl
56}