summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/openssl/openssl_1.0.1g.bb
diff options
context:
space:
mode:
authorCristiana Voicu <cristiana.voicu@intel.com>2014-04-08 14:49:48 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-04-08 17:45:09 +0100
commit5dd1d7566964c90d33c0c44f569d9336fb0724ce (patch)
tree6c9516db6873f1254723cbeeca204a43d5d410ba /meta/recipes-connectivity/openssl/openssl_1.0.1g.bb
parentc0ac09ab49d7a2b9cc7601ceef2852d690cdf3d1 (diff)
downloadpoky-5dd1d7566964c90d33c0c44f569d9336fb0724ce.tar.gz
openssl: Upgrade to v1.0.1g
The trigger for the upgrade was the serious "heartbleed" vulnerability (CVE-2014-0160). More information: http://www.itnews.com.au/News/382068,serious-openssl-bug-renders-websites-wide-open.aspx Dropped obsolete patches, because the new version contains them: 0001-Fix-for-TLS-record-tampering-bug-CVE-2013-4353.patch 0001-Fix-DTLS-retransmission-from-previous-session.patch 0001-Use-version-in-SSL_METHOD-not-SSL-structure.patch Modified 2 patches (small changes), in order to apply properly: initial-aarch64-bits.patch openssl-fix-doc.patch Addresses CVEs: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-0160 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-0076 (From OE-Core rev: ff52836e1838590eeec7d7658e15b21d83cf8455) Signed-off-by: Cristiana Voicu <cristiana.voicu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/openssl/openssl_1.0.1g.bb')
-rw-r--r--meta/recipes-connectivity/openssl/openssl_1.0.1g.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl_1.0.1g.bb b/meta/recipes-connectivity/openssl/openssl_1.0.1g.bb
new file mode 100644
index 0000000000..f3c20e8c97
--- /dev/null
+++ b/meta/recipes-connectivity/openssl/openssl_1.0.1g.bb
@@ -0,0 +1,55 @@
1require openssl.inc
2
3# For target side versions of openssl enable support for OCF Linux driver
4# if they are available.
5DEPENDS += "cryptodev-linux"
6
7CFLAG += "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS"
8
9LIC_FILES_CHKSUM = "file://LICENSE;md5=f9a8f968107345e0b75aa8c2ecaa7ec8"
10
11export DIRS = "crypto ssl apps engines"
12export OE_LDFLAGS="${LDFLAGS}"
13
14SRC_URI += "file://configure-targets.patch \
15 file://shared-libs.patch \
16 file://oe-ldflags.patch \
17 file://engines-install-in-libdir-ssl.patch \
18 file://openssl-fix-link.patch \
19 file://debian/version-script.patch \
20 file://debian/pic.patch \
21 file://debian/c_rehash-compat.patch \
22 file://debian/ca.patch \
23 file://debian/make-targets.patch \
24 file://debian/no-rpath.patch \
25 file://debian/man-dir.patch \
26 file://debian/man-section.patch \
27 file://debian/no-symbolic.patch \
28 file://debian/debian-targets.patch \
29 file://openssl_fix_for_x32.patch \
30 file://openssl-fix-doc.patch \
31 file://fix-cipher-des-ede3-cfb1.patch \
32 file://openssl-avoid-NULL-pointer-dereference-in-EVP_DigestInit_ex.patch \
33 file://openssl-avoid-NULL-pointer-dereference-in-dh_pub_encode.patch \
34 file://initial-aarch64-bits.patch \
35 file://find.pl \
36 file://openssl-fix-des.pod-error.patch \
37 "
38
39SRC_URI[md5sum] = "de62b43dfcd858e66a74bee1c834e959"
40SRC_URI[sha256sum] = "53cb818c3b90e507a8348f4f5eaedb05d8bfe5358aabb508b7263cc670c3e028"
41
42PACKAGES =+ " \
43 ${PN}-engines \
44 ${PN}-engines-dbg \
45 "
46
47FILES_${PN}-engines = "${libdir}/ssl/engines/*.so ${libdir}/engines"
48FILES_${PN}-engines-dbg = "${libdir}/ssl/engines/.debug"
49
50PARALLEL_MAKE = ""
51PARALLEL_MAKEINST = ""
52
53do_configure_prepend() {
54 cp ${WORKDIR}/find.pl ${S}/util/find.pl
55}