summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/openssl/openssl_1.0.1g.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2014-06-09 10:36:34 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-10 17:11:55 +0100
commit3255d58577234b130768d6d57619cc76b6afcc6a (patch)
tree74ce2fcb911f84101ea99f8b1e6fe18046c55f25 /meta/recipes-connectivity/openssl/openssl_1.0.1g.bb
parent66d5be204fd339cc84a0ae92d3923a8c1e6f1389 (diff)
downloadpoky-3255d58577234b130768d6d57619cc76b6afcc6a.tar.gz
openssl: upgrade to 1.0.1h
Fixes the following security issues: * CVE-2014-0224 * CVE-2014-0221 * CVE-2014-0195 * CVE-2014-3470 The patch for CVE-2010-5298, CVE-2014-0198 and a fix for building the documentation are integrated upstream in this release and so were dropped. Additionally, a patch from upstream was added in order to fix a failure during do_compile_ptest_base. A similar upgrade was also submitted by Yao Xinpan <yaoxp@cn.fujitsu.com> and Lei Maohui <leimaohui@cn.fujitsu.com>. (From OE-Core rev: a3e80de6d423c272a287bf3538196b48ac5ddec1) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/openssl/openssl_1.0.1g.bb')
-rw-r--r--meta/recipes-connectivity/openssl/openssl_1.0.1g.bb59
1 files changed, 0 insertions, 59 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl_1.0.1g.bb b/meta/recipes-connectivity/openssl/openssl_1.0.1g.bb
deleted file mode 100644
index bbf1455f7d..0000000000
--- a/meta/recipes-connectivity/openssl/openssl_1.0.1g.bb
+++ /dev/null
@@ -1,59 +0,0 @@
1require openssl.inc
2
3# For target side versions of openssl enable support for OCF Linux driver
4# if they are available.
5DEPENDS += "cryptodev-linux"
6
7CFLAG += "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS"
8
9LIC_FILES_CHKSUM = "file://LICENSE;md5=f9a8f968107345e0b75aa8c2ecaa7ec8"
10
11export DIRS = "crypto ssl apps engines"
12export OE_LDFLAGS="${LDFLAGS}"
13
14SRC_URI += "file://configure-targets.patch \
15 file://shared-libs.patch \
16 file://oe-ldflags.patch \
17 file://engines-install-in-libdir-ssl.patch \
18 file://openssl-fix-link.patch \
19 file://debian/version-script.patch \
20 file://debian/pic.patch \
21 file://debian/c_rehash-compat.patch \
22 file://debian/ca.patch \
23 file://debian/make-targets.patch \
24 file://debian/no-rpath.patch \
25 file://debian/man-dir.patch \
26 file://debian/man-section.patch \
27 file://debian/no-symbolic.patch \
28 file://debian/debian-targets.patch \
29 file://openssl_fix_for_x32.patch \
30 file://openssl-fix-doc.patch \
31 file://fix-cipher-des-ede3-cfb1.patch \
32 file://openssl-avoid-NULL-pointer-dereference-in-EVP_DigestInit_ex.patch \
33 file://openssl-avoid-NULL-pointer-dereference-in-dh_pub_encode.patch \
34 file://initial-aarch64-bits.patch \
35 file://find.pl \
36 file://openssl-fix-des.pod-error.patch \
37 file://openssl-CVE-2014-0198-fix.patch \
38 file://Makefiles-ptest.patch \
39 file://run-ptest \
40 file://openssl-CVE-2010-5298.patch \
41 "
42
43SRC_URI[md5sum] = "de62b43dfcd858e66a74bee1c834e959"
44SRC_URI[sha256sum] = "53cb818c3b90e507a8348f4f5eaedb05d8bfe5358aabb508b7263cc670c3e028"
45
46PACKAGES =+ " \
47 ${PN}-engines \
48 ${PN}-engines-dbg \
49 "
50
51FILES_${PN}-engines = "${libdir}/ssl/engines/*.so ${libdir}/engines"
52FILES_${PN}-engines-dbg = "${libdir}/ssl/engines/.debug"
53
54PARALLEL_MAKE = ""
55PARALLEL_MAKEINST = ""
56
57do_configure_prepend() {
58 cp ${WORKDIR}/find.pl ${S}/util/find.pl
59}