summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/openssl/cryptodev-linux_1.6.bb
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2014-03-26 18:15:57 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-27 15:46:51 +0000
commitb895ee7407bac338f6235215ce52e6c51169a55e (patch)
tree90effaef919da6de3812ed4088380b3fc262e9c2 /meta/recipes-connectivity/openssl/cryptodev-linux_1.6.bb
parentcbefaa3e3160aed390722b301e909f72b22dbbb8 (diff)
downloadpoky-b895ee7407bac338f6235215ce52e6c51169a55e.tar.gz
cryptodev-linux: add recipe
Yocto kernel linux-yocto uses cryptodev-linux to use device /dev/crypto. So add cryptodev-linux which is one alternative of ocf-linux and then remove ocf-linux later. (From OE-Core rev: 6b6c24eccdb0030ecccadefe94c1c5b4387e46d1) Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/openssl/cryptodev-linux_1.6.bb')
-rw-r--r--meta/recipes-connectivity/openssl/cryptodev-linux_1.6.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/openssl/cryptodev-linux_1.6.bb b/meta/recipes-connectivity/openssl/cryptodev-linux_1.6.bb
new file mode 100644
index 0000000000..320716d6aa
--- /dev/null
+++ b/meta/recipes-connectivity/openssl/cryptodev-linux_1.6.bb
@@ -0,0 +1,22 @@
1SUMMARY = "A /dev/crypto device driver"
2HOMEPAGE = "http://cryptodev-linux.org/"
3
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6
7SRC_URI = "http://download.gna.org/cryptodev-linux/${BPN}-${PV}.tar.gz"
8
9SRC_URI[md5sum] = "eade38998313c25fd7934719cdf8a2ea"
10SRC_URI[sha256sum] = "75f1425c8ea1f8cae523905a5a046a35092327a6152800b0b86efc4e56fb3e2f"
11
12do_compile() {
13 :
14}
15
16# Just install cryptodev.h which is the only header file needed to be exported
17do_install() {
18 install -D ${S}/crypto/cryptodev.h ${D}${includedir}/crypto/cryptodev.h
19}
20
21ALLOW_EMPTY_${PN} = "1"
22BBCLASSEXTEND = "native nativesdk"