summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/openssh/openssh_6.2p2.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2013-10-28 16:44:39 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-10-29 10:41:36 +0000
commit4a8d62ca86d7a8027afcb41a67a5a78183507b8c (patch)
treebe18943e44069b8f2a56ab9818adb47044fdf580 /meta/recipes-connectivity/openssh/openssh_6.2p2.bb
parent9c01b3bf75b166d0fc8e1b794ff20aedd4fbfe42 (diff)
downloadpoky-4a8d62ca86d7a8027afcb41a67a5a78183507b8c.tar.gz
openssh: upgrade to 6.3p1
Removed the following backported patch(es): * mac.patch (From OE-Core rev: ce04ba6a5385ad2d021d472cf9236787c6ea7357) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/openssh/openssh_6.2p2.bb')
-rw-r--r--meta/recipes-connectivity/openssh/openssh_6.2p2.bb138
1 files changed, 0 insertions, 138 deletions
diff --git a/meta/recipes-connectivity/openssh/openssh_6.2p2.bb b/meta/recipes-connectivity/openssh/openssh_6.2p2.bb
deleted file mode 100644
index bb5c79eb5b..0000000000
--- a/meta/recipes-connectivity/openssh/openssh_6.2p2.bb
+++ /dev/null
@@ -1,138 +0,0 @@
1SUMMARY = "Secure rlogin/rsh/rcp/telnet replacement"
2DESCRIPTION = "Secure rlogin/rsh/rcp/telnet replacement (OpenSSH) \
3Ssh (Secure Shell) is a program for logging into a remote machine \
4and for executing commands on a remote machine."
5HOMEPAGE = "http://openssh.org"
6SECTION = "console/network"
7LICENSE = "BSD"
8LIC_FILES_CHKSUM = "file://LICENCE;md5=e326045657e842541d3f35aada442507"
9
10PR = "r0"
11
12DEPENDS = "zlib openssl"
13DEPENDS += "${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
14
15RPROVIDES_${PN}-ssh = "ssh"
16RPROVIDES_${PN}-sshd = "sshd"
17
18RCONFLICTS_${PN} = "dropbear"
19RCONFLICTS_${PN}-sshd = "dropbear"
20RCONFLICTS_${PN}-keygen = "ssh-keygen"
21
22SRC_URI = "ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-${PV}.tar.gz \
23 file://nostrip.patch \
24 file://sshd_config \
25 file://ssh_config \
26 file://init \
27 file://openssh-CVE-2011-4327.patch \
28 file://mac.patch \
29 ${@base_contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)} \
30 file://sshd.socket \
31 file://sshd@.service \
32 file://sshdgenkeys.service \
33 file://volatiles.99_sshd "
34
35PAM_SRC_URI = "file://sshd"
36
37SRC_URI[md5sum] = "be46174dcbb77ebb4ea88ef140685de1"
38SRC_URI[sha256sum] = "7f29b9d2ad672ae0f9e1dcbff871fc5c2e60a194e90c766432e32161b842313b"
39
40inherit useradd update-rc.d update-alternatives systemd
41
42USERADD_PACKAGES = "${PN}-sshd"
43USERADD_PARAM_${PN}-sshd = "--system --no-create-home --home-dir /var/run/sshd --shell /bin/false --user-group sshd"
44INITSCRIPT_PACKAGES = "${PN}-sshd"
45INITSCRIPT_NAME_${PN}-sshd = "sshd"
46INITSCRIPT_PARAMS_${PN}-sshd = "defaults 9"
47
48SYSTEMD_PACKAGES = "${PN}-sshd"
49SYSTEMD_SERVICE_${PN}-sshd = "sshd.socket sshd@.service sshdgenkeys.service"
50
51PACKAGECONFIG ??= "tcp-wrappers"
52PACKAGECONFIG[tcp-wrappers] = "--with-tcp-wrappers,,tcp-wrappers"
53
54inherit autotools
55
56# LFS support:
57CFLAGS += "-D__FILE_OFFSET_BITS=64"
58export LD = "${CC}"
59
60EXTRA_OECONF = "--with-rand-helper=no \
61 ${@base_contains('DISTRO_FEATURES', 'pam', '--with-pam', '--without-pam', d)} \
62 --without-zlib-version-check \
63 --with-privsep-path=/var/run/sshd \
64 --sysconfdir=${sysconfdir}/ssh \
65 --with-xauth=/usr/bin/xauth"
66
67# This is a workaround for uclibc because including stdio.h
68# pulls in pthreads.h and causes conflicts in function prototypes.
69# This results in compilation failure, so unless this is fixed,
70# disable pam for uclibc.
71EXTRA_OECONF_append_libc-uclibc=" --without-pam"
72
73do_configure_prepend () {
74 if [ ! -e acinclude.m4 -a -e aclocal.m4 ]; then
75 cp aclocal.m4 acinclude.m4
76 fi
77}
78
79do_compile_append () {
80 install -m 0644 ${WORKDIR}/sshd_config ${S}/
81 install -m 0644 ${WORKDIR}/ssh_config ${S}/
82}
83
84do_install_append () {
85 for i in ${DISTRO_FEATURES};
86 do
87 if [ ${i} = "pam" ]; then
88 install -d ${D}${sysconfdir}/pam.d
89 install -m 0755 ${WORKDIR}/sshd ${D}${sysconfdir}/pam.d/sshd
90 fi
91 done
92 install -d ${D}${sysconfdir}/init.d
93 install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/sshd
94 rm -f ${D}${bindir}/slogin ${D}${datadir}/Ssh.bin
95 rmdir ${D}${localstatedir}/run/sshd ${D}${localstatedir}/run ${D}${localstatedir}
96 install -d ${D}/${sysconfdir}/default/volatiles
97 install -m 644 ${WORKDIR}/volatiles.99_sshd ${D}/${sysconfdir}/default/volatiles/99_sshd
98
99 # Create config files for read-only rootfs
100 install -d ${D}${sysconfdir}/ssh
101 install -m 644 ${WORKDIR}/sshd_config ${D}${sysconfdir}/ssh/sshd_config_readonly
102 sed -i '/HostKey/d' ${D}${sysconfdir}/ssh/sshd_config_readonly
103 echo "HostKey /var/run/ssh/ssh_host_rsa_key" >> ${D}${sysconfdir}/ssh/sshd_config_readonly
104 echo "HostKey /var/run/ssh/ssh_host_dsa_key" >> ${D}${sysconfdir}/ssh/sshd_config_readonly
105 echo "HostKey /var/run/ssh/ssh_host_ecdsa_key" >> ${D}${sysconfdir}/ssh/sshd_config_readonly
106
107 install -d ${D}${systemd_unitdir}/system
108 install -c -m 0644 ${WORKDIR}/sshd.socket ${D}${systemd_unitdir}/system
109 install -c -m 0644 ${WORKDIR}/sshd@.service ${D}${systemd_unitdir}/system
110 install -c -m 0644 ${WORKDIR}/sshdgenkeys.service ${D}${systemd_unitdir}/system
111 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \
112 -e 's,@SBINDIR@,${sbindir},g' \
113 -e 's,@BINDIR@,${bindir},g' \
114 ${D}${systemd_unitdir}/system/sshd.socket ${D}${systemd_unitdir}/system/*.service
115}
116
117ALLOW_EMPTY_${PN} = "1"
118
119PACKAGES =+ "${PN}-keygen ${PN}-scp ${PN}-ssh ${PN}-sshd ${PN}-sftp ${PN}-misc ${PN}-sftp-server"
120FILES_${PN}-scp = "${bindir}/scp.${BPN}"
121FILES_${PN}-ssh = "${bindir}/ssh.${BPN} ${sysconfdir}/ssh/ssh_config"
122FILES_${PN}-sshd = "${sbindir}/sshd ${sysconfdir}/init.d/sshd"
123FILES_${PN}-sshd += "${sysconfdir}/ssh/moduli ${sysconfdir}/ssh/sshd_config ${sysconfdir}/ssh/sshd_config_readonly ${sysconfdir}/default/volatiles/99_sshd"
124FILES_${PN}-sftp = "${bindir}/sftp"
125FILES_${PN}-sftp-server = "${libexecdir}/sftp-server"
126FILES_${PN}-misc = "${bindir}/ssh* ${libexecdir}/ssh*"
127FILES_${PN}-keygen = "${bindir}/ssh-keygen"
128
129RDEPENDS_${PN} += "${PN}-scp ${PN}-ssh ${PN}-sshd ${PN}-keygen"
130RDEPENDS_${PN}-sshd += "${PN}-keygen"
131
132CONFFILES_${PN}-sshd = "${sysconfdir}/ssh/sshd_config"
133CONFFILES_${PN}-ssh = "${sysconfdir}/ssh/ssh_config"
134
135ALTERNATIVE_PRIORITY = "90"
136ALTERNATIVE_${PN}-scp = "scp"
137ALTERNATIVE_${PN}-ssh = "ssh"
138