summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/ofono/ofono_1.31.bb
diff options
context:
space:
mode:
authorOleksandr Kravchuk <open.source@oleksandr-kravchuk.com>2019-10-31 19:35:48 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-11-04 13:39:05 +0000
commit6c7ceeab99e3c00a2a99b932f4c8e8edb30512cb (patch)
treee951a6be1b5990b744cad04d26baa18b85df880f /meta/recipes-connectivity/ofono/ofono_1.31.bb
parentf03d4a72f08c7d0247ea4f122ffce4e924dc59aa (diff)
downloadpoky-6c7ceeab99e3c00a2a99b932f4c8e8edb30512cb.tar.gz
ofono: update to 1.31
Changelog: - Fix issue with handling CID 0 context identifier - Fix issue with handling detach state and running LTE - Fix issue with handling SIM states and Quectel modems (From OE-Core rev: afda6f8a4c0f43316aabb11f02fc114f607d5f35) Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/ofono/ofono_1.31.bb')
-rw-r--r--meta/recipes-connectivity/ofono/ofono_1.31.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/ofono/ofono_1.31.bb b/meta/recipes-connectivity/ofono/ofono_1.31.bb
new file mode 100644
index 0000000000..7d0976ad7f
--- /dev/null
+++ b/meta/recipes-connectivity/ofono/ofono_1.31.bb
@@ -0,0 +1,50 @@
1SUMMARY = "open source telephony"
2DESCRIPTION = "oFono is a stack for mobile telephony devices on Linux. oFono supports speaking to telephony devices through specific drivers, or with generic AT commands."
3HOMEPAGE = "http://www.ofono.org"
4BUGTRACKER = "https://01.org/jira/browse/OF"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a \
7 file://src/ofono.h;beginline=1;endline=20;md5=3ce17d5978ef3445def265b98899c2ee"
8DEPENDS = "dbus glib-2.0 udev mobile-broadband-provider-info ell"
9
10SRC_URI = "\
11 ${KERNELORG_MIRROR}/linux/network/${BPN}/${BP}.tar.xz \
12 file://ofono \
13 file://0001-mbim-add-an-optional-TEMP_FAILURE_RETRY-macro-copy.patch \
14"
15SRC_URI[md5sum] = "1c26340e3c6ed132cc812595081bb3dc"
16SRC_URI[sha256sum] = "a15c5d28096c10eb30e47a68b6dc2e7c4a5a99d7f4cfedf0b69624f33d859e9b"
17
18inherit autotools pkgconfig update-rc.d systemd gobject-introspection-data
19
20INITSCRIPT_NAME = "ofono"
21INITSCRIPT_PARAMS = "defaults 22"
22SYSTEMD_SERVICE_${PN} = "ofono.service"
23
24PACKAGECONFIG ??= "\
25 ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
26 ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \
27"
28PACKAGECONFIG[systemd] = "--with-systemdunitdir=${systemd_unitdir}/system/,--with-systemdunitdir="
29PACKAGECONFIG[bluez] = "--enable-bluetooth, --disable-bluetooth, bluez5"
30
31EXTRA_OECONF += "--enable-test --enable-external-ell"
32
33do_install_append() {
34 install -d ${D}${sysconfdir}/init.d/
35 install -m 0755 ${WORKDIR}/ofono ${D}${sysconfdir}/init.d/ofono
36}
37
38PACKAGES =+ "${PN}-tests"
39
40FILES_${PN} += "${systemd_unitdir}"
41FILES_${PN}-tests = "${libdir}/${BPN}/test"
42
43RDEPENDS_${PN} += "dbus"
44RDEPENDS_${PN}-tests = "\
45 python3-core \
46 python3-dbus \
47 ${@bb.utils.contains('GI_DATA_ENABLED', 'True', 'python3-pygobject', '', d)} \
48"
49
50RRECOMMENDS_${PN} += "kernel-module-tun mobile-broadband-provider-info"