summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/nfs-utils/nfs-utils_2.4.2.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@cn.fujitsu.com>2020-02-20 01:41:34 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-02-21 09:39:00 +0000
commit028d5c616dce1bd2839a9d9a7eab9434b487ec2b (patch)
tree40d8fc245800d4e18df60b3803c7d3a131a6780e /meta/recipes-connectivity/nfs-utils/nfs-utils_2.4.2.bb
parent523b2bbb084bee28d6bde1aac37ef5252d95f918 (diff)
downloadpoky-028d5c616dce1bd2839a9d9a7eab9434b487ec2b.tar.gz
nfs-utils: upgrade 2.4.2 -> 2.4.3
0001-Don-t-build-tools-with-CC_FOR_BUILD.patch Removed since it is included in 2.4.3. refresh the following patch: 0001-Makefile.am-fix-undefined-function-for-libnsm.a.patch (From OE-Core rev: fcaca33d458449379eeb2f99b613f8be1e6a44ce) Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/nfs-utils/nfs-utils_2.4.2.bb')
-rw-r--r--meta/recipes-connectivity/nfs-utils/nfs-utils_2.4.2.bb146
1 files changed, 0 insertions, 146 deletions
diff --git a/meta/recipes-connectivity/nfs-utils/nfs-utils_2.4.2.bb b/meta/recipes-connectivity/nfs-utils/nfs-utils_2.4.2.bb
deleted file mode 100644
index 6647d3428b..0000000000
--- a/meta/recipes-connectivity/nfs-utils/nfs-utils_2.4.2.bb
+++ /dev/null
@@ -1,146 +0,0 @@
1SUMMARY = "userspace utilities for kernel nfs"
2DESCRIPTION = "The nfs-utils package provides a daemon for the kernel \
3NFS server and related tools."
4HOMEPAGE = "http://nfs.sourceforge.net/"
5SECTION = "console/network"
6
7LICENSE = "MIT & GPLv2+ & BSD"
8LIC_FILES_CHKSUM = "file://COPYING;md5=95f3a93a5c3c7888de623b46ea085a84"
9
10# util-linux for libblkid
11DEPENDS = "libcap libevent util-linux sqlite3 libtirpc"
12RDEPENDS_${PN} = "${PN}-client"
13RRECOMMENDS_${PN} = "kernel-module-nfsd"
14
15inherit useradd
16
17USERADD_PACKAGES = "${PN}-client"
18USERADD_PARAM_${PN}-client = "--system --home-dir /var/lib/nfs \
19 --shell /bin/false --user-group rpcuser"
20
21SRC_URI = "${KERNELORG_MIRROR}/linux/utils/nfs-utils/${PV}/nfs-utils-${PV}.tar.xz \
22 file://nfsserver \
23 file://nfscommon \
24 file://nfs-utils.conf \
25 file://nfs-server.service \
26 file://nfs-mountd.service \
27 file://nfs-statd.service \
28 file://proc-fs-nfsd.mount \
29 file://nfs-utils-debianize-start-statd.patch \
30 file://bugfix-adjust-statd-service-name.patch \
31 file://0001-cacheio-use-intmax_t-for-formatted-IO.patch \
32 file://0001-Makefile.am-fix-undefined-function-for-libnsm.a.patch \
33 file://0001-Don-t-build-tools-with-CC_FOR_BUILD.patch \
34 file://clang-warnings.patch \
35 "
36SRC_URI[md5sum] = "d427c6b3014e9a04e8498f0598b1c1b9"
37SRC_URI[sha256sum] = "4464737a03d5f73ded2ffefe19d5543ed7b1d6c541985d8acaafdc8025aa1038"
38
39# Only kernel-module-nfsd is required here (but can be built-in) - the nfsd module will
40# pull in the remainder of the dependencies.
41
42INITSCRIPT_PACKAGES = "${PN} ${PN}-client"
43INITSCRIPT_NAME = "nfsserver"
44INITSCRIPT_PARAMS = "defaults"
45INITSCRIPT_NAME_${PN}-client = "nfscommon"
46INITSCRIPT_PARAMS_${PN}-client = "defaults 19 21"
47
48inherit autotools-brokensep update-rc.d systemd pkgconfig
49
50SYSTEMD_PACKAGES = "${PN} ${PN}-client"
51SYSTEMD_SERVICE_${PN} = "nfs-server.service nfs-mountd.service"
52SYSTEMD_SERVICE_${PN}-client = "nfs-statd.service"
53
54# --enable-uuid is need for cross-compiling
55EXTRA_OECONF = "--with-statduser=rpcuser \
56 --enable-mountconfig \
57 --enable-libmount-mount \
58 --enable-uuid \
59 --disable-gss \
60 --disable-nfsdcltrack \
61 --with-statdpath=/var/lib/nfs/statd \
62 "
63
64PACKAGECONFIG ??= "tcp-wrappers \
65 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
66"
67PACKAGECONFIG_remove_libc-musl = "tcp-wrappers"
68PACKAGECONFIG[tcp-wrappers] = "--with-tcp-wrappers,--without-tcp-wrappers,tcp-wrappers"
69PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
70# libdevmapper is available in meta-oe
71PACKAGECONFIG[nfsv41] = "--enable-nfsv41,--disable-nfsv41,libdevmapper"
72# keyutils is available in meta-security
73PACKAGECONFIG[nfsv4] = "--enable-nfsv4,--disable-nfsv4,keyutils"
74
75PACKAGES =+ "${PN}-client ${PN}-mount ${PN}-stats"
76
77CONFFILES_${PN}-client += "${localstatedir}/lib/nfs/etab \
78 ${localstatedir}/lib/nfs/rmtab \
79 ${localstatedir}/lib/nfs/xtab \
80 ${localstatedir}/lib/nfs/statd/state \
81 ${sysconfdir}/nfsmount.conf"
82
83FILES_${PN}-client = "${sbindir}/*statd \
84 ${sbindir}/rpc.idmapd ${sbindir}/sm-notify \
85 ${sbindir}/showmount ${sbindir}/nfsstat \
86 ${localstatedir}/lib/nfs \
87 ${sysconfdir}/nfs-utils.conf \
88 ${sysconfdir}/nfsmount.conf \
89 ${sysconfdir}/init.d/nfscommon \
90 ${systemd_unitdir}/system/nfs-statd.service"
91RDEPENDS_${PN}-client = "${PN}-mount rpcbind"
92
93FILES_${PN}-mount = "${base_sbindir}/*mount.nfs*"
94
95FILES_${PN}-stats = "${sbindir}/mountstats ${sbindir}/nfsiostat"
96RDEPENDS_${PN}-stats = "python3-core"
97
98FILES_${PN} += "${systemd_unitdir}"
99
100do_configure_prepend() {
101 sed -i -e 's,sbindir = /sbin,sbindir = ${base_sbindir},g' \
102 ${S}/utils/mount/Makefile.am
103}
104
105# Make clean needed because the package comes with
106# precompiled 64-bit objects that break the build
107do_compile_prepend() {
108 make clean
109}
110
111# Works on systemd only
112HIGH_RLIMIT_NOFILE ??= "4096"
113
114do_install_append () {
115 install -d ${D}${sysconfdir}/init.d
116 install -m 0755 ${WORKDIR}/nfsserver ${D}${sysconfdir}/init.d/nfsserver
117 install -m 0755 ${WORKDIR}/nfscommon ${D}${sysconfdir}/init.d/nfscommon
118
119 install -m 0755 ${WORKDIR}/nfs-utils.conf ${D}${sysconfdir}
120 install -m 0755 ${S}/utils/mount/nfsmount.conf ${D}${sysconfdir}
121
122 install -d ${D}${systemd_unitdir}/system
123 install -m 0644 ${WORKDIR}/nfs-server.service ${D}${systemd_unitdir}/system/
124 install -m 0644 ${WORKDIR}/nfs-mountd.service ${D}${systemd_unitdir}/system/
125 install -m 0644 ${WORKDIR}/nfs-statd.service ${D}${systemd_unitdir}/system/
126 sed -i -e 's,@SBINDIR@,${sbindir},g' \
127 -e 's,@SYSCONFDIR@,${sysconfdir},g' \
128 -e 's,@HIGH_RLIMIT_NOFILE@,${HIGH_RLIMIT_NOFILE},g' \
129 ${D}${systemd_unitdir}/system/*.service
130 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
131 install -m 0644 ${WORKDIR}/proc-fs-nfsd.mount ${D}${systemd_unitdir}/system/
132 install -d ${D}${systemd_unitdir}/system/sysinit.target.wants/
133 ln -sf ../proc-fs-nfsd.mount ${D}${systemd_unitdir}/system/sysinit.target.wants/proc-fs-nfsd.mount
134 fi
135
136 # kernel code as of 3.8 hard-codes this path as a default
137 install -d ${D}/var/lib/nfs/v4recovery
138
139 # chown the directories and files
140 chown -R rpcuser:rpcuser ${D}${localstatedir}/lib/nfs/statd
141 chmod 0644 ${D}${localstatedir}/lib/nfs/statd/state
142
143 # Make python tools use python 3
144 sed -i -e '1s,#!.*python.*,#!${bindir}/python3,' ${D}${sbindir}/mountstats ${D}${sbindir}/nfsiostat
145
146}