summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/nfs-utils/nfs-utils_1.3.3.bb
diff options
context:
space:
mode:
authorMariano Lopez <mariano.lopez@linux.intel.com>2016-11-23 14:41:03 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-30 15:48:07 +0000
commit93947f60e94aba68057d3cc00511f1322cc801b5 (patch)
tree988a818b59743f95e4a35c8f0044155fe222a92f /meta/recipes-connectivity/nfs-utils/nfs-utils_1.3.3.bb
parent8be26d5833cea0d221d85a3502bbc11641209701 (diff)
downloadpoky-93947f60e94aba68057d3cc00511f1322cc801b5.tar.gz
nfs-utils: 1.3.3 -> 1.3.4
(From OE-Core rev: 844c63050e849c68fc9b40ada2068309e5e37e16) Signed-off-by: Mariano Lopez <mariano.lopez@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/nfs-utils/nfs-utils_1.3.3.bb')
-rw-r--r--meta/recipes-connectivity/nfs-utils/nfs-utils_1.3.3.bb149
1 files changed, 0 insertions, 149 deletions
diff --git a/meta/recipes-connectivity/nfs-utils/nfs-utils_1.3.3.bb b/meta/recipes-connectivity/nfs-utils/nfs-utils_1.3.3.bb
deleted file mode 100644
index 1a0d4d7482..0000000000
--- a/meta/recipes-connectivity/nfs-utils/nfs-utils_1.3.3.bb
+++ /dev/null
@@ -1,149 +0,0 @@
1SUMMARY = "userspace utilities for kernel nfs"
2DESCRIPTION = "The nfs-utils package provides a daemon for the kernel \
3NFS server and related tools."
4HOMEPAGE = "http://nfs.sourceforge.net/"
5SECTION = "console/network"
6
7LICENSE = "MIT & GPLv2+ & BSD"
8LIC_FILES_CHKSUM = "file://COPYING;md5=95f3a93a5c3c7888de623b46ea085a84"
9
10# util-linux for libblkid
11DEPENDS = "libcap libnfsidmap libevent util-linux sqlite3 libtirpc"
12RDEPENDS_${PN}-client = "rpcbind bash"
13RDEPENDS_${PN} = "${PN}-client bash"
14RRECOMMENDS_${PN} = "kernel-module-nfsd"
15
16inherit useradd
17
18USERADD_PACKAGES = "${PN}-client"
19USERADD_PARAM_${PN}-client = "--system --home-dir /var/lib/nfs \
20 --shell /bin/false --user-group rpcuser"
21
22SRC_URI = "${KERNELORG_MIRROR}/linux/utils/nfs-utils/${PV}/nfs-utils-${PV}.tar.xz \
23 file://0001-configure-Allow-to-explicitly-disable-nfsidmap.patch \
24 file://nfs-utils-1.2.3-sm-notify-res_init.patch \
25 file://nfsserver \
26 file://nfscommon \
27 file://nfs-utils.conf \
28 file://nfs-server.service \
29 file://nfs-mountd.service \
30 file://nfs-statd.service \
31 file://proc-fs-nfsd.mount \
32 file://nfs-utils-Do-not-pass-CFLAGS-to-gcc-while-building.patch \
33 file://nfs-utils-debianize-start-statd.patch \
34 file://0001-nfs-utils-statd-fix-a-segfault-caused-by-improper-us.patch \
35 file://bugfix-adjust-statd-service-name.patch \
36 file://fix-protocol-minor-version-fall-back.patch \
37"
38
39SRC_URI[md5sum] = "cd6b568c2e9301cc3bfac09d87fbbc0b"
40SRC_URI[sha256sum] = "700d689c5622c87953c34102e5befafc4d3c811e676852238f0dd79c9c0c084d"
41
42# Only kernel-module-nfsd is required here (but can be built-in) - the nfsd module will
43# pull in the remainder of the dependencies.
44
45INITSCRIPT_PACKAGES = "${PN} ${PN}-client"
46INITSCRIPT_NAME = "nfsserver"
47INITSCRIPT_PARAMS = "defaults"
48INITSCRIPT_NAME_${PN}-client = "nfscommon"
49INITSCRIPT_PARAMS_${PN}-client = "defaults 19 21"
50
51inherit autotools-brokensep update-rc.d systemd pkgconfig
52
53SYSTEMD_SERVICE_${PN} = "nfs-server.service nfs-mountd.service"
54SYSTEMD_SERVICE_${PN}-client = "nfs-statd.service"
55SYSTEMD_AUTO_ENABLE = "disable"
56
57# --enable-uuid is need for cross-compiling
58EXTRA_OECONF = "--with-statduser=rpcuser \
59 --enable-mountconfig \
60 --enable-libmount-mount \
61 --disable-nfsv41 \
62 --enable-uuid \
63 --disable-gss \
64 --disable-nfsdcltrack \
65 --with-statdpath=/var/lib/nfs/statd \
66 "
67
68PACKAGECONFIG ??= "tcp-wrappers \
69 ${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '', d)} \
70"
71PACKAGECONFIG_remove_libc-musl = "tcp-wrappers"
72PACKAGECONFIG[tcp-wrappers] = "--with-tcp-wrappers,--without-tcp-wrappers,tcp-wrappers"
73PACKAGECONFIG[nfsidmap] = "--enable-nfsidmap,--disable-nfsidmap,keyutils"
74PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
75
76PACKAGES =+ "${PN}-client ${PN}-stats"
77
78CONFFILES_${PN}-client += "${localstatedir}/lib/nfs/etab \
79 ${localstatedir}/lib/nfs/rmtab \
80 ${localstatedir}/lib/nfs/xtab \
81 ${localstatedir}/lib/nfs/statd/state \
82 ${sysconfdir}/nfsmount.conf"
83
84FILES_${PN}-client = "${base_sbindir}/*mount.nfs* ${sbindir}/*statd \
85 ${sbindir}/rpc.idmapd ${sbindir}/sm-notify \
86 ${sbindir}/showmount ${sbindir}/nfsstat \
87 ${localstatedir}/lib/nfs \
88 ${sysconfdir}/nfs-utils.conf \
89 ${sysconfdir}/nfsmount.conf \
90 ${sysconfdir}/init.d/nfscommon \
91 ${systemd_unitdir}/system/nfs-statd.service"
92FILES_${PN}-stats = "${sbindir}/mountstats ${sbindir}/nfsiostat"
93RDEPENDS_${PN}-stats = "python3-core"
94
95FILES_${PN} += "${systemd_unitdir}"
96
97do_configure_prepend() {
98 sed -i -e 's,sbindir = /sbin,sbindir = ${base_sbindir},g' \
99 ${S}/utils/mount/Makefile.am
100
101 sed -i -e 's,sbindir = /sbin,sbindir = ${base_sbindir},g' \
102 ${S}/utils/osd_login/Makefile.am
103}
104
105# Make clean needed because the package comes with
106# precompiled 64-bit objects that break the build
107do_compile_prepend() {
108 make clean
109}
110
111do_install_append () {
112 install -d ${D}${sysconfdir}/init.d
113 install -m 0755 ${WORKDIR}/nfsserver ${D}${sysconfdir}/init.d/nfsserver
114 install -m 0755 ${WORKDIR}/nfscommon ${D}${sysconfdir}/init.d/nfscommon
115
116 install -m 0755 ${WORKDIR}/nfs-utils.conf ${D}${sysconfdir}
117 install -m 0755 ${S}/utils/mount/nfsmount.conf ${D}${sysconfdir}
118
119 install -d ${D}${systemd_unitdir}/system
120 install -m 0644 ${WORKDIR}/nfs-server.service ${D}${systemd_unitdir}/system/
121 install -m 0644 ${WORKDIR}/nfs-mountd.service ${D}${systemd_unitdir}/system/
122 install -m 0644 ${WORKDIR}/nfs-statd.service ${D}${systemd_unitdir}/system/
123 sed -i -e 's,@SBINDIR@,${sbindir},g' \
124 -e 's,@SYSCONFDIR@,${sysconfdir},g' \
125 ${D}${systemd_unitdir}/system/*.service
126 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
127 install -d ${D}${sysconfdir}/modules-load.d
128 echo "nfsd" > ${D}${sysconfdir}/modules-load.d/nfsd.conf
129 install -m 0644 ${WORKDIR}/proc-fs-nfsd.mount ${D}${systemd_unitdir}/system/
130 install -d ${D}${systemd_unitdir}/system/sysinit.target.wants/
131 ln -sf ../proc-fs-nfsd.mount ${D}${systemd_unitdir}/system/sysinit.target.wants/proc-fs-nfsd.mount
132 fi
133
134 # kernel code as of 3.8 hard-codes this path as a default
135 install -d ${D}/var/lib/nfs/v4recovery
136
137 # chown the directories and files
138 chown -R rpcuser:rpcuser ${D}${localstatedir}/lib/nfs/statd
139 chmod 0644 ${D}${localstatedir}/lib/nfs/statd/state
140
141 # the following are built by CC_FOR_BUILD
142 rm -f ${D}${sbindir}/rpcdebug
143 rm -f ${D}${sbindir}/rpcgen
144 rm -f ${D}${sbindir}/locktest
145
146 # Make python tools use python 3
147 sed -i -e '1s,#!.*python.*,#!${bindir}/python3,' ${D}${sbindir}/mountstats ${D}${sbindir}/nfsiostat
148
149}