summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/nfs-utils/nfs-utils_1.3.0.bb
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2014-11-12 12:42:35 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-11-25 13:03:26 +0000
commit1379659da5658c01ce2aa040ae924c7b0f5c6fd1 (patch)
tree5566d312e6ddf92a44e73d5a94af3bbf9b2021fa /meta/recipes-connectivity/nfs-utils/nfs-utils_1.3.0.bb
parent16edf5c21289dd2fb9f1adde813f0634dff0ea1a (diff)
downloadpoky-1379659da5658c01ce2aa040ae924c7b0f5c6fd1.tar.gz
nfs-utils: Upgrade to 1.3.1
Removed: fix-a-Gcc-undefined-behavior.patch - Upstream Removed: 0001-statd-fixed-the-with-statdpath-flag.patch - Upstream Removed: fix-the-start-statd.patch - Different solution on upstream Removed: nfs-utils-1.0.6-uclibc.patch - Different solution on upstream (From OE-Core rev: 7cd8b38f4f53d25a6dec8ec3b130a345480ff6b7) Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/nfs-utils/nfs-utils_1.3.0.bb')
-rw-r--r--meta/recipes-connectivity/nfs-utils/nfs-utils_1.3.0.bb118
1 files changed, 0 insertions, 118 deletions
diff --git a/meta/recipes-connectivity/nfs-utils/nfs-utils_1.3.0.bb b/meta/recipes-connectivity/nfs-utils/nfs-utils_1.3.0.bb
deleted file mode 100644
index 37a2e1a6da..0000000000
--- a/meta/recipes-connectivity/nfs-utils/nfs-utils_1.3.0.bb
+++ /dev/null
@@ -1,118 +0,0 @@
1SUMMARY = "userspace utilities for kernel nfs"
2DESCRIPTION = "The nfs-utils package provides a daemon for the kernel \
3NFS server and related tools."
4HOMEPAGE = "http://nfs.sourceforge.net/"
5SECTION = "console/network"
6
7LICENSE = "MIT & GPLv2+ & BSD"
8LIC_FILES_CHKSUM = "file://COPYING;md5=95f3a93a5c3c7888de623b46ea085a84"
9
10# util-linux for libblkid
11DEPENDS = "libcap libnfsidmap libevent util-linux sqlite3"
12RDEPENDS_${PN}-client = "rpcbind bash"
13RDEPENDS_${PN} = "${PN}-client bash"
14RRECOMMENDS_${PN} = "kernel-module-nfsd"
15
16inherit useradd
17
18USERADD_PACKAGES = "${PN}-client"
19USERADD_PARAM_${PN}-client = "--system --home-dir /var/lib/nfs \
20 --shell /bin/false --user-group rpcuser"
21
22SRC_URI = "${KERNELORG_MIRROR}/linux/utils/nfs-utils/${PV}/nfs-utils-${PV}.tar.xz \
23 file://0001-configure-Allow-to-explicitly-disable-nfsidmap.patch \
24 file://nfs-utils-1.0.6-uclibc.patch \
25 file://nfs-utils-1.2.3-sm-notify-res_init.patch \
26 file://nfsserver \
27 file://nfscommon \
28 file://nfs-utils.conf \
29 file://nfs-server.service \
30 file://nfs-mountd.service \
31 file://nfs-statd.service \
32 file://nfs-utils-Do-not-pass-CFLAGS-to-gcc-while-building.patch \
33 file://0001-statd-fixed-the-with-statdpath-flag.patch \
34 file://fix-a-Gcc-undefined-behavior.patch \
35 file://fix-the-start-statd.patch \
36"
37
38SRC_URI[md5sum] = "6e93a7997ca3a1eac56bf219adab72a8"
39SRC_URI[sha256sum] = "ab8384d0e487ed6a18c5380d5df28015f7dd98680bf08f3247c97d9f7d99e56f"
40
41PARALLEL_MAKE = ""
42
43# Only kernel-module-nfsd is required here (but can be built-in) - the nfsd module will
44# pull in the remainder of the dependencies.
45
46INITSCRIPT_PACKAGES = "${PN} ${PN}-client"
47INITSCRIPT_NAME = "nfsserver"
48INITSCRIPT_PARAMS = "defaults"
49INITSCRIPT_NAME_${PN}-client = "nfscommon"
50INITSCRIPT_PARAMS_${PN}-client = "defaults 19 21"
51
52inherit autotools-brokensep update-rc.d systemd pkgconfig
53
54SYSTEMD_SERVICE_${PN} = "nfs-server.service nfs-mountd.service"
55SYSTEMD_SERVICE_${PN}-client = "nfs-statd.service"
56SYSTEMD_AUTO_ENABLE = "disable"
57
58# --enable-uuid is need for cross-compiling
59EXTRA_OECONF = "--with-statduser=rpcuser \
60 --enable-mountconfig \
61 --enable-libmount-mount \
62 --disable-nfsv41 \
63 --enable-uuid \
64 --disable-gss \
65 --disable-tirpc \
66 --disable-nfsdcltrack \
67 --with-statdpath=/var/lib/nfs/statd \
68 "
69
70PACKAGECONFIG ??= "tcp-wrappers"
71PACKAGECONFIG[tcp-wrappers] = "--with-tcp-wrappers,--without-tcp-wrappers,tcp-wrappers"
72PACKAGECONFIG[nfsidmap] = "--enable-nfsidmap,--disable-nfsidmap,keyutils"
73
74INHIBIT_AUTO_STAGE = "1"
75
76PACKAGES =+ "${PN}-client ${PN}-stats"
77FILES_${PN}-client = "${base_sbindir}/*mount.nfs* ${sbindir}/*statd \
78 ${sbindir}/rpc.idmapd ${sbindir}/sm-notify \
79 ${sbindir}/showmount ${sbindir}/nfsstat \
80 ${localstatedir}/lib/nfs \
81 ${sysconfdir}/nfs-utils.conf \
82 ${sysconfdir}/init.d/nfscommon \
83 ${systemd_unitdir}/system/nfs-statd.service"
84FILES_${PN}-stats = "${sbindir}/mountstats ${sbindir}/nfsiostat"
85RDEPENDS_${PN}-stats = "python"
86
87# Make clean needed because the package comes with
88# precompiled 64-bit objects that break the build
89do_compile_prepend() {
90 make clean
91}
92
93do_install_append () {
94 install -d ${D}${sysconfdir}/init.d
95 install -m 0755 ${WORKDIR}/nfsserver ${D}${sysconfdir}/init.d/nfsserver
96 install -m 0755 ${WORKDIR}/nfscommon ${D}${sysconfdir}/init.d/nfscommon
97
98 install -m 0755 ${WORKDIR}/nfs-utils.conf ${D}${sysconfdir}
99 install -d ${D}${systemd_unitdir}/system
100 install -m 0644 ${WORKDIR}/nfs-server.service ${D}${systemd_unitdir}/system/
101 install -m 0644 ${WORKDIR}/nfs-mountd.service ${D}${systemd_unitdir}/system/
102 install -m 0644 ${WORKDIR}/nfs-statd.service ${D}${systemd_unitdir}/system/
103 sed -i -e 's,@SBINDIR@,${sbindir},g' \
104 -e 's,@SYSCONFDIR@,${sysconfdir},g' \
105 ${D}${systemd_unitdir}/system/*.service
106
107 # kernel code as of 3.8 hard-codes this path as a default
108 install -d ${D}/var/lib/nfs/v4recovery
109
110 # chown the directories and files
111 chown -R rpcuser:rpcuser ${D}${localstatedir}/lib/nfs/statd
112 chmod 0644 ${D}${localstatedir}/lib/nfs/statd/state
113
114 # the following are built by CC_FOR_BUILD
115 rm -f ${D}${sbindir}/rpcdebug
116 rm -f ${D}${sbindir}/rpcgen
117 rm -f ${D}${sbindir}/locktest
118}