summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/libpcap/libpcap_1.9.1.bb
diff options
context:
space:
mode:
authorZang Ruochen <zangrc.fnst@cn.fujitsu.com>2019-10-07 10:52:14 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-10-09 14:07:44 +0100
commit60f9ba605f1031378be34ea4cf7d7fa9ef846385 (patch)
tree0a5c93a4fad7e5528f79a94e5c1e28b15500c05e /meta/recipes-connectivity/libpcap/libpcap_1.9.1.bb
parentcfc27f68fb948b1b2bc22841cf97a117efca8d5b (diff)
downloadpoky-60f9ba605f1031378be34ea4cf7d7fa9ef846385.tar.gz
libpcap:upgrade 1.9.0 -> 1.9.1
-libpcap/0001-pcap-usb-linux.c-add-missing-limits.h-for-musl-syste.patch Removed since this is included in 1.9.1. (From OE-Core rev: d42f381c4f5f9ec248e5b464a2aab39fdc9a7644) Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/libpcap/libpcap_1.9.1.bb')
-rw-r--r--meta/recipes-connectivity/libpcap/libpcap_1.9.1.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/libpcap/libpcap_1.9.1.bb b/meta/recipes-connectivity/libpcap/libpcap_1.9.1.bb
new file mode 100644
index 0000000000..318e2d769a
--- /dev/null
+++ b/meta/recipes-connectivity/libpcap/libpcap_1.9.1.bb
@@ -0,0 +1,44 @@
1SUMMARY = "Interface for user-level network packet capture"
2DESCRIPTION = "Libpcap provides a portable framework for low-level network \
3monitoring. Libpcap can provide network statistics collection, \
4security monitoring and network debugging."
5HOMEPAGE = "http://www.tcpdump.org/"
6BUGTRACKER = "http://sourceforge.net/tracker/?group_id=53067&atid=469577"
7SECTION = "libs/network"
8LICENSE = "BSD"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=5eb289217c160e2920d2e35bddc36453 \
10 file://pcap.h;beginline=1;endline=32;md5=39af3510e011f34b8872f120b1dc31d2"
11DEPENDS = "flex-native bison-native"
12
13SRC_URI = "https://www.tcpdump.org/release/${BP}.tar.gz \
14 "
15SRC_URI[md5sum] = "21af603d9a591c7d96a6457021d84e6c"
16SRC_URI[sha256sum] = "635237637c5b619bcceba91900666b64d56ecb7be63f298f601ec786ce087094"
17
18inherit autotools binconfig-disabled pkgconfig
19
20BINCONFIG = "${bindir}/pcap-config"
21
22# Explicitly disable dag support. We don't have recipe for it and if enabled here,
23# configure script poisons the include dirs with /usr/local/include even when the
24# support hasn't been detected.
25EXTRA_OECONF = " \
26 --with-pcap=linux \
27 --without-dag \
28 "
29EXTRA_AUTORECONF += "--exclude=aclocal"
30
31PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez5', '', d)} \
32 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
33"
34PACKAGECONFIG[bluez5] = "--enable-bluetooth,--disable-bluetooth,bluez5"
35PACKAGECONFIG[dbus] = "--enable-dbus,--disable-dbus,dbus"
36PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
37PACKAGECONFIG[libnl] = "--with-libnl,--without-libnl,libnl"
38
39do_configure_prepend () {
40 #remove hardcoded references to /usr/include
41 sed 's|\([ "^'\''I]\+\)/usr/include/|\1${STAGING_INCDIR}/|g' -i ${S}/configure.ac
42}
43
44BBCLASSEXTEND = "native"