summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/kea/kea_1.7.10.bb
diff options
context:
space:
mode:
authorakuster <akuster808@gmail.com>2020-10-14 22:48:31 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-10-17 12:34:29 +0100
commitd4ecc90268438900ccbef6020cdb15c054fb4027 (patch)
tree5e90660082b80f65467f53e36c5389d5991d0c90 /meta/recipes-connectivity/kea/kea_1.7.10.bb
parent044b20737a6b4647852637437a5c97a17274cea8 (diff)
downloadpoky-d4ecc90268438900ccbef6020cdb15c054fb4027.tar.gz
kea: add init scripts
[ Yocto # 14074 ] Add init scripts for dhcp4,6 and ddns (From OE-Core rev: 6d20bfda696fc6c6c3989ecf9996d2494953e232) Signed-off-by: Armin kuster <akuster808@gmail.com> -- V2] remove 'status' from usage add patch to fix ps -p in keactrl.in Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/kea/kea_1.7.10.bb')
-rw-r--r--meta/recipes-connectivity/kea/kea_1.7.10.bb14
1 files changed, 13 insertions, 1 deletions
diff --git a/meta/recipes-connectivity/kea/kea_1.7.10.bb b/meta/recipes-connectivity/kea/kea_1.7.10.bb
index 2ea4b12758..c9a5819e47 100644
--- a/meta/recipes-connectivity/kea/kea_1.7.10.bb
+++ b/meta/recipes-connectivity/kea/kea_1.7.10.bb
@@ -13,11 +13,18 @@ SRC_URI = "\
13 file://kea-dhcp4.service \ 13 file://kea-dhcp4.service \
14 file://kea-dhcp6.service \ 14 file://kea-dhcp6.service \
15 file://kea-dhcp-ddns.service \ 15 file://kea-dhcp-ddns.service \
16 file://kea-dhcp4-server \
17 file://kea-dhcp6-server \
18 file://kea-dhcp-ddns-server \
16 file://fix-multilib-conflict.patch \ 19 file://fix-multilib-conflict.patch \
20 file://fix_pid_keactrl.patch \
17" 21"
18SRC_URI[sha256sum] = "4e121f0e58b175a827581c69cb1d60778647049fa47f142940dddc9ce58f3c82" 22SRC_URI[sha256sum] = "4e121f0e58b175a827581c69cb1d60778647049fa47f142940dddc9ce58f3c82"
19 23
20inherit autotools systemd 24inherit autotools systemd update-rc.d
25
26INITSCRIPT_NAME = "kea-dhcp4-server"
27INITSCRIPT_PARAMS = "defaults 30"
21 28
22SYSTEMD_SERVICE_${PN} = "kea-dhcp4.service kea-dhcp6.service kea-dhcp-ddns.service" 29SYSTEMD_SERVICE_${PN} = "kea-dhcp4.service kea-dhcp6.service kea-dhcp-ddns.service"
23SYSTEMD_AUTO_ENABLE = "disable" 30SYSTEMD_AUTO_ENABLE = "disable"
@@ -44,8 +51,11 @@ do_configure_prepend() {
44} 51}
45 52
46do_install_append() { 53do_install_append() {
54 install -d ${D}${sysconfdir}/init.d
47 install -d ${D}${systemd_system_unitdir} 55 install -d ${D}${systemd_system_unitdir}
56
48 install -m 0644 ${WORKDIR}/kea-dhcp*service ${D}${systemd_system_unitdir} 57 install -m 0644 ${WORKDIR}/kea-dhcp*service ${D}${systemd_system_unitdir}
58 install -m 0755 ${WORKDIR}/kea-*-server ${D}${sysconfdir}/init.d
49 sed -i -e 's,@SBINDIR@,${sbindir},g' -e 's,@BASE_BINDIR@,${base_bindir},g' \ 59 sed -i -e 's,@SBINDIR@,${sbindir},g' -e 's,@BASE_BINDIR@,${base_bindir},g' \
50 -e 's,@LOCALSTATEDIR@,${localstatedir},g' -e 's,@SYSCONFDIR@,${sysconfdir},g' \ 60 -e 's,@LOCALSTATEDIR@,${localstatedir},g' -e 's,@SYSCONFDIR@,${sysconfdir},g' \
51 ${D}${systemd_system_unitdir}/kea-dhcp*service ${D}${sbindir}/keactrl 61 ${D}${systemd_system_unitdir}/kea-dhcp*service ${D}${sbindir}/keactrl
@@ -55,6 +65,8 @@ do_install_append() {
55 rm -rf "${D}${localstatedir}" 65 rm -rf "${D}${localstatedir}"
56} 66}
57 67
68CONFFILES_${PN} = "${sysconfdir}/kea/keactrl.conf"
69
58FILES_${PN}-staticdev += "${libdir}/kea/hooks/*.a ${libdir}/hooks/*.a" 70FILES_${PN}-staticdev += "${libdir}/kea/hooks/*.a ${libdir}/hooks/*.a"
59FILES_${PN} += "${libdir}/hooks/*.so" 71FILES_${PN} += "${libdir}/hooks/*.so"
60 72