summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/iw/iw_6.7.bb
diff options
context:
space:
mode:
authorChanghyeok Bae <changhyeok.bae@gmail.com>2024-01-10 18:01:53 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-01-15 21:42:15 +0000
commite5a9f41366c362e2e9d949e908a1402e735798e2 (patch)
tree5db0fc9655e6026320406fd08a7d0400bf14eedb /meta/recipes-connectivity/iw/iw_6.7.bb
parent61182659c212db24e52cdbcdbb043c7b0de86094 (diff)
downloadpoky-e5a9f41366c362e2e9d949e908a1402e735798e2.tar.gz
iw: upgrade 5.19 -> 6.7
52ae965 bump version to 6.7 ac7e46b update nl80211.h 44686ac iw: allow extra cflags e2224c7 iw: S1G: add 802.11ah support for link command display 7298198 update nl80211.h a1c9376 iw: connect: Fix segfault during open authentication ea706b3 iw: fix attribute size mismatch cb491fa iw: add more extended capa bits cf26fc9 iw: Fix EHT rates printing. f2d9f5b iw: S1G: add list command support for 802.11ah 1bc6ab0 iw: S1G: add parsing for 802.11ah scan IE's a32046b iw: S1G: add frequency set in kHz and offset options f5e3b43 util: don't print EHT info if not present 7794573 interface: print links 221875e link: update for MLO 5f64b70 link: fix some formatting 29555e1 iw: scan: set NL80211_SCAN_FLAG_COLOCATED_6GHZ in case of full sched scan 997e5f1 util: add support for 320MHz bandwidth without cf1 81d112f util: add support for 320Mhz bandwidth de3da80 update nl80211.h d6fd275 iw: event: fix printf format error cc660cc iw: add support for retrieving keys c4743bb iw: info: fix bug reading preambles and bandwidths 82e6fba iw: add cac background command ad2f2f8 iw: info: print PMSR capabilities (From OE-Core rev: e44ce3000864407b773f64581ba6eac38b8297c6) Signed-off-by: Changhyeok Bae <changhyeok.bae@gmail.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/iw/iw_6.7.bb')
-rw-r--r--meta/recipes-connectivity/iw/iw_6.7.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/iw/iw_6.7.bb b/meta/recipes-connectivity/iw/iw_6.7.bb
new file mode 100644
index 0000000000..b46b54bc93
--- /dev/null
+++ b/meta/recipes-connectivity/iw/iw_6.7.bb
@@ -0,0 +1,31 @@
1SUMMARY = "nl80211 based CLI configuration utility for wireless devices"
2DESCRIPTION = "iw is a new nl80211 based CLI configuration utility for \
3wireless devices. It supports almost all new drivers that have been added \
4to the kernel recently. "
5HOMEPAGE = "https://wireless.wiki.kernel.org/en/users/documentation/iw"
6SECTION = "base"
7LICENSE = "BSD-2-Clause"
8LIC_FILES_CHKSUM = "file://COPYING;md5=878618a5c4af25e9b93ef0be1a93f774"
9
10DEPENDS = "libnl"
11
12SRC_URI = "http://www.kernel.org/pub/software/network/iw/${BP}.tar.gz \
13 file://0001-iw-version.sh-don-t-use-git-describe-for-versioning.patch \
14 file://separate-objdir.patch \
15"
16
17SRC_URI[sha256sum] = "b3ef3fa85fa1177b11d3e97d6d38cdfe10ee250ca31482b581f3bd0fc79cb015"
18
19inherit pkgconfig
20
21EXTRA_OEMAKE = "\
22 -f '${S}/Makefile' \
23 \
24 'PREFIX=${prefix}' \
25 'SBINDIR=${sbindir}' \
26 'MANDIR=${mandir}' \
27"
28
29do_install() {
30 oe_runmake 'DESTDIR=${D}' install
31}