summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/dhcpcd/dhcpcd_9.2.0.bb
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2020-09-11 09:45:29 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-09-12 14:49:00 +0100
commit6559577d70d291b9a3c4d145b34d0e86a854066a (patch)
tree6ff1ce0b5059a1ff172718de5e816145facaeffa /meta/recipes-connectivity/dhcpcd/dhcpcd_9.2.0.bb
parentd107c45b2c73a0ee2849a9864b7395fb9cbddd29 (diff)
downloadpoky-6559577d70d291b9a3c4d145b34d0e86a854066a.tar.gz
dhcpcd: 9.1.4 -> 9.2.0
Upgrade dhcpcd from 9.1.4 to 9.2.0. And add systemd services files dhcpcd.service and dhcpcd@.service from Fedora: https://src.fedoraproject.org/rpms/dhcpcd/tree/master (From OE-Core rev: 3e729e918ca7f42446517abfcd1eced72db7a7f1) Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/dhcpcd/dhcpcd_9.2.0.bb')
-rw-r--r--meta/recipes-connectivity/dhcpcd/dhcpcd_9.2.0.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/dhcpcd/dhcpcd_9.2.0.bb b/meta/recipes-connectivity/dhcpcd/dhcpcd_9.2.0.bb
new file mode 100644
index 0000000000..292cb5b008
--- /dev/null
+++ b/meta/recipes-connectivity/dhcpcd/dhcpcd_9.2.0.bb
@@ -0,0 +1,39 @@
1SECTION = "console/network"
2SUMMARY = "dhcpcd - a DHCP client"
3DESCRIPTION = "dhcpcd runs on your machine and silently configures your \
4 computer to work on the attached networks without trouble \
5 and mostly without configuration."
6
7HOMEPAGE = "http://roy.marples.name/projects/dhcpcd/"
8
9LICENSE = "BSD-2-Clause"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=9674cc803c5d71306941e6e8b5c002f2"
11
12UPSTREAM_CHECK_URI = "https://roy.marples.name/downloads/dhcpcd/"
13
14SRC_URI = "https://roy.marples.name/downloads/${BPN}/${BPN}-${PV}.tar.xz \
15 file://0001-remove-INCLUDEDIR-to-prevent-build-issues.patch \
16 file://dhcpcd.service \
17 file://dhcpcd@.service \
18 "
19
20SRC_URI[sha256sum] = "fcb2d19672d445bbfd38678fdee4f556ef967a3ea6bd81092d10545df2cb9666"
21
22inherit pkgconfig autotools-brokensep systemd
23
24SYSTEMD_SERVICE_${PN} = "dhcpcd.service"
25
26PACKAGECONFIG ?= "udev ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
27
28PACKAGECONFIG[udev] = "--with-udev,--without-udev,udev,udev"
29PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6"
30
31EXTRA_OECONF = "--enable-ipv4"
32
33do_install_append () {
34 # install systemd unit files
35 install -d ${D}${systemd_unitdir}/system
36 install -m 0644 ${WORKDIR}/dhcpcd*.service ${D}${systemd_unitdir}/system
37}
38
39FILES_${PN}-dbg += "${libdir}/dhcpcd/dev/.debug"