summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/bind/bind_9.9.5.bb
diff options
context:
space:
mode:
authorRoy Li <rongqing.li@windriver.com>2015-05-04 16:43:39 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-09 22:26:42 +0100
commit05956671a250e7664593e136d1d60cc2df36e245 (patch)
tree6f8862d781328447029afb139514de0f2c49aba3 /meta/recipes-connectivity/bind/bind_9.9.5.bb
parent29c7111362add0b4c457d11eecdb9c1928806e51 (diff)
downloadpoky-05956671a250e7664593e136d1d60cc2df36e245.tar.gz
bind: upgrade to 9.10.2
1. Remove two unneeded CVE patches, 9.10.2 fixed the CVE-2015-1349 also 2. Remove bind-subdirs-run-serially.patch and cross-build-fix.patch, similar fixes are merged into 9.10.2 3. update the dont-test-on-host.patch 4. update the Copyright file checksum, since the date in it has been changed. 5. replace the hardcode lib dir with $base_libdir in bind-add-crosscripts*.patch (From OE-Core rev: 41d53f0139a9cb29679dbcaaab8311a1364c65f4) Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/bind/bind_9.9.5.bb')
-rw-r--r--meta/recipes-connectivity/bind/bind_9.9.5.bb105
1 files changed, 0 insertions, 105 deletions
diff --git a/meta/recipes-connectivity/bind/bind_9.9.5.bb b/meta/recipes-connectivity/bind/bind_9.9.5.bb
deleted file mode 100644
index e34cdedde7..0000000000
--- a/meta/recipes-connectivity/bind/bind_9.9.5.bb
+++ /dev/null
@@ -1,105 +0,0 @@
1SUMMARY = "ISC Internet Domain Name Server"
2HOMEPAGE = "http://www.isc.org/sw/bind/"
3SECTION = "console/network"
4
5LICENSE = "ISC & BSD"
6LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=a3df5f651469919a0e6cb42f84fb6ff1"
7
8DEPENDS = "openssl libcap"
9
10SRC_URI = "ftp://ftp.isc.org/isc/bind9/${PV}/${BPN}-${PV}.tar.gz \
11 file://conf.patch \
12 file://cross-build-fix.patch \
13 file://make-etc-initd-bind-stop-work.patch \
14 file://mips1-not-support-opcode.diff \
15 file://dont-test-on-host.patch \
16 file://generate-rndc-key.sh \
17 file://named.service \
18 file://bind9 \
19 file://init.d-add-support-for-read-only-rootfs.patch \
20 file://bind9_9_5-CVE-2014-8500.patch \
21 file://bind-add-crosscripts-search-path-for-xml2-config.patch \
22 file://bind-subdirs-run-serially.patch \
23 file://bind-confgen-build-unix.o-once.patch \
24 "
25
26SRC_URI[md5sum] = "e676c65cad5234617ee22f48e328c24e"
27SRC_URI[sha256sum] = "d4b64c1dde442145a316679acff2df4008aa117ae52dfa3a6bc69efecc7840d1"
28
29# --enable-exportlib is necessary for building dhcp
30ENABLE_IPV6 = "--enable-ipv6=${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'yes', 'no', d)}"
31EXTRA_OECONF = " ${ENABLE_IPV6} --with-randomdev=/dev/random --disable-threads \
32 --disable-devpoll --disable-epoll --with-gost=no \
33 --with-gssapi=no --with-ecdsa=yes \
34 --sysconfdir=${sysconfdir}/bind \
35 --with-openssl=${STAGING_LIBDIR}/.. \
36 --enable-exportlib --with-export-includedir=${includedir} --with-export-libdir=${libdir} \
37 "
38inherit autotools-brokensep update-rc.d systemd useradd pkgconfig
39
40PACKAGECONFIG ?= "libxml2"
41
42PACKAGECONFIG[libxml2] = "--with-libxml2=${STAGING_LIBDIR}/..,--with-libxml2=no,libxml2"
43
44USERADD_PACKAGES = "${PN}"
45USERADD_PARAM_${PN} = "--system --home /var/cache/bind --no-create-home \
46 --user-group bind"
47
48INITSCRIPT_NAME = "bind"
49INITSCRIPT_PARAMS = "defaults"
50
51SYSTEMD_SERVICE_${PN} = "named.service"
52
53PARALLEL_MAKE = ""
54
55RDEPENDS_${PN} = "python-core"
56
57PACKAGE_BEFORE_PN += "${PN}-utils"
58FILES_${PN}-utils = "${bindir}/host ${bindir}/dig"
59FILES_${PN}-dev += "${bindir}/isc-config.h"
60FILES_${PN} += "${sbindir}/generate-rndc-key.sh"
61
62do_install_prepend() {
63 # clean host path in isc-config.sh before the hardlink created
64 # by "make install":
65 # bind9-config -> isc-config.sh
66 sed -i -e "s,${STAGING_LIBDIR},${libdir}," ${S}/isc-config.sh
67}
68
69do_install_append() {
70 rm "${D}${bindir}/nslookup"
71 rm "${D}${mandir}/man1/nslookup.1"
72 rmdir "${D}${localstatedir}/run"
73 rmdir --ignore-fail-on-non-empty "${D}${localstatedir}"
74 install -d "${D}${localstatedir}/cache/bind"
75 install -d "${D}${sysconfdir}/bind"
76 install -d "${D}${sysconfdir}/init.d"
77 install -m 644 ${S}/conf/* "${D}${sysconfdir}/bind/"
78 install -m 755 "${S}/init.d" "${D}${sysconfdir}/init.d/bind"
79 sed -i -e '1s,#!.*python,#! /usr/bin/env python,' ${D}${sbindir}/dnssec-coverage ${D}${sbindir}/dnssec-checkds
80
81 # Install systemd related files
82 install -d ${D}${localstatedir}/cache/bind
83 install -d ${D}${sbindir}
84 install -m 755 ${WORKDIR}/generate-rndc-key.sh ${D}${sbindir}
85 install -d ${D}${systemd_unitdir}/system
86 install -m 0644 ${WORKDIR}/named.service ${D}${systemd_unitdir}/system
87 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \
88 -e 's,@SBINDIR@,${sbindir},g' \
89 ${D}${systemd_unitdir}/system/named.service
90
91 install -d ${D}${sysconfdir}/default
92 install -m 0644 ${WORKDIR}/bind9 ${D}${sysconfdir}/default
93}
94
95CONFFILES_${PN} = " \
96 ${sysconfdir}/bind/named.conf \
97 ${sysconfdir}/bind/named.conf.local \
98 ${sysconfdir}/bind/named.conf.options \
99 ${sysconfdir}/bind/db.0 \
100 ${sysconfdir}/bind/db.127 \
101 ${sysconfdir}/bind/db.empty \
102 ${sysconfdir}/bind/db.local \
103 ${sysconfdir}/bind/db.root \
104 "
105