summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/bind/bind_9.18.16.bb
diff options
context:
space:
mode:
authorSiddharth Doshi <sdoshi@mvista.com>2023-06-27 12:02:00 +0530
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-06-28 07:56:33 +0100
commit0745cb1cb3d480829ce81645f89d10b37e91e063 (patch)
tree8f5ec2f5774298ec4e75f87c4e47538f56000816 /meta/recipes-connectivity/bind/bind_9.18.16.bb
parentc14fb8602e1d29cef49a4a39e3946692378f55f6 (diff)
downloadpoky-0745cb1cb3d480829ce81645f89d10b37e91e063.tar.gz
bind: Upgrade 9.18.15 -> 9.18.16
- Remove configure options no longer supported online. Changelog: ========= [security] A query that prioritizes stale data over lookup triggers a fetch to refresh the stale data in cache. If the fetch is aborted for exceeding the recursion quota, it was possible for 'named' to enter an infinite callback loop and crash due to stack overflow. This has been fixed. (CVE-2023-2911) [GL #4089] [security] Improve the overmem cleaning process to prevent the cache going over the configured limit. (CVE-2023-2828) [GL #4055] [performance] Reduce memory consumption by allocating properly sized send buffers for stream-based transports. [GL #4038] [bug] Fix a 'clients-per-query' miscalculation bug. When the 'stale-answer-enable' options was enabled and the 'stale-answer-client-timeout' option was enabled and larger than 0, named was taking two places from the 'clients-per-query' limit for each client and was failing to gradually auto-tune its value, as configured. [GL #4074] [func] Add "ClientQuota" statistics channel counter, which indicates the number of the resolver's spilled queries due to reaching the clients per query quota. [GL !7978] [bug] Fix a serve-stale bug where a delegation from cache could be returned to the client. [GL #3950] [cleanup] Remove configure checks for epoll, kqueue and /dev/poll. [GL #4098] [func] The "tkey-dhkey" option has been deprecated; a warning will be logged when it is used. In a future release, Diffie-Hellman TKEY mode will be removed. [GL #3905] [bug] The session key object could be incorrectly added to multiple different views' keyrings. [GL #4079] [bug] Fix an interfacemgr use-after-free error in zoneconf.c:isself(). [GL #3765] [test] Add support for using pytest & pytest-xdist to execute the system test suite. [GL #3978] [bug] BIND could get stuck on reconfiguration when a 'listen' statement for HTTP is removed from the configuration. That has been fixed. [GL #4071] [bug] Properly process extra "nameserver" lines in resolv.conf otherwise the next line is not properly processed. [GL #4066] [bug] named could crash when deleting inline-signing zones with "rndc delzone". [GL #4054] [bug] Fix a logic error in dighost.c which could call the dighost_shutdown() callback twice and cause problems if the callback function was not idempotent. [GL #4039] (From OE-Core rev: 77d2fa5ac1f394fba2b8e24f2b6ded6ea6b691b4) Signed-off-by: Siddharth Doshi <sdoshi@mvista.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/bind/bind_9.18.16.bb')
-rw-r--r--meta/recipes-connectivity/bind/bind_9.18.16.bb113
1 files changed, 113 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/bind/bind_9.18.16.bb b/meta/recipes-connectivity/bind/bind_9.18.16.bb
new file mode 100644
index 0000000000..1b1649566a
--- /dev/null
+++ b/meta/recipes-connectivity/bind/bind_9.18.16.bb
@@ -0,0 +1,113 @@
1SUMMARY = "ISC Internet Domain Name Server"
2HOMEPAGE = "https://www.isc.org/bind/"
3DESCRIPTION = "BIND 9 provides a full-featured Domain Name Server system"
4SECTION = "console/network"
5
6LICENSE = "MPL-2.0"
7LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=d8cf7bd9c4fd5471a588e7e66e672408"
8
9DEPENDS = "openssl libcap zlib libuv"
10
11SRC_URI = "https://ftp.isc.org/isc/bind9/${PV}/${BPN}-${PV}.tar.xz \
12 file://conf.patch \
13 file://named.service \
14 file://bind9 \
15 file://generate-rndc-key.sh \
16 file://make-etc-initd-bind-stop-work.patch \
17 file://init.d-add-support-for-read-only-rootfs.patch \
18 file://bind-ensure-searching-for-json-headers-searches-sysr.patch \
19 file://0001-named-lwresd-V-and-start-log-hide-build-options.patch \
20 file://0001-avoid-start-failure-with-bind-user.patch \
21 "
22
23SRC_URI[sha256sum] = "c88234fe07ee75c3c8a9e59152fee64b714643de8e22cf98da3db4d0b57e0775"
24
25UPSTREAM_CHECK_URI = "https://ftp.isc.org/isc/bind9/"
26# follow the ESV versions divisible by 2
27UPSTREAM_CHECK_REGEX = "(?P<pver>9.(\d*[02468])+(\.\d+)+(-P\d+)*)/"
28
29# Issue only affects dhcpd with recent bind versions. We don't ship dhcpd anymore
30# so the issue doesn't affect us.
31CVE_CHECK_IGNORE += "CVE-2019-6470"
32
33inherit autotools update-rc.d systemd useradd pkgconfig multilib_header update-alternatives
34
35# PACKAGECONFIGs readline and libedit should NOT be set at same time
36PACKAGECONFIG ?= "readline"
37PACKAGECONFIG[httpstats] = "--with-libxml2=${STAGING_DIR_HOST}${prefix},--without-libxml2,libxml2"
38PACKAGECONFIG[readline] = "--with-readline=readline,,readline"
39PACKAGECONFIG[libedit] = "--with-readline=libedit,,libedit"
40PACKAGECONFIG[dns-over-http] = "--enable-doh,--disable-doh,nghttp2"
41
42EXTRA_OECONF = " --disable-auto-validation \
43 --with-gssapi=no --with-lmdb=no --with-zlib \
44 --sysconfdir=${sysconfdir}/bind \
45 --with-openssl=${STAGING_DIR_HOST}${prefix} \
46 "
47LDFLAGS:append = " -lz"
48
49# dhcp needs .la so keep them
50REMOVE_LIBTOOL_LA = "0"
51
52USERADD_PACKAGES = "${PN}"
53USERADD_PARAM:${PN} = "--system --home ${localstatedir}/cache/bind --no-create-home \
54 --user-group bind"
55
56INITSCRIPT_NAME = "bind"
57INITSCRIPT_PARAMS = "defaults"
58
59SYSTEMD_SERVICE:${PN} = "named.service"
60
61do_install:append() {
62
63 install -d -o bind "${D}${localstatedir}/cache/bind"
64 install -d "${D}${sysconfdir}/bind"
65 install -d "${D}${sysconfdir}/init.d"
66 install -m 644 ${S}/conf/* "${D}${sysconfdir}/bind/"
67 install -m 755 "${S}/init.d" "${D}${sysconfdir}/init.d/bind"
68
69 # Install systemd related files
70 install -d ${D}${sbindir}
71 install -m 755 ${WORKDIR}/generate-rndc-key.sh ${D}${sbindir}
72 install -d ${D}${systemd_system_unitdir}
73 install -m 0644 ${WORKDIR}/named.service ${D}${systemd_system_unitdir}
74 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \
75 -e 's,@SBINDIR@,${sbindir},g' \
76 ${D}${systemd_system_unitdir}/named.service
77
78 install -d ${D}${sysconfdir}/default
79 install -m 0644 ${WORKDIR}/bind9 ${D}${sysconfdir}/default
80
81 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
82 install -d ${D}${sysconfdir}/tmpfiles.d
83 echo "d /run/named 0755 bind bind - -" > ${D}${sysconfdir}/tmpfiles.d/bind.conf
84 fi
85}
86
87CONFFILES:${PN} = " \
88 ${sysconfdir}/bind/named.conf \
89 ${sysconfdir}/bind/named.conf.local \
90 ${sysconfdir}/bind/named.conf.options \
91 ${sysconfdir}/bind/db.0 \
92 ${sysconfdir}/bind/db.127 \
93 ${sysconfdir}/bind/db.empty \
94 ${sysconfdir}/bind/db.local \
95 ${sysconfdir}/bind/db.root \
96 "
97
98ALTERNATIVE:${PN}-utils = "nslookup"
99ALTERNATIVE_LINK_NAME[nslookup] = "${bindir}/nslookup"
100ALTERNATIVE_PRIORITY = "100"
101
102PACKAGE_BEFORE_PN += "${PN}-utils"
103FILES:${PN}-utils = "${bindir}/host ${bindir}/dig ${bindir}/mdig ${bindir}/nslookup ${bindir}/nsupdate"
104FILES:${PN}-dev += "${bindir}/isc-config.h"
105FILES:${PN} += "${sbindir}/generate-rndc-key.sh"
106
107PACKAGE_BEFORE_PN += "${PN}-libs"
108# special arrangement below due to
109# https://github.com/isc-projects/bind9/commit/0e25af628cd776f98c04fc4cc59048f5448f6c88
110FILES_SOLIBSDEV = "${libdir}/*[!0-9].so ${libdir}/libbind9.so"
111FILES:${PN}-libs = "${libdir}/named/*.so* ${libdir}/*-${PV}.so"
112
113DEV_PKG_DEPENDENCY = ""