summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/bind/bind_9.11.4.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2018-07-18 15:48:03 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-07-26 13:16:40 +0100
commit53b50b5d11dfd6f299116edc7254ebc1f29f19e5 (patch)
treea83c22b7c78011cf9160b0590dc9389113527453 /meta/recipes-connectivity/bind/bind_9.11.4.bb
parent8a2b440f87eb4084fab638a3814e82727af8f8cf (diff)
downloadpoky-53b50b5d11dfd6f299116edc7254ebc1f29f19e5.tar.gz
bind: update to 9.11.4
include: CVE-2018-5738 (From OE-Core rev: fcf45459bc32d833740e3bb237ea0b8f8845f308) Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/bind/bind_9.11.4.bb')
-rw-r--r--meta/recipes-connectivity/bind/bind_9.11.4.bb131
1 files changed, 131 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/bind/bind_9.11.4.bb b/meta/recipes-connectivity/bind/bind_9.11.4.bb
new file mode 100644
index 0000000000..7522fdbaa0
--- /dev/null
+++ b/meta/recipes-connectivity/bind/bind_9.11.4.bb
@@ -0,0 +1,131 @@
1SUMMARY = "ISC Internet Domain Name Server"
2HOMEPAGE = "http://www.isc.org/sw/bind/"
3SECTION = "console/network"
4
5LICENSE = "ISC & BSD"
6LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=6ba7c9fe0c888a943c79c93e6de744fb"
7
8DEPENDS = "openssl libcap zlib"
9
10SRC_URI = "https://ftp.isc.org/isc/bind9/${PV}/${BPN}-${PV}.tar.gz \
11 file://conf.patch \
12 file://named.service \
13 file://bind9 \
14 file://generate-rndc-key.sh \
15 file://make-etc-initd-bind-stop-work.patch \
16 file://init.d-add-support-for-read-only-rootfs.patch \
17 file://bind-ensure-searching-for-json-headers-searches-sysr.patch \
18 file://0001-gen.c-extend-DIRNAMESIZE-from-256-to-512.patch \
19 file://0001-lib-dns-gen.c-fix-too-long-error.patch \
20"
21
22SRC_URI[md5sum] = "9b4834d78f30cdb796ce437262272a36"
23SRC_URI[sha256sum] = "595070b031f869f8939656b5a5d11b121211967f15f6afeafa895df745279617"
24
25UPSTREAM_CHECK_URI = "https://ftp.isc.org/isc/bind9/"
26UPSTREAM_CHECK_REGEX = "(?P<pver>9(\.\d+)+(-P\d+)*)/"
27
28inherit autotools update-rc.d systemd useradd pkgconfig
29
30# PACKAGECONFIGs readline and libedit should NOT be set at same time
31PACKAGECONFIG ?= "readline"
32PACKAGECONFIG[httpstats] = "--with-libxml2=${STAGING_DIR_HOST}${prefix},--without-libxml2,libxml2"
33PACKAGECONFIG[readline] = "--with-readline=-lreadline,,readline"
34PACKAGECONFIG[libedit] = "--with-readline=-ledit,,libedit"
35PACKAGECONFIG[urandom] = "--with-randomdev=/dev/urandom,--with-randomdev=/dev/random,,"
36PACKAGECONFIG[python3] = "--with-python=${PYTHON} --with-python-install-dir=${D}/${PYTHON_SITEPACKAGES_DIR} , --without-python, python3-ply-native,"
37
38ENABLE_IPV6 = "--enable-ipv6=${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'yes', 'no', d)}"
39EXTRA_OECONF = " ${ENABLE_IPV6} --with-libtool --enable-threads \
40 --disable-devpoll --enable-epoll --with-gost=no \
41 --with-gssapi=no --with-ecdsa=yes --with-eddsa=no \
42 --with-lmdb=no \
43 --sysconfdir=${sysconfdir}/bind \
44 --with-openssl=${STAGING_DIR_HOST}${prefix} \
45 "
46
47inherit ${@bb.utils.contains('PACKAGECONFIG', 'python3', 'python3native distutils3-base', '', d)}
48
49# dhcp needs .la so keep them
50REMOVE_LIBTOOL_LA = "0"
51
52USERADD_PACKAGES = "${PN}"
53USERADD_PARAM_${PN} = "--system --home ${localstatedir}/cache/bind --no-create-home \
54 --user-group bind"
55
56INITSCRIPT_NAME = "bind"
57INITSCRIPT_PARAMS = "defaults"
58
59SYSTEMD_SERVICE_${PN} = "named.service"
60
61do_install_prepend() {
62 # clean host path in isc-config.sh before the hardlink created
63 # by "make install":
64 # bind9-config -> isc-config.sh
65 sed -i -e "s,${STAGING_LIBDIR},${libdir}," ${B}/isc-config.sh
66}
67
68do_install_append() {
69
70 rm "${D}${bindir}/nslookup"
71 rm "${D}${mandir}/man1/nslookup.1"
72 rmdir "${D}${localstatedir}/run"
73 rmdir --ignore-fail-on-non-empty "${D}${localstatedir}"
74 install -d -o bind "${D}${localstatedir}/cache/bind"
75 install -d "${D}${sysconfdir}/bind"
76 install -d "${D}${sysconfdir}/init.d"
77 install -m 644 ${S}/conf/* "${D}${sysconfdir}/bind/"
78 install -m 755 "${S}/init.d" "${D}${sysconfdir}/init.d/bind"
79 if ${@bb.utils.contains('PACKAGECONFIG', 'python3', 'true', 'false', d)}; then
80 sed -i -e '1s,#!.*python3,#! /usr/bin/python3,' \
81 ${D}${sbindir}/dnssec-coverage \
82 ${D}${sbindir}/dnssec-checkds \
83 ${D}${sbindir}/dnssec-keymgr
84 fi
85
86 # Install systemd related files
87 install -d ${D}${sbindir}
88 install -m 755 ${WORKDIR}/generate-rndc-key.sh ${D}${sbindir}
89 install -d ${D}${systemd_unitdir}/system
90 install -m 0644 ${WORKDIR}/named.service ${D}${systemd_unitdir}/system
91 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \
92 -e 's,@SBINDIR@,${sbindir},g' \
93 ${D}${systemd_unitdir}/system/named.service
94
95 install -d ${D}${sysconfdir}/default
96 install -m 0644 ${WORKDIR}/bind9 ${D}${sysconfdir}/default
97
98 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
99 install -d ${D}${sysconfdir}/tmpfiles.d
100 echo "d /run/named 0755 bind bind - -" > ${D}${sysconfdir}/tmpfiles.d/bind.conf
101 fi
102}
103
104CONFFILES_${PN} = " \
105 ${sysconfdir}/bind/named.conf \
106 ${sysconfdir}/bind/named.conf.local \
107 ${sysconfdir}/bind/named.conf.options \
108 ${sysconfdir}/bind/db.0 \
109 ${sysconfdir}/bind/db.127 \
110 ${sysconfdir}/bind/db.empty \
111 ${sysconfdir}/bind/db.local \
112 ${sysconfdir}/bind/db.root \
113 "
114
115PACKAGE_BEFORE_PN += "${PN}-utils"
116FILES_${PN}-utils = "${bindir}/host ${bindir}/dig ${bindir}/mdig"
117FILES_${PN}-dev += "${bindir}/isc-config.h"
118FILES_${PN} += "${sbindir}/generate-rndc-key.sh"
119
120PACKAGE_BEFORE_PN += "${PN}-libs"
121FILES_${PN}-libs = "${libdir}/*.so*"
122FILES_${PN}-staticdev += "${libdir}/*.la"
123
124PACKAGE_BEFORE_PN += "${@bb.utils.contains('PACKAGECONFIG', 'python3', 'python3-bind', '', d)}"
125FILES_python3-bind = "${sbindir}/dnssec-coverage ${sbindir}/dnssec-checkds \
126 ${sbindir}/dnssec-keymgr ${PYTHON_SITEPACKAGES_DIR}"
127
128RDEPENDS_${PN} = "bash"
129RDEPENDS_${PN}-utils = "bash"
130RDEPENDS_${PN}-dev = ""
131RDEPENDS_python3-bind = "python3-core python3-ply"