summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/bind/bind_9.10.2-P4.bb
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2015-12-22 09:04:54 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-28 09:25:17 +0000
commitc2e8079e87b184f064b7113da4314f869804f2ca (patch)
tree285034369759c1d0d7ff2fd8d296e9eb4550e75d /meta/recipes-connectivity/bind/bind_9.10.2-P4.bb
parent7204a0f18ec46f6dec4246a46cee64293821474d (diff)
downloadpoky-c2e8079e87b184f064b7113da4314f869804f2ca.tar.gz
bind: 9.10.2-P4 -> 9.10.3-P2
Upgrade bind from 9.10.2-P4 to 9.10.3-P2. * update context of 0001-build-use-pkg-config-to-find-libxml2.patch * add PACKAGECONFIGs readline and libedit. They provide same library, so should not be set at same time. (From OE-Core rev: b49751e7febd262b754043e4e523e6690bfbbfaa) Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/bind/bind_9.10.2-P4.bb')
-rw-r--r--meta/recipes-connectivity/bind/bind_9.10.2-P4.bb103
1 files changed, 0 insertions, 103 deletions
diff --git a/meta/recipes-connectivity/bind/bind_9.10.2-P4.bb b/meta/recipes-connectivity/bind/bind_9.10.2-P4.bb
deleted file mode 100644
index 1e1e7262fe..0000000000
--- a/meta/recipes-connectivity/bind/bind_9.10.2-P4.bb
+++ /dev/null
@@ -1,103 +0,0 @@
1SUMMARY = "ISC Internet Domain Name Server"
2HOMEPAGE = "http://www.isc.org/sw/bind/"
3SECTION = "console/network"
4
5LICENSE = "ISC & BSD"
6LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=0a95f52a0ab6c5f52dedc9a45e7abb3f"
7
8DEPENDS = "openssl libcap"
9
10SRC_URI = "ftp://ftp.isc.org/isc/bind9/${PV}/${BPN}-${PV}.tar.gz \
11 file://conf.patch \
12 file://make-etc-initd-bind-stop-work.patch \
13 file://mips1-not-support-opcode.diff \
14 file://dont-test-on-host.patch \
15 file://generate-rndc-key.sh \
16 file://named.service \
17 file://bind9 \
18 file://init.d-add-support-for-read-only-rootfs.patch \
19 file://bind-confgen-build-unix.o-once.patch \
20 file://0001-build-use-pkg-config-to-find-libxml2.patch \
21 file://bind-ensure-searching-for-json-headers-searches-sysr.patch \
22 file://0001-gen.c-extend-DIRNAMESIZE-from-256-to-512.patch \
23 file://0001-lib-dns-gen.c-fix-too-long-error.patch \
24 "
25
26SRC_URI[md5sum] = "8b1f5064837756c938eadc1537dec5c7"
27SRC_URI[sha256sum] = "c00b21ec1def212957f28efe9d10aac52d6ec515e84fbf2c42143f5d71429cb8"
28
29ENABLE_IPV6 = "--enable-ipv6=${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'yes', 'no', d)}"
30EXTRA_OECONF = " ${ENABLE_IPV6} --with-randomdev=/dev/random --disable-threads \
31 --disable-devpoll --disable-epoll --with-gost=no \
32 --with-gssapi=no --with-ecdsa=yes \
33 --sysconfdir=${sysconfdir}/bind \
34 --with-openssl=${STAGING_LIBDIR}/.. \
35 "
36inherit autotools update-rc.d systemd useradd pkgconfig
37
38PACKAGECONFIG ?= ""
39PACKAGECONFIG[httpstats] = "--with-libxml2,--without-libxml2,libxml2"
40
41USERADD_PACKAGES = "${PN}"
42USERADD_PARAM_${PN} = "--system --home /var/cache/bind --no-create-home \
43 --user-group bind"
44
45INITSCRIPT_NAME = "bind"
46INITSCRIPT_PARAMS = "defaults"
47
48SYSTEMD_SERVICE_${PN} = "named.service"
49
50PARALLEL_MAKE = ""
51
52RDEPENDS_${PN} = "python-core"
53RDEPENDS_${PN}-dev = ""
54
55PACKAGE_BEFORE_PN += "${PN}-utils"
56FILES_${PN}-utils = "${bindir}/host ${bindir}/dig"
57FILES_${PN}-dev += "${bindir}/isc-config.h"
58FILES_${PN} += "${sbindir}/generate-rndc-key.sh"
59
60do_install_prepend() {
61 # clean host path in isc-config.sh before the hardlink created
62 # by "make install":
63 # bind9-config -> isc-config.sh
64 sed -i -e "s,${STAGING_LIBDIR},${libdir}," ${B}/isc-config.sh
65}
66
67do_install_append() {
68 rm "${D}${bindir}/nslookup"
69 rm "${D}${mandir}/man1/nslookup.1"
70 rmdir "${D}${localstatedir}/run"
71 rmdir --ignore-fail-on-non-empty "${D}${localstatedir}"
72 install -d "${D}${localstatedir}/cache/bind"
73 install -d "${D}${sysconfdir}/bind"
74 install -d "${D}${sysconfdir}/init.d"
75 install -m 644 ${S}/conf/* "${D}${sysconfdir}/bind/"
76 install -m 755 "${S}/init.d" "${D}${sysconfdir}/init.d/bind"
77 sed -i -e '1s,#!.*python,#! /usr/bin/env python,' ${D}${sbindir}/dnssec-coverage ${D}${sbindir}/dnssec-checkds
78
79 # Install systemd related files
80 install -d ${D}${localstatedir}/cache/bind
81 install -d ${D}${sbindir}
82 install -m 755 ${WORKDIR}/generate-rndc-key.sh ${D}${sbindir}
83 install -d ${D}${systemd_unitdir}/system
84 install -m 0644 ${WORKDIR}/named.service ${D}${systemd_unitdir}/system
85 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \
86 -e 's,@SBINDIR@,${sbindir},g' \
87 ${D}${systemd_unitdir}/system/named.service
88
89 install -d ${D}${sysconfdir}/default
90 install -m 0644 ${WORKDIR}/bind9 ${D}${sysconfdir}/default
91}
92
93CONFFILES_${PN} = " \
94 ${sysconfdir}/bind/named.conf \
95 ${sysconfdir}/bind/named.conf.local \
96 ${sysconfdir}/bind/named.conf.options \
97 ${sysconfdir}/bind/db.0 \
98 ${sysconfdir}/bind/db.127 \
99 ${sysconfdir}/bind/db.empty \
100 ${sysconfdir}/bind/db.local \
101 ${sysconfdir}/bind/db.root \
102 "
103