summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/avahi/avahi_0.7.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-05-05 15:01:13 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-05-07 12:15:59 +0100
commitaf24c40ca46eff0390408f7b4e442ec9bdcd0c1e (patch)
tree2a03c7a614fb687287c14cdcc807d9c0c591af14 /meta/recipes-connectivity/avahi/avahi_0.7.bb
parentcca4eebd030c3d568a28b33c7adc17681a1866bd (diff)
downloadpoky-af24c40ca46eff0390408f7b4e442ec9bdcd0c1e.tar.gz
avahi: update to 0.8
(From OE-Core rev: 520cb26ac248994a88f161b6ad92211ffcb93d9b) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/avahi/avahi_0.7.bb')
-rw-r--r--meta/recipes-connectivity/avahi/avahi_0.7.bb183
1 files changed, 0 insertions, 183 deletions
diff --git a/meta/recipes-connectivity/avahi/avahi_0.7.bb b/meta/recipes-connectivity/avahi/avahi_0.7.bb
deleted file mode 100644
index b25cffa3cd..0000000000
--- a/meta/recipes-connectivity/avahi/avahi_0.7.bb
+++ /dev/null
@@ -1,183 +0,0 @@
1SUMMARY = "Avahi IPv4LL network address configuration daemon"
2DESCRIPTION = 'Avahi is a fully LGPL framework for Multicast DNS Service Discovery. It \
3allows programs to publish and discover services and hosts running on a local network \
4with no specific configuration. This tool implements IPv4LL, "Dynamic Configuration of \
5IPv4 Link-Local Addresses" (IETF RFC3927), a protocol for automatic IP address \
6configuration from the link-local 169.254.0.0/16 range without the need for a central \
7server.'
8AUTHOR = "Lennart Poettering <lennart@poettering.net>"
9HOMEPAGE = "http://avahi.org"
10BUGTRACKER = "https://github.com/lathiat/avahi/issues"
11SECTION = "network"
12
13# major part is under LGPLv2.1+, but several .dtd, .xsl, initscripts and
14# python scripts are under GPLv2+
15LICENSE = "GPLv2+ & LGPLv2.1+"
16LIC_FILES_CHKSUM = "file://LICENSE;md5=2d5025d4aa3495befef8f17206a5b0a1 \
17 file://avahi-common/address.h;endline=25;md5=b1d1d2cda1c07eb848ea7d6215712d9d \
18 file://avahi-core/dns.h;endline=23;md5=6fe82590b81aa0ddea5095b548e2fdcb \
19 file://avahi-daemon/main.c;endline=21;md5=9ee77368c5407af77caaef1b07285969 \
20 file://avahi-client/client.h;endline=23;md5=f4ac741a25c4f434039ba3e18c8674cf"
21
22SRC_URI = "https://github.com/lathiat/avahi/releases/download/v${PV}/avahi-${PV}.tar.gz \
23 file://fix-CVE-2017-6519.patch \
24 "
25
26UPSTREAM_CHECK_URI = "https://github.com/lathiat/avahi/releases/"
27SRC_URI[md5sum] = "d76c59d0882ac6c256d70a2a585362a6"
28SRC_URI[sha256sum] = "57a99b5dfe7fdae794e3d1ee7a62973a368e91e414bd0dfa5d84434de5b14804"
29
30DEPENDS = "expat libcap libdaemon glib-2.0 intltool-native"
31
32# For gtk related PACKAGECONFIGs: gtk, gtk3
33AVAHI_GTK ?= "gtk3"
34
35PACKAGECONFIG ??= "dbus ${AVAHI_GTK}"
36PACKAGECONFIG[dbus] = "--enable-dbus,--disable-dbus,dbus"
37PACKAGECONFIG[gtk] = "--enable-gtk,--disable-gtk,gtk+"
38PACKAGECONFIG[gtk3] = "--enable-gtk3,--disable-gtk3,gtk+3"
39PACKAGECONFIG[libdns_sd] = "--enable-compat-libdns_sd --enable-dbus,,dbus"
40
41inherit autotools pkgconfig gettext gobject-introspection
42
43EXTRA_OECONF = "--with-avahi-priv-access-group=adm \
44 --disable-stack-protector \
45 --disable-gdbm \
46 --disable-mono \
47 --disable-monodoc \
48 --disable-qt3 \
49 --disable-qt4 \
50 --disable-python \
51 --disable-doxygen-doc \
52 --enable-manpages \
53 ${EXTRA_OECONF_SYSVINIT} \
54 ${EXTRA_OECONF_SYSTEMD} \
55 "
56
57# The distro choice determines what init scripts are installed
58EXTRA_OECONF_SYSVINIT = "${@bb.utils.contains('DISTRO_FEATURES','sysvinit','--with-distro=debian','--with-distro=none',d)}"
59EXTRA_OECONF_SYSTEMD = "${@bb.utils.contains('DISTRO_FEATURES','systemd','--with-systemdsystemunitdir=${systemd_unitdir}/system/','--without-systemdsystemunitdir',d)}"
60
61do_configure_prepend() {
62 sed 's:AM_CHECK_PYMOD:echo "no pymod" #AM_CHECK_PYMOD:g' -i ${S}/configure.ac
63
64 # This m4 file will get in the way of our introspection.m4 with special cross-compilation fixes
65 rm "${S}/common/introspection.m4" || true
66}
67
68do_compile_prepend() {
69 export GIR_EXTRA_LIBS_PATH="${B}/avahi-gobject/.libs:${B}/avahi-common/.libs:${B}/avahi-client/.libs:${B}/avahi-glib/.libs"
70}
71
72RRECOMMENDS_${PN}_append_libc-glibc = " libnss-mdns"
73
74do_install() {
75 autotools_do_install
76 rm -rf ${D}/run
77 rm -rf ${D}${datadir}/dbus-1/interfaces
78 test -d ${D}${datadir}/dbus-1 && rmdir --ignore-fail-on-non-empty ${D}${datadir}/dbus-1
79 rm -rf ${D}${libdir}/avahi
80}
81
82PACKAGES =+ "${@bb.utils.contains("PACKAGECONFIG", "libdns_sd", "libavahi-compat-libdnssd", "", d)}"
83
84FILES_libavahi-compat-libdnssd = "${libdir}/libdns_sd.so.*"
85
86RPROVIDES_libavahi-compat-libdnssd = "libdns-sd"
87
88SRC_URI += "file://00avahi-autoipd \
89 file://99avahi-autoipd \
90 file://initscript.patch \
91 file://0001-Fix-opening-etc-resolv.conf-error.patch \
92 "
93
94inherit update-rc.d systemd useradd
95
96PACKAGES =+ "libavahi-gobject avahi-daemon libavahi-common libavahi-core libavahi-client avahi-dnsconfd libavahi-glib avahi-autoipd avahi-utils avahi-discover avahi-ui"
97
98FILES_avahi-ui = "${libdir}/libavahi-ui*.so.*"
99FILES_avahi-discover = "${datadir}/applications/avahi-discover.desktop \
100 ${datadir}/avahi/interfaces/avahi-discover.ui \
101 ${bindir}/avahi-discover-standalone \
102 "
103
104LICENSE_libavahi-gobject = "LGPLv2.1+"
105LICENSE_avahi-daemon = "LGPLv2.1+"
106LICENSE_libavahi-common = "LGPLv2.1+"
107LICENSE_libavahi-core = "LGPLv2.1+"
108LICENSE_avahi-client = "LGPLv2.1+"
109LICENSE_avahi-dnsconfd = "LGPLv2.1+"
110LICENSE_libavahi-glib = "LGPLv2.1+"
111LICENSE_avahi-autoipd = "LGPLv2.1+"
112LICENSE_avahi-utils = "LGPLv2.1+"
113
114# As avahi doesn't put any files into PN, clear the files list to avoid problems
115# if extra libraries appear.
116FILES_${PN} = ""
117FILES_avahi-autoipd = "${sbindir}/avahi-autoipd \
118 ${sysconfdir}/avahi/avahi-autoipd.action \
119 ${sysconfdir}/dhcp/*/avahi-autoipd \
120 ${sysconfdir}/udhcpc.d/00avahi-autoipd \
121 ${sysconfdir}/udhcpc.d/99avahi-autoipd"
122FILES_libavahi-common = "${libdir}/libavahi-common.so.*"
123FILES_libavahi-core = "${libdir}/libavahi-core.so.* ${libdir}/girepository-1.0/AvahiCore*.typelib"
124FILES_avahi-daemon = "${sbindir}/avahi-daemon \
125 ${sysconfdir}/avahi/avahi-daemon.conf \
126 ${sysconfdir}/avahi/hosts \
127 ${sysconfdir}/avahi/services \
128 ${sysconfdir}/dbus-1 \
129 ${sysconfdir}/init.d/avahi-daemon \
130 ${datadir}/avahi/introspection/*.introspect \
131 ${datadir}/avahi/avahi-service.dtd \
132 ${datadir}/avahi/service-types \
133 ${datadir}/dbus-1/system-services"
134FILES_libavahi-client = "${libdir}/libavahi-client.so.*"
135FILES_avahi-dnsconfd = "${sbindir}/avahi-dnsconfd \
136 ${sysconfdir}/avahi/avahi-dnsconfd.action \
137 ${sysconfdir}/init.d/avahi-dnsconfd"
138FILES_libavahi-glib = "${libdir}/libavahi-glib.so.*"
139FILES_libavahi-gobject = "${libdir}/libavahi-gobject.so.* ${libdir}/girepository-1.0/Avahi*.typelib"
140FILES_avahi-utils = "${bindir}/avahi-* ${bindir}/b* ${datadir}/applications/b*"
141
142RDEPENDS_${PN}-dev = "avahi-daemon (= ${EXTENDPKGV}) libavahi-core (= ${EXTENDPKGV})"
143RDEPENDS_${PN}-dev += "${@["", " libavahi-client (= ${EXTENDPKGV})"][bb.utils.contains('PACKAGECONFIG', 'dbus', 1, 0, d)]}"
144
145RRECOMMENDS_avahi-daemon_append_libc-glibc = " libnss-mdns"
146
147CONFFILES_avahi-daemon = "${sysconfdir}/avahi/avahi-daemon.conf"
148
149USERADD_PACKAGES = "avahi-daemon avahi-autoipd"
150USERADD_PARAM_avahi-daemon = "--system --home /run/avahi-daemon \
151 --no-create-home --shell /bin/false \
152 --user-group avahi"
153
154USERADD_PARAM_avahi-autoipd = "--system --home /run/avahi-autoipd \
155 --no-create-home --shell /bin/false \
156 --user-group \
157 -c \"Avahi autoip daemon\" \
158 avahi-autoipd"
159
160INITSCRIPT_PACKAGES = "avahi-daemon avahi-dnsconfd"
161INITSCRIPT_NAME_avahi-daemon = "avahi-daemon"
162INITSCRIPT_PARAMS_avahi-daemon = "defaults 21 19"
163INITSCRIPT_NAME_avahi-dnsconfd = "avahi-dnsconfd"
164INITSCRIPT_PARAMS_avahi-dnsconfd = "defaults 22 19"
165
166SYSTEMD_PACKAGES = "${PN}-daemon ${PN}-dnsconfd"
167SYSTEMD_SERVICE_${PN}-daemon = "avahi-daemon.service"
168SYSTEMD_SERVICE_${PN}-dnsconfd = "avahi-dnsconfd.service"
169
170do_install_append() {
171 install -d ${D}${sysconfdir}/udhcpc.d
172 install ${WORKDIR}/00avahi-autoipd ${D}${sysconfdir}/udhcpc.d
173 install ${WORKDIR}/99avahi-autoipd ${D}${sysconfdir}/udhcpc.d
174}
175
176# At the time the postinst runs, dbus might not be setup so only restart if running
177# Don't exit early, because update-rc.d needs to run subsequently.
178pkg_postinst_avahi-daemon () {
179if [ -z "$D" ]; then
180 killall -q -HUP dbus-daemon || true
181fi
182}
183