summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/v86d/v86d_0.1.10.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-10-11 10:37:33 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-10-14 13:18:16 +0100
commit87eabec9c949d545cf786ade09437b7e7ea17737 (patch)
treeaf6d92fd1be0b32ee61e1fc48a2698f186a5f143 /meta/recipes-bsp/v86d/v86d_0.1.10.bb
parente4953031de8f47953de6715bd0921da1a8e470a1 (diff)
downloadpoky-87eabec9c949d545cf786ade09437b7e7ea17737.tar.gz
v86d: update to 0.1.10
(From OE-Core rev: 933eb8224c6152fb574f97ddc36511026d512d75) Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/v86d/v86d_0.1.10.bb')
-rw-r--r--meta/recipes-bsp/v86d/v86d_0.1.10.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-bsp/v86d/v86d_0.1.10.bb b/meta/recipes-bsp/v86d/v86d_0.1.10.bb
new file mode 100644
index 0000000000..70db6adb04
--- /dev/null
+++ b/meta/recipes-bsp/v86d/v86d_0.1.10.bb
@@ -0,0 +1,40 @@
1DESCRIPTION = "User support binary for the uvesafb kernel module"
2HOMEPAGE = "http://dev.gentoo.org/~spock/projects/uvesafb/"
3
4# the copyright info is at the bottom of README, expect break
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://README;md5=94ac1971e4f2309dc322d598e7b1f7dd"
7
8DEPENDS = "virtual/kernel"
9RRECOMMENDS_${PN} = "kernel-module-uvesafb"
10PR = "r0"
11
12SRC_URI = "http://dev.gentoo.org/~spock/projects/uvesafb/archive/v86d-${PV}.tar.bz2 \
13 file://fbsetup"
14
15SRC_URI[md5sum] = "51c792ba7b874ad8c43f0d3da4cfabe0"
16SRC_URI[sha256sum] = "634964ae18ef68c8493add2ce150e3b4502badeb0d9194b4bd81241d25e6735c"
17
18PACKAGE_ARCH = "${MACHINE_ARCH}"
19COMPATIBLE_MACHINE = "(qemux86)"
20
21INITSCRIPT_NAME = "fbsetup"
22INITSCRIPT_PARAMS = "start 0 S ."
23
24do_configure () {
25 ./configure --with-x86emu
26}
27
28do_compile () {
29 KDIR="${STAGING_KERNEL_DIR}" make
30}
31
32do_install () {
33 install -d ${D}${base_sbindir}
34 install v86d ${D}${base_sbindir}/
35
36 install -d ${D}${sysconfdir}/init.d/
37 install -m 0755 ${WORKDIR}/fbsetup ${D}${sysconfdir}/init.d/fbsetup
38}
39
40inherit update-rc.d