summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot_2011.06.bb
diff options
context:
space:
mode:
authorMatthew McClintock <msm@freescale.com>2012-07-26 11:21:43 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-28 09:20:52 +0100
commita35f60a829b4c4ebd7fdfee560640216ecf7b368 (patch)
treee0935e946efadf72090d1189cc9c59f0ae7c1e24 /meta/recipes-bsp/u-boot/u-boot_2011.06.bb
parent76df4493996c5b0f5c372e527a57b4e9ffe6b797 (diff)
downloadpoky-a35f60a829b4c4ebd7fdfee560640216ecf7b368.tar.gz
u-boot.inc: update linker arguments to pass --sysroot arg
If we are building from sstate-cache it's possible to be building from another folder on another machine, therefore the linker requires that a proper --sysroot is passed too it so it can find things like libgcc.a and avoid errors such as: | arm-poky-linux-gnueabi-gcc -g -O2 -fno-common -ffixed-r8 -msoft-float -D__KERNEL__ -DCONFIG_SYS_TEXT_BASE=0x80008000 -I/local/yocto/upstream/label/ubuntu1204-64b/machine/beagleboard/poky/edison/tmp/work/beagleboard-poky-linux-gnueabi/u-boot-v2011.06+git5+b1af6f532e0d348b153d5c148369229d24af361a-r0/git/include -fno-builtin -ffreestanding -nostdinc -isystem /local/yocto/upstream/label/ubuntu1204-64b/machine/beagleboard/poky/edison/tmp/sysroots/x86_64-linux/usr/bin/armv7a-vfp-neon-poky-linux-gnueabi/../../lib/armv7a-vfp-neon-poky-linux-gnueabi/gcc/arm-poky-linux-gnueabi/4.6.3/include -pipe -DCONFIG_ARM -D__ARM__ -marm -mabi=aapcs-linux -mno-thumb-interwork -march=armv5 -Wall -Wstrict-prototypes -fno-stack-protector -fno-toplevel-reorder -o hello_world.o hello_world.c -c | arm-poky-linux-gnueabi-gcc -g -O2 -fno-common -ffixed-r8 -msoft-float -D__KERNEL__ -DCONFIG_SYS_TEXT_BASE=0x80008000 -I/local/yocto/upstream/label/ubuntu1204-64b/machine/beagleboard/poky/edison/tmp/work/beagleboard-poky-linux-gnueabi/u-boot-v2011.06+git5+b1af6f532e0d348b153d5c148369229d24af361a-r0/git/include -fno-builtin -ffreestanding -nostdinc -isystem /local/yocto/upstream/label/ubuntu1204-64b/machine/beagleboard/poky/edison/tmp/sysroots/x86_64-linux/usr/bin/armv7a-vfp-neon-poky-linux-gnueabi/../../lib/armv7a-vfp-neon-poky-linux-gnueabi/gcc/arm-poky-linux-gnueabi/4.6.3/include -pipe -DCONFIG_ARM -D__ARM__ -marm -mabi=aapcs-linux -mno-thumb-interwork -march=armv5 -Wall -Wstrict-prototypes -fno-stack-protector -fno-toplevel-reorder -o stubs.o stubs.c -c | arm-poky-linux-gnueabi-ld -r -o libstubs.o stubs.o | arm-poky-linux-gnueabi-ld -g -Ttext 0x80300000 \ | -o hello_world -e hello_world hello_world.o libstubs.o \ | -L. -lgcc | arm-poky-linux-gnueabi-ld: cannot find -lgcc | make[1]: *** [hello_world] Error 1 (From OE-Core rev: 923eb657f24a1feaa93172eda8f87252e86bfea2) Signed-off-by: Matthew McClintock <msm@freescale.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot_2011.06.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot_2011.06.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot_2011.06.bb b/meta/recipes-bsp/u-boot/u-boot_2011.06.bb
index da61852107..9654795744 100644
--- a/meta/recipes-bsp/u-boot/u-boot_2011.06.bb
+++ b/meta/recipes-bsp/u-boot/u-boot_2011.06.bb
@@ -15,7 +15,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb \
15SRCREV = "b1af6f532e0d348b153d5c148369229d24af361a" 15SRCREV = "b1af6f532e0d348b153d5c148369229d24af361a"
16 16
17PV = "v2011.06+git${SRCPV}" 17PV = "v2011.06+git${SRCPV}"
18PR = "r1" 18PR = "r2"
19 19
20SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git" 20SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"
21 21