summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-mkimage_2018.05.bb
diff options
context:
space:
mode:
authorMarek Vasut <marex@denx.de>2018-05-16 22:14:15 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-29 21:07:12 +0100
commitb3588b0ca9889d83e09ecc50eefd3727011d5f79 (patch)
tree96a1cd261936d8a4cb9cfbbc3d2a3d3590f6248a /meta/recipes-bsp/u-boot/u-boot-mkimage_2018.05.bb
parent074b2e8c2f8cef4e75e0c36811655d71aad50c53 (diff)
downloadpoky-b3588b0ca9889d83e09ecc50eefd3727011d5f79.tar.gz
u-boot: Upgrade to 2018.05 release
This upgrades the U-Boot from 2018.03 to 2018.05 release. (From OE-Core rev: 8e8cea4569ffa8ea81b7e99f98f9dab203614d22) Signed-off-by: Marek Vasut <marex@denx.de> Cc: Otavio Salvador <otavio@ossystems.com.br> Cc: Richard Purdie <richard.purdie@linuxfoundation.org> Cc: Ross Burton <ross.burton@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-mkimage_2018.05.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-mkimage_2018.05.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2018.05.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2018.05.bb
new file mode 100644
index 0000000000..1c008be96e
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-mkimage_2018.05.bb
@@ -0,0 +1,29 @@
1require u-boot-common_${PV}.inc
2
3SUMMARY = "U-Boot bootloader image creation tool"
4DEPENDS = "openssl"
5
6EXTRA_OEMAKE_class-target = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1'
7EXTRA_OEMAKE_class-native = 'CC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1'
8EXTRA_OEMAKE_class-nativesdk = 'CROSS_COMPILE="${HOST_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1'
9
10do_compile () {
11 oe_runmake sandbox_defconfig
12
13 # Disable CONFIG_CMD_LICENSE, license.h is not used by tools and
14 # generating it requires bin2header tool, which for target build
15 # is built with target tools and thus cannot be executed on host.
16 sed -i "s/CONFIG_CMD_LICENSE=.*/# CONFIG_CMD_LICENSE is not set/" .config
17
18 oe_runmake cross_tools NO_SDL=1
19}
20
21do_install () {
22 install -d ${D}${bindir}
23 install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
24 ln -sf uboot-mkimage ${D}${bindir}/mkimage
25}
26
27RDEPENDS_${PN} += "dtc"
28
29BBCLASSEXTEND = "native nativesdk"