summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-mkimage_2016.09.01.bb
diff options
context:
space:
mode:
authorMarek Vasut <marex@denx.de>2016-09-04 12:50:01 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-12-08 10:31:30 +0000
commit49ec5bae8a2f46dfe71c9b452637d4ffcbec3a93 (patch)
tree9b352235326230de41ceafd2131ace2a6a205fd2 /meta/recipes-bsp/u-boot/u-boot-mkimage_2016.09.01.bb
parentf46e54c7c9069f8d84483e1ba4cadaa4300c3e18 (diff)
downloadpoky-49ec5bae8a2f46dfe71c9b452637d4ffcbec3a93.tar.gz
u-boot: Update to 2016.09.01 release
Upgrade U-Boot to the latest version. (From OE-Core rev: 7f5f8bec25bc05acb7b6584e41e1067107b216dc) Signed-off-by: Marek Vasut <marex@denx.de> Cc: Richard Purdie <richard.purdie@linuxfoundation.org> Cc: Denys Dmytriyenko <denis@denix.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-mkimage_2016.09.01.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-mkimage_2016.09.01.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2016.09.01.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2016.09.01.bb
new file mode 100644
index 0000000000..5025961f91
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-mkimage_2016.09.01.bb
@@ -0,0 +1,19 @@
1require u-boot-common_${PV}.inc
2
3SUMMARY = "U-Boot bootloader image creation tool"
4DEPENDS = "openssl"
5
6EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" STRIP=true V=1'
7
8do_compile () {
9 oe_runmake sandbox_defconfig
10 oe_runmake cross_tools NO_SDL=1
11}
12
13do_install () {
14 install -d ${D}${bindir}
15 install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
16 ln -sf uboot-mkimage ${D}${bindir}/mkimage
17}
18
19BBCLASSEXTEND = "native nativesdk"