summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-mkimage_2016.01.bb
diff options
context:
space:
mode:
authorMarek Vasut <marex@denx.de>2016-01-14 04:17:12 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-18 11:47:04 +0000
commit5abb69126ce1c0ebcde16271fa5c732e5a1c946d (patch)
treecf20e8477af0dbe34a8799852cacc906638a498a /meta/recipes-bsp/u-boot/u-boot-mkimage_2016.01.bb
parente9280d13a88701500ffdcb9ba51abeb5c322ca0d (diff)
downloadpoky-5abb69126ce1c0ebcde16271fa5c732e5a1c946d.tar.gz
u-boot: Update to 2016.01 release
Upgrade U-Boot to latest version and drop upstreamed patches. (From OE-Core rev: fd0a8923638217dfa0a61ee63f2013229429808c) Signed-off-by: Marek Vasut <marex@denx.de> Cc: Otavio Salvador <otavio@ossystems.com.br> Cc: Ross Burton <ross.burton@intel.com> Cc: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-mkimage_2016.01.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-mkimage_2016.01.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2016.01.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2016.01.bb
new file mode 100644
index 0000000000..5d163a8af4
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-mkimage_2016.01.bb
@@ -0,0 +1,32 @@
1SUMMARY = "U-Boot bootloader image creation tool"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://Licenses/README;md5=0507cd7da8e7ad6d6701926ec9b84c95"
4SECTION = "bootloader"
5
6DEPENDS = "openssl"
7
8# This revision corresponds to the tag "v2016.01"
9# We use the revision in order to avoid having to fetch it from the
10# repo during parse
11SRCREV = "fa85e826c16b9ce1ad302a57e9c4b24db0d8b930"
12
13PV = "v2016.01+git${SRCPV}"
14
15SRC_URI = "git://git.denx.de/u-boot.git;branch=master"
16
17S = "${WORKDIR}/git"
18
19EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" STRIP=true V=1'
20
21do_compile () {
22 oe_runmake sandbox_defconfig
23 oe_runmake cross_tools NO_SDL=1
24}
25
26do_install () {
27 install -d ${D}${bindir}
28 install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
29 ln -sf uboot-mkimage ${D}${bindir}/mkimage
30}
31
32BBCLASSEXTEND = "native nativesdk"