summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-mkimage_2015.10.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-11-10 09:01:42 -0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-11-25 07:50:31 +0000
commita59d019372362da126f3fb4570723081d0f2359a (patch)
tree2cdadc8cf20867e0fb2f1cbd04b5d77cba404dcf /meta/recipes-bsp/u-boot/u-boot-mkimage_2015.10.bb
parente67c5b0ccf65eba3fb1c4fb177931baa24d1767a (diff)
downloadpoky-a59d019372362da126f3fb4570723081d0f2359a.tar.gz
u-boot: Update to 2015.10 release
The U-Boot 2015.10 has been released at October 20th 2015. This also removes the GCC workaround, for the inline behavior, as this version properlu supports the GCC 5.2 as compiler. (From OE-Core rev: aebd1a87bbf960e69301bd29137aabb5dfab05fc) Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-mkimage_2015.10.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-mkimage_2015.10.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2015.10.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2015.10.bb
new file mode 100644
index 0000000000..301b6e2bec
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-mkimage_2015.10.bb
@@ -0,0 +1,32 @@
1SUMMARY = "U-Boot bootloader image creation tool"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://Licenses/README;md5=0507cd7da8e7ad6d6701926ec9b84c95"
4SECTION = "bootloader"
5
6DEPENDS = "openssl"
7
8# This revision corresponds to the tag "v2015.10"
9# We use the revision in order to avoid having to fetch it from the
10# repo during parse
11SRCREV = "5ec0003b19cbdf06ccd6941237cbc0d1c3468e2d"
12
13PV = "v2015.10+git${SRCPV}"
14
15SRC_URI = "git://git.denx.de/u-boot.git;branch=master"
16
17S = "${WORKDIR}/git"
18
19EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" STRIP=true V=1'
20
21do_compile () {
22 oe_runmake sandbox_defconfig
23 oe_runmake cross_tools NO_SDL=1
24}
25
26do_install () {
27 install -d ${D}${bindir}
28 install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
29 ln -sf uboot-mkimage ${D}${bindir}/mkimage
30}
31
32BBCLASSEXTEND = "native nativesdk"