summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-mkimage_2015.07.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-07-20 11:10:30 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-23 08:48:39 +0100
commit51b590db259375aa6259845862ca9020ed264b05 (patch)
tree21f33b36e23c47114e9d7b956f61493fc7966655 /meta/recipes-bsp/u-boot/u-boot-mkimage_2015.07.bb
parent99b082d0b61cecec1f4e12b3c5d54080f27281e4 (diff)
downloadpoky-51b590db259375aa6259845862ca9020ed264b05.tar.gz
u-boot: Upgrade to 2015.07 release
This upgrades the U-Boot and its related recipes for the 2015.07 release. The following recipes has been upgraded: - u-boot - u-boot-mkimage - u-boot-fw-utils The patches which were applied on top of the 2015.01 release are dropped as those are not needed in this release. The license checksum update was due minimal changes in the text, those have no impact in the license terms. (From OE-Core rev: 3157f8995e24f8a70492a261815be3a6fe51dcbd) Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-mkimage_2015.07.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-mkimage_2015.07.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2015.07.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2015.07.bb
new file mode 100644
index 0000000000..ba29bbb922
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-mkimage_2015.07.bb
@@ -0,0 +1,32 @@
1SUMMARY = "U-Boot bootloader image creation tool"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://Licenses/README;md5=0507cd7da8e7ad6d6701926ec9b84c95"
4SECTION = "bootloader"
5
6DEPENDS = "openssl"
7
8# This revision corresponds to the tag "v2015.07"
9# We use the revision in order to avoid having to fetch it from the
10# repo during parse
11SRCREV = "33711bdd4a4dce942fb5ae85a68899a8357bdd94"
12
13PV = "v2015.07+git${SRCPV}"
14
15SRC_URI = "git://git.denx.de/u-boot.git;branch=master"
16
17S = "${WORKDIR}/git"
18
19EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" STRIP=true V=1'
20
21do_compile () {
22 oe_runmake sandbox_defconfig
23 oe_runmake cross_tools NO_SDL=1
24}
25
26do_install () {
27 install -d ${D}${bindir}
28 install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
29 ln -sf uboot-mkimage ${D}${bindir}/mkimage
30}
31
32BBCLASSEXTEND = "native nativesdk"