summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-mkimage_2015.01.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2015-02-10 13:56:00 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-02-14 08:40:59 +0000
commit34a4413ef7a873e8bfed4153173cc7050965510b (patch)
treeea24d7359fe1c57f4ddda08b8a0db6e97d19655a /meta/recipes-bsp/u-boot/u-boot-mkimage_2015.01.bb
parent1993237a90fb12de37d9212f900e48ebe67e9f55 (diff)
downloadpoky-34a4413ef7a873e8bfed4153173cc7050965510b.tar.gz
u-boot: update to version 2015.01
(From OE-Core rev: 62052810dbf3ed19697078a48b617bfbdadf2a29) Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-mkimage_2015.01.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-mkimage_2015.01.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2015.01.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2015.01.bb
new file mode 100644
index 0000000000..57989c785f
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-mkimage_2015.01.bb
@@ -0,0 +1,32 @@
1SUMMARY = "U-Boot bootloader image creation tool"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919"
4SECTION = "bootloader"
5
6DEPENDS = "openssl"
7
8# This revision corresponds to the tag "v2015.01"
9# We use the revision in order to avoid having to fetch it from the
10# repo during parse
11SRCREV = "92fa7f53f1f3f03296f8ffb14bdf1baefab83368"
12
13PV = "v2015.01+git${SRCPV}"
14
15SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"
16
17S = "${WORKDIR}/git"
18
19EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" STRIP=true V=1'
20
21do_compile () {
22 oe_runmake sandbox_defconfig
23 oe_runmake cross_tools NO_SDL=1
24}
25
26do_install () {
27 install -d ${D}${bindir}
28 install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
29 ln -sf uboot-mkimage ${D}${bindir}/mkimage
30}
31
32BBCLASSEXTEND = "native nativesdk"