summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2014-09-16 19:10:01 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-11-12 15:38:31 +0000
commit5c23ec681c162636d68b3665cf6aef3af38ab205 (patch)
tree9c0cb0d9be0ee47ba2430e8605ac71f7acdc1ffe /meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb
parent2abfdcfd1c2f8d450f482fbf6922c5d2371d0aef (diff)
downloadpoky-5c23ec681c162636d68b3665cf6aef3af38ab205.tar.gz
u-boot: update to version 2014.07
u-boot doesn't really support building its tools for the target, as they are built with HOSTCC compiler, which is also used to compile fixdep utility that gets executed during the build. Since it might be beneficial to have a target version of mkimage, let's hack it to build fixdep in a separate step. (From OE-Core rev: a8692184d25cb7d8cb3b617e1dfb901fe1b0ca3d) Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb32
1 files changed, 0 insertions, 32 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb
deleted file mode 100644
index 3173b0ac73..0000000000
--- a/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb
+++ /dev/null
@@ -1,32 +0,0 @@
1SUMMARY = "U-Boot bootloader image creation tool"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
4SECTION = "bootloader"
5
6# This revision corresponds to the tag "v2013.07"
7# We use the revision in order to avoid having to fetch it from the
8# repo during parse
9SRCREV = "62c175fbb8a0f9a926c88294ea9f7e88eb898f6c"
10
11PV = "v2013.07+git${SRCPV}"
12
13SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"
14
15S = "${WORKDIR}/git"
16
17EXTRA_OEMAKE = 'HOSTCC="${CC}" HOSTLD="${LD}" HOSTLDFLAGS="${LDFLAGS}" HOSTSTRIP=true'
18
19do_compile () {
20 # Make sure the recompile is OK
21 rm -f ${B}/tools/.depend
22
23 oe_runmake tools
24}
25
26do_install () {
27 install -d ${D}${bindir}
28 install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
29 ln -sf uboot-mkimage ${D}${bindir}/mkimage
30}
31
32BBCLASSEXTEND = "native nativesdk"