summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb
diff options
context:
space:
mode:
authorLaszlo Papp <lpapp-RoXCvvDuEio@public.gmane.org>2013-08-23 10:48:10 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-08-26 16:29:18 +0100
commit355a781662ffcb78a3852f94a231659cafcb1880 (patch)
tree238832073e3536e73d08838055d88ee55ed308b6 /meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb
parentb07d12dacf61d54f3ab37c23eb014e129acaab9a (diff)
downloadpoky-355a781662ffcb78a3852f94a231659cafcb1880.tar.gz
u-boot: update to 2013.07
(From OE-Core rev: b2d6f08ff4f03079973eab76a790bf4555e32236) Signed-off-by: Laszlo Papp <lpapp-RoXCvvDuEio@public.gmane.org> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb
new file mode 100644
index 0000000000..0108e0059f
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "U-boot bootloader mkimage tool"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb \
4 file://README;beginline=1;endline=22;md5=78b195c11cb6ef63e6985140db7d7bab"
5SECTION = "bootloader"
6
7SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2"
8
9SRC_URI[md5sum] = "8445162690052e6afd4b8f87af2bb557"
10SRC_URI[sha256sum] = "2bbd440c1b29928d230604eac372fda5152d3ae23f52b1910c77fc5bf531250b"
11
12S = "${WORKDIR}/u-boot-${PV}"
13
14BBCLASSEXTEND = "native nativesdk"
15
16EXTRA_OEMAKE = 'HOSTCC="${CC}" HOSTLD="${LD}" HOSTLDFLAGS="${LDFLAGS}" HOSTSTRIP=true'
17
18do_compile () {
19 oe_runmake tools
20}
21
22do_install () {
23 install -d ${D}${bindir}
24 install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
25 ln -sf uboot-mkimage ${D}${bindir}/mkimage
26}
27