summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-fw-utils_2016.03.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2016-03-18 15:39:34 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-03-20 23:12:31 +0000
commit13a2a3f90d5cd75c528ffcd19d36686f952acfe6 (patch)
treed44e2b01d68ae1f2bb623399bba0ef1f39b2c3d4 /meta/recipes-bsp/u-boot/u-boot-fw-utils_2016.03.bb
parentecf33963946bb3f1fd63d2d225cd6a92cd0a3678 (diff)
downloadpoky-13a2a3f90d5cd75c528ffcd19d36686f952acfe6.tar.gz
u-boot: Upgrade to 2016.03 release
The 2016.03 release has been announced in March 14th. This incorporates a lot of bug fixes and improvements which are useful for any new embedded development. Along with the upgrade of U-Boot and its related recipes, this patch also drops the AM335x environment fix which has been merged into the release. (From OE-Core rev: 15130f7bad0f0a1894c34bbb34a547722552c69e) Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-fw-utils_2016.03.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-fw-utils_2016.03.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-fw-utils_2016.03.bb b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2016.03.bb
new file mode 100644
index 0000000000..dfda5c1d30
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2016.03.bb
@@ -0,0 +1,49 @@
1SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
4SECTION = "bootloader"
5DEPENDS = "mtd-utils"
6
7# This revision corresponds to the tag "v2016.03"
8# We use the revision in order to avoid having to fetch it from the
9# repo during parse
10SRCREV = "df61a74e6845ec9bdcdd48d2aff5e9c2c6debeaa"
11
12PV = "v2016.03+git${SRCPV}"
13
14SRC_URI = "git://git.denx.de/u-boot.git;branch=master"
15
16S = "${WORKDIR}/git"
17
18INSANE_SKIP_${PN} = "already-stripped"
19EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
20EXTRA_OEMAKE_class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
21
22inherit uboot-config
23
24do_compile () {
25 oe_runmake ${UBOOT_MACHINE}
26 oe_runmake env
27}
28
29do_install () {
30 install -d ${D}${base_sbindir}
31 install -d ${D}${sysconfdir}
32 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
33 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
34 install -m 0644 ${S}/tools/env/fw_env.config ${D}${sysconfdir}/fw_env.config
35}
36
37do_install_class-cross () {
38 install -d ${D}${bindir_cross}
39 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
40 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
41}
42
43SYSROOT_PREPROCESS_FUNCS_class-cross = "uboot_fw_utils_cross"
44uboot_fw_utils_cross() {
45 sysroot_stage_dir ${D}${bindir_cross} ${SYSROOT_DESTDIR}${bindir_cross}
46}
47
48PACKAGE_ARCH = "${MACHINE_ARCH}"
49BBCLASSEXTEND = "cross"